Results 1 to 5 of 5

Thread: ITPS Startup Shutdown Controller Not Working

  1. #1
    Variable Bitrate
    Join Date
    Jun 2003
    Location
    Chicago
    Posts
    384

    ITPS Startup Shutdown Controller Not Working

    I bought the ITPS from MP3Car.com a couple months ago to use solely as a startup/shutdown controller cannot get that to even work properly. The problem I am having is that the ITPS will turn on my computer when ignition is applied. I tested this in the car and on the bench. I connected an oscilloscope to see PWR_ON output (connects to motherboard power jumper) of the ITPS. As you can see from the capture the turn on pulse is only 344nS which is way to short for the motherboard to detect. Has anyone else had similar problems with their ITPS?

    Ch1: Input Voltage to ITPS
    CH2: ITPS Pwr_On Output 1
    CH3: ITPS Pwr_On Output 2
    Ch4: ITPS Ignition input
    Attached Images Attached Images  

  2. #2
    Variable Bitrate
    Join Date
    Jun 2003
    Location
    Chicago
    Posts
    384
    1.10.6.7 Power On Connector
    This connector can be connected to a front panel power switch. The switch must pull the
    SW_ON# pin to ground for at least 50 ms to signal the power supply to switch on or off. (The
    time requirement is due to internal debounce circuitry on the motherboard.) At least two seconds
    must pass before the power supply will recognize another on/off signal.

  3. #3
    Raw Wave
    Join Date
    Jun 2003
    Posts
    1,823
    That dont look right.

    Yup for the motherboard to turn on/off the ITPS should be pulling it to the ground. Have you tried the ITPS without the motherboard at all? to see if the ground-pulling does actually work...you may need to use a 10K pullup resistor to see this working properly.

    Nice scope you got there...what is it?

  4. #4
    Variable Bitrate
    Join Date
    Jun 2003
    Location
    Chicago
    Posts
    384
    Quote Originally Posted by Ricky327
    That dont look right.

    Yup for the motherboard to turn on/off the ITPS should be pulling it to the ground. Have you tried the ITPS without the motherboard at all? to see if the ground-pulling does actually work...you may need to use a 10K pullup resistor to see this working properly.

    Nice scope you got there...what is it?
    The scope capture was taken without the motherboard. It probably does need a pullup reistor if it is an open drain output.

    The scope is a LeCroy Wavepro950

  5. #5
    Raw Wave
    Join Date
    Jun 2003
    Posts
    1,823
    LeCroy Wavepro950 priced at 22,500 USD?

    Do a search on ITPS...Im sure someone did had the same problem as yours before, cant remeber who.

Similar Threads

  1. DSSC startup / shutdown controller available
    By dashpc in forum Power Supplies
    Replies: 0
    Last Post: 04-18-2004, 09:00 PM
  2. PW70a w/o ITPS startup, shutdown, and more!
    By cybermob2 in forum Power Supplies
    Replies: 5
    Last Post: 03-23-2004, 03:25 PM
  3. Startup pulse fix with Jeff Shutdown Controller
    By moahdib in forum Power Supplies
    Replies: 2
    Last Post: 03-03-2004, 11:51 AM
  4. Working BX-24 startup controller
    By droswell in forum Power Supplies
    Replies: 2
    Last Post: 12-18-2003, 05:23 PM
  5. startup shutdown etc.
    By marsjell in forum Power Supplies
    Replies: 6
    Last Post: 06-19-2002, 06:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •