Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25

Thread: Opus Cold Weather Resolution

  1. #11
    Registered User Jeff48's Avatar
    Join Date
    Mar 2004
    Location
    Illinois
    Posts
    27
    OK here's the answer----but only because you have a Mazda though=====Otherwise it would have been

    The cold problem is restricted to the OPUS 90....there is no problem with the 150.




    Quote Originally Posted by Dexter
    Sorry to sound like a newb...but are people with the 150W having any problems? I have a 150W but have yet to get it hooked up and running...

  2. #12
    Constant Bitrate
    Join Date
    Sep 2004
    Location
    Springfield, IL
    Posts
    207
    has anyone sent their opus back to opus w/out the receipt or proof of purchase??

  3. #13
    Constant Bitrate
    Join Date
    Sep 2003
    Location
    Boston, MA
    Posts
    120
    Sent mine last week on Tuesday. Got word today that it is fixed and was shipped back to me. I was told that the 'cold weather' mystery has been solved and I shouldn't experience anymore problems.

    As for sending it without proof of purchase, since they are the only ones that make them...
    99 VW GTI VR6 SC
    -The GTI-PC-

  4. #14
    Constant Bitrate
    Join Date
    Sep 2004
    Location
    Springfield, IL
    Posts
    207
    I was just going by what I read on their returns page, and it says that any unit that is sent it it need to have a proof of purchase b/c the warranty is only good to the original purchaser. Just wondering if anyone had recieved any flack or was denied a repair b/c of no receipt...

  5. #15
    Constant Bitrate
    Join Date
    Sep 2003
    Location
    Boston, MA
    Posts
    120
    Hmm I see. Well you have to call them first anyway to setup a RMA number/account so I guess you could ask them then.
    99 VW GTI VR6 SC
    -The GTI-PC-

  6. #16
    Constant Bitrate
    Join Date
    Sep 2004
    Location
    Springfield, IL
    Posts
    207
    I have the RMA # via e-mail. I'll just send it in and hope i get lucky...

  7. #17
    Low Bitrate
    Join Date
    Sep 2004
    Posts
    111
    I have the Opus 150w and it works flawlessly in cold weather. It was just 11 below 0 and carputer worked flawlessly.. also, a word about Opus tech support. i sent mine in for them to modify to cut power to all USB devices when the power is off and they were great.. they modded it at no cost and shipped it back to me in Canada at no cost.. they also turned it around the same day, they are a great company to deal with..

    Craig

  8. #18
    Constant Bitrate
    Join Date
    Sep 2003
    Location
    Boston, MA
    Posts
    120
    Yeah, it's only the 90w version that seems to have had the problem with the cold weather.

    And yes, they were great to deal with.
    99 VW GTI VR6 SC
    -The GTI-PC-

  9. #19
    Constant Bitrate
    Join Date
    Sep 2003
    Location
    Boston, MA
    Posts
    120
    So I got my PSU back from OPUS today. I'll be putting it back in the car when I leave work tonight. OPUS says they were able to fixe it and resolve the cold weather problem. This weekend is supposed to be really cold so we shall see what happens. I'll kepp ya'll posted.
    99 VW GTI VR6 SC
    -The GTI-PC-

  10. #20
    Newbie
    Join Date
    Apr 2004
    Posts
    51
    Supposedly it is a batch of capacitor that fails during cold weather...according to OPUS.

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. Opus and Cold Weather
    By KaiTech in forum Power Supplies
    Replies: 22
    Last Post: 12-28-2004, 01:55 PM
  2. Liliput in cold weather?
    By Lucky13 in forum LCD/Display
    Replies: 4
    Last Post: 12-25-2004, 03:15 PM
  3. Cold weather +LCD
    By Adragontattoo in forum LCD/Display
    Replies: 4
    Last Post: 10-13-2004, 10:25 AM
  4. carputers and cold weather?!
    By mrzigzag in forum General Hardware Discussion
    Replies: 13
    Last Post: 08-06-2003, 01:00 AM
  5. Hard Drive screwed in cold weather!?!!?
    By grandamp3 in forum General Hardware Discussion
    Replies: 8
    Last Post: 11-23-2000, 11:41 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •