Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: LM 2587 -12 Blowing Up??

  1. #1
    Low Bitrate
    Join Date
    Dec 2001
    Posts
    67

    LM 2587 -12 Blowing Up??

    Ok the national semiconductors piece the LM2587-12 t or whateevr it is.... I put it onto the suppy turn on the pwoer and that goes to ~ 1000 degrees or so and blows... Anyone have any idea hwat could be causing this???

    I blew 3 alredy

  2. #2
    Raw Wave Rob Withey's Avatar
    Join Date
    Apr 2000
    Location
    Bedfordshire, UK
    Posts
    2,139
    Erm, give us a clue. What circuit are you using?


    Rob
    Old Systems retired due to new car
    New system at design/prototype stage on BeagleBoard.

  3. #3
    Banned
    Join Date
    Jun 2001
    Location
    Adelaide, Australia
    Posts
    687
    Could have been shorted somehow.. The transformer could be in the wrong way, or something... yeah, what PCB are you using, or aren't you using a premade one???

  4. #4
    FLAC Mastero's Avatar
    Join Date
    Aug 2001
    Location
    India
    Posts
    1,640
    YOU GOT A SHORT in the pcb .. double check it and do it with a magnifining glass even a small tiny solder thing can cause a Major short !

    mastero

  5. #5
    Variable Bitrate
    Join Date
    Jul 2001
    Posts
    384
    Same thing happened to me buddy - I found a short in it thanks to mastero's help

  6. #6
    FLAC Mastero's Avatar
    Join Date
    Aug 2001
    Location
    India
    Posts
    1,640
    Hey ces m3 ... got ur Psu working?

  7. #7
    Variable Bitrate
    Join Date
    Jul 2001
    Posts
    384
    not yet mastero Ive been kinda busy - just taking my time with it like you suggested

  8. #8
    Low Bitrate
    Join Date
    Dec 2001
    Posts
    67
    Hmm ill check the board its a sproggy that I made via the iron on method... Does anyone sell boards tho I may just start over!

  9. #9
    Maximum Bitrate
    Join Date
    Nov 1999
    Location
    Sydney NSW Australia
    Posts
    581
    I think this should be the first question... Did you put a heatsink on the regulator?
    Fosgate

    System Comp V3 - In progress.
    Low power MB with C7 CPU, DC-DC PSU, car ECU link, USB TV, GPS, 7" TFT, Wireless, Voice.

  10. #10
    Low Bitrate
    Join Date
    Dec 2001
    Posts
    67
    Yes I had one on... but it gets to 1000 degrees in like 3 seconds so the worlds largest heatsink wouldnt prob do anything......

    liquid nintro may help LoL

    im figuring its a short and am lookign around.... i may just end up buyin a pcb from whoever sells em

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •