Results 1 to 5 of 5

Thread: M1 , M2 , Opsus & EP13000 Informative Thread

  1. #1
    Variable Bitrate Philhop's Avatar
    Join Date
    Apr 2006
    Posts
    291

    Post M1 , M2 , Opsus & EP13000 Informative Thread

    Hi I thought I would make a post to comment on my problems that im suffering from and the experence I have had.

    First was the M1-ATX , worked great till i put 12v down the switch wire and fried the PSU , you would think it would have some overload protection here.

    Second Ordered a M2-ATX thought why not get a bit more power , no such luck there are alot of issues with the EP13000 and M2-ATX due to the 5v startup as mentioned in other posts, Pehaps the latest version of the psu works , there is nothing conclusive here.

    Third RMA'd the M2-Atx the wonderful support I had from ITX.co.nz , recommended me getting a OPUS 120w but I like the features of the M1-ATX that worked in the past , and the shear fit of it into the AMPIE case . I have opted for the M1 again this however could be a bad choice they threw in a free wireless usb for my troubles and to make up the diffrence, thanks guys.

    Final conclusion - If this M1 doesnt work ill RMA it again and go for a OPUS , so any doubts id go for a OPUS if your running a EP13000 motherboard , Its more expensive but good things have been said about this psu , Im not running alot so the M1 Should be fine. I have cut the ampie case to allow some extra USB ports to come out of the AMPIE and just running some EL wire from the Molex as well at 45 Ma it should be able to handle that.

    The Ep13000 hardly uses the 12v rail its all mainly 5v.

    Any questions or suggestions are welcome, I just want to get my Project Altezza back up and running so I can post some pictures.

  2. #2
    Maximum Bitrate v8 scimitar's Avatar
    Join Date
    Jan 2005
    Location
    Scotland
    Posts
    743
    hope it works out for you, I went through 2 M2's and none of them would work with my sp13000 so went for the opus and never looked back. Only thing that bugs me on the opus is the 5v line being left on but I soon sorted that with a relay and a few diods although I belive there is a software update opus can put on. Not very handy if you have to ship overseas tho.

  3. #3
    Variable Bitrate Philhop's Avatar
    Join Date
    Apr 2006
    Posts
    291
    Now im even more glad i didnt get the opus, thanks for that advice

  4. #4
    Newbie Howie's Avatar
    Join Date
    Jun 2006
    Location
    Adelaide, Australia
    Posts
    24
    Quote Originally Posted by Philhop
    Now im even more glad i didnt get the opus, thanks for that advice
    hey? he recommended the opus not the m1-2.

    anyhow thanks for the headsup .. i'll be going the opus too.

  5. #5
    Variable Bitrate Philhop's Avatar
    Join Date
    Apr 2006
    Posts
    291
    actualy i got a m1 replaced it works fine now
    my TURBO! Altezza!

    ATEZZA / IS200 3SGE-TURBO 6SPD MANUAL , EPIA 13000, 512 RAM W/LAN , 100GIG , GPS , TOUCH, 3X LCD, FLUSH TOUCHPAD MOUSE, SOUNDBLASTER EXTERNAL

Similar Threads

  1. Replies: 3
    Last Post: 01-06-2008, 03:11 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •