Results 1 to 3 of 3

Thread: Power Supply problems

  1. #1
    Newbie
    Join Date
    May 2002
    Posts
    4

    Angry Power Supply problems

    Hi,
    I hope you guys can help me. I have built a power supply based on the MAX787 IC. You can see it here http://www.jarcom.com/inmotion/power.htm

    Now, instead of using a 50uH inductor (which I could not find), I used a 47uH instead (with a 10% tolerance) thinking that this should be ok.

    When I plugged it in with no load it was ok abut when I connected it to the computer, the inductor burned up quite quickly. I tested what current the PC is drawing and it is only about 2.5A or a little less -- this is well within the 5A load limit.

    Do you guys have any idea's before I do get another inductor and try again.

    Thanks a lot,
    c-dawg

  2. #2
    FLAC Mastero's Avatar
    Join Date
    Aug 2001
    Location
    India
    Posts
    1,640
    what is the amp rating on the inductor? should be atleast 5amps min

    also check for shorts on the board

    Mastero

  3. #3
    Newbie
    Join Date
    May 2002
    Posts
    4
    Thanks!

    The current for that inductor was < 0.1A !!

    No wonder it turned into fried silcon!

    I have order a 7A inductor but it has to ship to me and it will take a week ok well -- I guess I will have to wait!

    Thanks again,

    C-Dawg

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •