Results 1 to 4 of 4

Thread: Need help with Navivoice 1.7

  1. #1
    Constant Bitrate
    Join Date
    May 2005
    Location
    Mother Earth
    Posts
    195

    Need help with Navivoice 1.7

    I can't launch Navivoice 1.7 with autoit. I get an error msg, "ole error 800C0005".

    This is weird because I can launch iNavivoice when I dont use an autoit script. I have sapi 6.1, Windows xp sp2 clean install, mp10, bluetooth dongle device with widcomm 5.

    Parameter I used to launch navivoce in autoit script

    Run("C:\Program Files\NaviVoiceV1.7\NaviVoice.exe")

    I have a via board so I know you dont like them.
    My goal is open and close navivoice via a script along wih pausing and muting the music in
    mobile impact through a external button

    #This script is push to talk
    Send("{NUMPAD5}")
    winWaitActive("Media Module")
    MouseClick("left", 247, 551, 1, 1)
    Run("cd\lineToggle.exe")
    Run("line\lineToggle.exe")
    Run("MIC\lineToggle.exe")
    Run("C:\Program Files\NaviVoiceV1.7\NaviVoice.exe")

    Navivoice wont launch help anybody,
    I know leelo you might say "nigwhyrito why dont you leave navivoice open, and make a command for conformation on and off in the xml". I did this already and I am trying to learn other ways to do stuff.

  2. #2
    My Village Called 0l33l's Avatar
    Join Date
    Jul 2004
    Location
    Berkeley, CA
    Posts
    10,516
    Hmmm.... maybe autoit has another way to launch a program. I'm guessing that you need to pass the directory to open navivoice in (its own directory). I think that that error means that it can't find the XML file (caused by it being launched outside of its directory).

  3. #3
    Constant Bitrate
    Join Date
    May 2005
    Location
    Mother Earth
    Posts
    195
    Thanks leelo i feel so stupid. You were right it can't run some programs that are outside itown directory.
    I moved the script and it worked flawlessy thanks again.

  4. #4
    My Village Called 0l33l's Avatar
    Join Date
    Jul 2004
    Location
    Berkeley, CA
    Posts
    10,516
    Quote Originally Posted by nigwhyrito
    Thanks leelo i feel so stupid. You were right it can't run some programs that are outside itown directory.
    I moved the script and it worked flawlessy thanks again.
    Great to hear that its working

Similar Threads

  1. Navivoice 1.7 wont load
    By brandonn in forum PowerVoice
    Replies: 7
    Last Post: 01-13-2006, 01:03 AM
  2. Replies: 8
    Last Post: 12-18-2005, 01:53 AM
  3. NaviVoice v.8 PREVEIW!
    By 0l33l in forum PowerVoice
    Replies: 35
    Last Post: 10-31-2004, 12:34 AM
  4. NaviVoice v.7 Release!
    By 0l33l in forum PowerVoice
    Replies: 47
    Last Post: 10-23-2004, 04:30 PM
  5. NaviVoice v.6 RELEASED!
    By 0l33l in forum PowerVoice
    Replies: 28
    Last Post: 10-11-2004, 01:34 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •