Page 1 of 4 1234 LastLast
Results 1 to 10 of 34

Thread: Flash Problems.... Flash Problems... and MORE Flash Problems!!!!!!!

  1. #1
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,703
    Blog Entries
    1

    Angry Flash Problems.... Flash Problems... and MORE Flash Problems!!!!!!!

    Ok, Do not know where to begin, other than the "Flash Issues" have gotten out of hand. If you do a search on the forums for "Flash Problem" you will find literally hundreds of posts. This has been an ongoing problem for the past 3 years that I personally know of.

    There are all sorts of supposed "solutions" like, renaming this flash OCX, Removing flash and reinstalling it, Installing flash with Internet Explorer, Installing the stand alone player, reverting to this or that version, throttling down the hardware acceleration a notch or two... but STILL there is no single solution to get this to work.

    Guino has put SSSSOOOOoooo Much time and effort into Road Runner, we could never thank or pay him enough! So it's hard for me to say something negative about Road Runner. Be that as it may, this problem needs to be resolved.

    I can play flash animations on websites, in the standalone flash player , and yet when trying to do the same thing inside RR, it can peg the CPU to 100%. This tells me that it HAS to be something inside Road Runner. Sure finding that sweet spot between Flash and Road runner is a work around, but still the problem is with Road Runner itself. I have never had flash peg my CPU at 100% in the stand alone player, on a website, or anywhere else for that matter, no matter what version of flash it was, or what version of flash the applet was written for.

    Hell, reading a post the other day, Liquid Smoke wrote a AutoIt script, that would embed in Road Runner to display a flash applet! When the Flash was directly embedded in RR it was slow as molasses (Using the Flash Traffic Addon for Road Runner), but using AutoIt to embed the same thing, it worked at normal speed, and the CPU usage didn't show any change that the flash file was even running.

    I heard one person even mention embedding the stand alone flash player inside Road Runner! Not a perfect solution by any means, but something that would at least work.

    This has got to tell you that something is seriously wrong somewhere

    There has to be some way to work this out with Road Runner. With more and more flash stuff being used the problem is just getting worse. Add in's like Flash Gauges, games, Traffic Plugins, Clocks, Replacement sliders and scroll lists... the list goes on and on.

    This finally just really got to me a couple days ago, and why I decided to start this thread. I release an update for my skin, and when I packaged it, I had the main menu set to use a flash clock. I had numerous complaints that when the skin loaded, the CPU went to 100%. The could not even get to the menu in the skin to change the clock for a standard RR code Digital clock. For one of the users, the skin worked perfect on the desktop, and locked the car CPU to 100%. He has uninstalled flash, renamed the ocx's, reinstalled with Internet Explorer, throttling down the hardware acceleration, and 50 other things, and can not get RR to work with flash correctly.

    This post is not simply a rant, but to start a discussion on how this problem can be fixed once and for all. Road Runner is, without a doubt the best Front End available, either for free, or something that you have to pay for. Flash, on the other hand with Road Runner is a serious drawback for a lot of people.

    What can be done to fix this once and for all?
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  2. #2
    FreeDrive Creator CdRsKuLL's Avatar
    Join Date
    Feb 2004
    Location
    Manchester
    Posts
    3,513
    I've been using flash for about 2 years now.. not really had a problem that I couldnt solve.. first try putting ,SOLID after your F01 line in the skin, this will speed it up by 50% at least as it doesnt then need to buffer it first before displaying. Second.. always use the latest flash version.. third make sure the app your using to design the swf file supports the latest flash version.. this was a major problem about a year ago when all swishmax swf files wouldnt play on flash 9, hence the renaming etc had to be done, but all that is a thing of the past now.. The only other really problem I've come across is the unichrome gfx card on the newer epia / jetway boards.. its crap to be honest with its 2d graphic abilitys and has been slagged off in the htpc media world as well.. I will be releasing my next alpha version of FU either tonight or tomorrow which is all flash based.. (0.4) have a play with that and you should see I dont have many problems at all.


    CdR

  3. #3
    FLAC ShawJohn's Avatar
    Join Date
    Aug 2004
    Location
    On the edge!
    Posts
    1,790
    try turning graphics hardware acceleration down a notch, helped a great deal with my flash problems

  4. #4
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,703
    Blog Entries
    1
    Guys, I wasn't asking for help to get flash working And you can see I mentioned turning down the hardware acceleration in the first message, and 5 other workarounds.

    It may seem like Flash is not a problem any longer, but do some searching on the forums, and, by all means have a look at the last 5 pages in my DigitalFX thread! Hahaah

    The bottom line, there is NO reason a simple flash clock, should peg a computer at 100% CPU to the point of CTRL ALT DEL not even being able to respond. SOMETHING is wrong, and I was just trying to figure out the root of the problem, not work around it.
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  5. #5
    FreeDrive Creator CdRsKuLL's Avatar
    Join Date
    Feb 2004
    Location
    Manchester
    Posts
    3,513
    did you do the clock ? maybe you have an error in your flash code, i'm using several clocks on my fu skin and not having a problem with any of them.. when doing a clock you only need it to update its code once a second so if your running 20fps then use frame 1 and 20.. no point having it like frame 1 and 2 as its a waste

    CdR

  6. #6
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,703
    Blog Entries
    1
    Me.... Write the clock? I couldn't code in flash to save my life! Hahahahh! You my friend are the flash Guru hands down!

    It's just one of the clocks on the Internet that you run across now and then.

    Again the bottom line, is very simple. Run that same clock in Adobe's Flash Player, or in a web browser, and there are NO CPU problems in any way whatsoever. So that, 100%, without a doubt, in any way, whatsoever, points to the way that RR handles flash in the first place. period.

    On the other hand, if this is not still a problem, just do a simple search of the forums for "Flash Problem"

    As for the ".solid", that will not work in 90% of situations, unless you want a nice white area instead of the transparent area around the flash clock or object.

    I have not said anything to this point, but every time I read you referring to your new skin as FU I definitely get a chuckle (Possibly a subliminal thought or message related to your previous skin?) I try to tell myself that it stands for "Flash University"
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  7. #7
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    Quote Originally Posted by JohnWPB View Post

    I have not said anything to this point, but every time I read you referring to your new skin as FU I definitely get a chuckle (Possibly a subliminal thought or message related to your previous skin?) I try to tell myself that it stands for "Flash University"
    hahahah, so what does it stand for?

    anyway, i know what you mean about flash and RR. There def is something different about how it works in RR, but with that said in the same breath i havnt had any issues with flash. I also dont use much flash either, so go figure.

    I think your problem with your clocks maybe that its redrawing on everyframe/updating every sec like cdr was saying. Since u didnt create them this is likely the issue. But to go back to what your bottom line point is, you shouldn't have to create the flash file this way, thus making cool stuff u find on the internet not really usable inside RR.
    01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
    01101101 01101111 01101011 01100101

    beer replenishment fund
    http://www.mp3car.com/vbulletin/rr-faq/
    mp3car live search

    i have joost invites, just hit me up for one.

  8. #8
    FLAC Chuck's Avatar
    Join Date
    Sep 2003
    Location
    Ellicott City, MD
    Posts
    1,671
    CdRsKuLL I tried the ,solid thing and the cpu’s did go down but the background in the flash turned white even though I have the background set as black in the .fla file.

    Any clues?
    2001 S10 ZR2

    Chucks Skin - to old

  9. #9
    FreeDrive Creator CdRsKuLL's Avatar
    Join Date
    Feb 2004
    Location
    Manchester
    Posts
    3,513
    Hi Chuck, the background in flash is just for design purpose, just place a solid black shape at the bottom of your swf file :-) if thats the colour you want

    FU stands for Freedom Ultimate, but I do like yours .. lol

    :-) CdR

  10. #10
    Maximum Bitrate DJiK's Avatar
    Join Date
    Apr 2005
    Location
    Los Angeles (Winnetka), CA
    Posts
    864
    Has anybody try to overcome this general flash issue beyond the thread?
    For Sale: Carputer (CarPC) & RCA Y-Adapter
    Newsflash: Take a look at my unsold stuff above, thanks!
    Up Next: Make an OBD to Serial cable & Redo the "MMI buttons"

Page 1 of 4 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •