Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Why does RR always go back to music page on resume?

  1. #1
    Low Bitrate scottgs's Avatar
    Join Date
    Feb 2006
    Location
    Knoxville, TN
    Posts
    60

    Why does RR always go back to music page on resume?

    Ok, I've really tried to figure this out, and tried to search here for the answer, all with no success. I know this has got to be simple.

    When RoadRunner resumes after Standby, it comes up exactly where it left off, for example if I have Nav running, which is perfect, except it only lasts for about 100 milliseconds, and then RR switches to the music player, just as if I had selected it. It does it no matter what I had running when it went into standby. It always resumes and immediatly goes to the Music player. I don't want it to do this, I want it to stay where it left off, like if I was navigating, I want it to resume navigating.

    I've searched for any "onresume" statements, and found nothing.

    I've looked through the .ini files, and just don't see it. There has to be something in there doing this. Help!

  2. #2
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,053
    Have you tried other skins?

    If you are using the BMV2 skin, perhaps your screen has debris there?
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

  3. #3
    Low Bitrate scottgs's Avatar
    Join Date
    Feb 2006
    Location
    Knoxville, TN
    Posts
    60
    Using iDrive. Haven't tried another skin yet. I did not use to have this problem with RR and iDrive though, prior to switching over to a new computer and a fresh load of RR.

  4. #4
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,053
    Can you post your ini file?

    Do you use iGuidance? Do you have that autoswitch to last screen thing set? It is the only one I know of that switches a screen like that...
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

  5. #5
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    It should stay in the same screen as before hibernating -- and I've always used it like that without a problem. Either some application is sending a command to RR, or the skin is, or you have something on the ONRESUME event in exectbl.ini that is triggering that screen to come up.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  6. #6
    MySQL Error MatrixPC's Avatar
    Join Date
    Sep 2003
    Location
    Beach City, Socal
    Posts
    4,053
    Skin problem.
    I never have this problem.
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 600E@750/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

  7. #7
    Low Bitrate scottgs's Avatar
    Join Date
    Feb 2006
    Location
    Knoxville, TN
    Posts
    60
    Thanks everyone for the help. Unfortunately, I still have yet to figure out the problem. Haven't had much time to work with the carpc, although i am using it everyday and Roadrunner is just great! Hoping to have some time to tackle the canbus interface in Oktober, so want to get this minor stuff out of the way.

    Here are my .ini files. If anyone see's anything, please let me know. This is really making me nuts. Also, I don't have the problem with other programs when I go into standby and then resume. Only roadrunner. It's got to be something really simple.


    ExecTBL.ini

    [deleted the comments...]

    "QUIT","SendMsg;RRCDRip;showplugin||bye"
    "BYE","QUIT"

    /, Set Bellow the Path to the CDRip plugin (if used)
    "CDRIP","PLUGIN;RRCDRip;D:\VBStuff\Road Runner\CDRip\CDRip.exe"

    /, You can add commands to execute before suspend
    /, and after resume, using the codes bellow:

    "ONSUSPEND",""
    "ONRESUME",""
    "ONFILECLICK",""
    "ONDIRCLICK",""
    "ONPLCLICK",""
    "ONDLCLICK",""
    "ONPBCLICK",""

    resume.ini

    -1
    -1
    False
    True
    C:\Program Files\Road Runner\skins\iDrive\
    26212
    False





    rr.ini

    voice=true
    musicpath=C:\Music\
    videopath=D:\DVDs\
    dvdpath=C:\Program Files\InterVideo\DVD6\WinDVD.exe
    dvdname=InterVideo WinDVD 6
    launchpath=C:\Program Files\Road Runner\Launch\
    winamppath=C:\Program Files\Winamp\
    skinpath=C:\Program Files\Road Runner\skins\iDrive\
    nightskin=C:\Program Files\Road Runner\skins\iDrive Night Red\
    mpcpath=C:\Program Files\Road Runner\mplayerc.exe
    screentype=16:9
    videoautohide=true
    videohidetime=4
    audiofiles=.mp3,wma,wav,cda
    hidemouse=false
    coverfile=*.jpg
    albumart=*.txt
    useid3=3
    showid3playlist=true
    showid3browse=true
    gpsmode=2
    gpsport=6
    mapmonkeypath=C:\DestinatorApps\Map Monkey\MapMonkey.exe
    gpspath=C:\Program Files\iNav\iGuidance\iGuidanceUMPC.exe
    gpsname=iguidance
    exitmode=0
    showicons=true
    showextensions=false
    titlesafter=-
    listfollowssong=true
    resumemusic=0
    audiorepeat=off
    audioshuffle=on
    gammamode=1
    gammapath=C:\Program Files\Road Runner\Gamma\GammaControl.exe
    dateformat=MM/DD/YYYY
    timeformat=HH:MM:SS
    id3listformat=%artist% / %title%
    id3browseformat=%artist% / %title% / %genre% / %album%
    mastervolmap=2
    listnumbers=false
    noformat=false
    hidewinamp=true
    visuname=!Winamp Gen!AVS
    overspeed=80
    scrollmode=1
    builtinvideo=true
    disableinternat=true
    locale=0
    hidetaskbar=false
    hidedesktop=true
    radiomode=0
    radioline=0
    playlistpath=C:\Music\
    lazytag=false
    allowallfreqs=false
    browsertype=1
    browserpath=C:\Program Files\Internet Explorer\iexplore.exe
    mapvol=50
    standardphonebook=0
    maxcalllistentries=100
    xmport=2
    xmline=1
    xmlineinplugin=true
    xmlineinpar=line://title=XM,srate=44100,bps=16,nch=2
    debugmode=false
    hibernateaware=true
    enableclipping=true
    soundcard=0
    nozoom=0
    ipoddrive=Click here to set drive
    resolution=800x600x32x60
    usegestures=false
    leavemousealone=false
    hibernatereload=false
    forcehibernate=true
    closeapps=true
    cityweather=piketon, oh
    weatherunits=USA


    Here are the iDrive skin .ini files

    execTBL.ini

    /, You can add commands to execute before suspend
    /, and after resume, using the codes bellow:

    /"ONSUSPEND",""
    /"ONRESUME",""
    "ONLINE",""
    "OFFLINE",""
    "ONFILECLICK",""
    "ONDIRCLICK",""
    "ONPLCLICK",""
    "ONDLCLICK",""
    "ONPBCLICK",""
    "ONPLSELCLICK",""
    "ONDLSELCLICK",""
    "ONSONGSTART","SETVARBYCODE;curtrack;trackpath "
    /"ONSKINSTART","SETVAR;NIGHT;0||SETVAR;SNIGHT;0||RU N;$skinpath$DNSwitch.exe||AUDIO"

    "TIMER","BYVAR;NIGHT;MM;Set_Color_Mode|1||SETVAR;N IGHT;1<<",destinator_gps.skin
    "TIMER","BYVAR;NIGHT;SENDMSG;FreeDrive;day||SETVAR ;NIGHT;1<<",external_gps.skin
    "TIMER","BYVAR;SNIGHT;ACTIVATE;- Microsoft Streets & Trips||SENDKEY;%vmd||SETVAR;SNIGHT;1<<",external_g ps.skin
    "TIMER","BYVAR;SLIDESHOW;<<NEXTPIC",PICVIEWER. SKIN

    "CAMALERT","",external_gps.skin
    "CAMALERT","MENU;camalert.skin"


    iDrive.ini

    iGuidance
    SpeedFan
    Internal
    GAMES=True,=Games,LOAD;games.skin,
    TV=True,=TV,TV,
    CDRIP=True,CD Rip,CDRIP,
    RADIO=False,=Radio,RADIO,
    PHOCO=True,=Phone,PHOCO,
    MOBILEWEB=True,=MobileWeb,LOAD;mobileweb.skin,
    RADAR=True,=Valentine 1,LOAD;valentine.skin,
    WEATHER=True,=Weather,LOAD;weather.skin,
    SIRIUS=False,=Sirius,SIRIUS,
    XM=True,=XM,XM,
    TRAFFIC=False,=Traffic,LOAD;traffic.skin,
    TRAFFICC=True,=Traffic Cam,LOAD;trafficcam.skin,
    GAS=True,=Gas Prices,gaspricefinder,
    PICTURES=True,=Pictures,PICS,
    TRIPMETER=True,=TripMeter,tripmeter,Milage
    RREARTH=True,RREarth,GE_START,
    MOTIONLOCK=True,MotionLock,MotionLock,
    DRAW=True,Draw,LOAD;draw.skin,
    CALENDAR=False,,LOAD;Calendar.skin,
    END


    general.ini

    OriginalWidth=800
    OriginalHeight=600
    ShowWidth=800
    ShowHeight=600
    XPosition=0
    YPosition=0
    ApplyToVideo=True
    ApplyToVisu=False
    AutoSwitch=False
    DayTime=08:00:00
    NightTime=17:00:00
    GammaDayRed=0
    GammaDayGreen=0
    GammaDayBlue=0
    GammaNightRed=0
    GammaNightGreen=0
    GammaNightBlue=0

  8. #8
    Confusion Master
    Auto Apps:loading...
    Enforcer's Avatar
    Join Date
    Sep 2003
    Location
    If you go down to the woods today, You're sure of
    Posts
    14,613
    Well you have slashed out the onskinstart line which is the only line I could think of that might cause it to do that. But even then if it did that would be a RR problem, because onskinstart commands shouldn't run on a resume.

    BTW by slashing out that line you have stopped the skin switcher from runnng, which switches the skins of some of the other programs/plugins.

  9. #9
    Low Bitrate scottgs's Avatar
    Join Date
    Feb 2006
    Location
    Knoxville, TN
    Posts
    60
    Well you have slashed out the onskinstart line
    Yes, I know. I was just stabbing at different things. I am running this under Vista, and I suppose maybe it has something to do with it. However, other programs running under vista seem to resume just fine.

    Thanks for looking it over, I do appreciate your time and the super cool skins that look so perfectly correct in my vehicle

  10. #10
    Raw Wave lostreception's Avatar
    Join Date
    Sep 2004
    Location
    NY
    Posts
    1,806
    Your answer is probably
    Attached Images Attached Images  
    .______
    | '_ |__\___
    [(o)|___(o)] XB
    ._________
    | I__I I_I|_\__I
    [(o)______(o)]b VanPimpin'

    LostReceptions Apps D/L Here

    GPSGasoline- Rewriting

    Draw- SkribblePad for Touchscreens

    iGQwerty-iG3.0 Qwerty Keyboard

    CarPCNetwork

Page 1 of 3 123 LastLast

Similar Threads

  1. How to resume music playback after using radio?
    By johnk in forum Mp3Car Infill G4 - Double Din Car Computer
    Replies: 2
    Last Post: 07-28-2008, 08:34 PM
  2. Music will not resume play from "Genre" folder.
    By polo6979 in forum StreetDeck Bug Reports
    Replies: 5
    Last Post: 06-28-2007, 09:39 AM
  3. need help ,run map on RR main page
    By zx16v in forum RR Skins
    Replies: 19
    Last Post: 03-05-2006, 07:25 AM
  4. Replies: 0
    Last Post: 12-18-2005, 12:16 AM
  5. No auto resume music and video?
    By organasised in forum Road Runner
    Replies: 3
    Last Post: 02-10-2005, 09:55 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •