Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: RR problem with buttons always on

  1. #1
    Maximum Bitrate Dalailama's Avatar
    Join Date
    Jan 2006
    Location
    Novara Italy
    Posts
    628

    RR problem with buttons always on

    Hi RR's gurus!
    I have installed a complete new carpc with Tiny xp beast edition e RR...
    ...and obviously my skin :P
    There's a problem somewhere (my fault for sure!) in each screen of the skin there's always a button on... when I click on another button (for example Vol up) that button lights up then after less than a sec it turn normal and always the same button on the bottom left corner lights up without any effect...
    It seems as the touchscreen has a problem and is always pressed in the position corrispontent to that button, but it is not so, because the pointer (arrow) doesn't move to that point..
    please help me!
    Live today like it is your last day, and behave as though you will live forever...

    my WEBSITE

    MapMonkey Dalai skin-preview-download ITA-email me for ENG
    Road Runner CrystalBlue skin-preview-beta release

  2. #2
    Confusion Master
    Auto Apps:loading...
    Enforcer's Avatar
    Join Date
    Sep 2003
    Location
    If you go down to the woods today, You're sure of
    Posts
    14,613
    look at the auto hide settings for the mouse.

    I had this problem with the idrive menu.

    Make sure there is not a button bottom left. or just raise the height (make it a lower number) a bit

    ie 596 not 600

    or Ypos + height is less than 600

  3. #3
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    if you down't want the mouse to move "away", set leavemousealone=true
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  4. #4
    Maximum Bitrate Dalailama's Avatar
    Join Date
    Jan 2006
    Location
    Novara Italy
    Posts
    628
    ...now that you make me think about the problem occurs from when I hide mouse!
    Thanks I'll try and let you know.

    @Guino the mouse doesn't move away, it stays in the position I left it, but the button bottom left lights up (even if the mouse is in the top right corner...
    BTW thank you.
    Live today like it is your last day, and behave as though you will live forever...

    my WEBSITE

    MapMonkey Dalai skin-preview-download ITA-email me for ENG
    Road Runner CrystalBlue skin-preview-beta release

  5. #5
    Variable Bitrate sargeants's Avatar
    Join Date
    Oct 2008
    Location
    Ontario, Canada
    Posts
    232
    I hate to bring up an old issue, but I'm having it with my setup.

    I've checked with 2 different installs, and a second computer. Even created a silly test skin to see if it was something I was doing.
    With my skin I'm planning on having multiple buttons in the bottom left, and it's kinda annoying to have the button light up after clicking some other button elsewhere.

    This happens on my GPS screen as well as my audio player screen.

    I have the mouse hidden and have just tested with having the leavemousealone=true set. While checking this on another system (cmotors was nice to help) we noticed that this also happens with DFX and the menu button.

    Is this an issue in RR's code with how the mouse is being hidden?? Seems silly to have to limit a skins button area because of this. This has happened for me over the past couple releases of RR, but I was always chalking it up to an issue with how I mounted my screen.

    Any ideas/help?
    03 Hyundai Elantra GT {Worklog}
    HP TC4400; 250GB SATA, WiFi, BT, 12.1" touch
    RideRunner; w/ mobilephone.net, OBDMPG, mediaart, RRMedia, DFXVoice and more...
    cmdRR tall skin creator

    86 Pontiac Fiero SE 2m6
    possible carpc install

  6. #6

  7. #7
    Variable Bitrate sargeants's Avatar
    Join Date
    Oct 2008
    Location
    Ontario, Canada
    Posts
    232
    doesn't anyone else find that odd / a little annoying?
    03 Hyundai Elantra GT {Worklog}
    HP TC4400; 250GB SATA, WiFi, BT, 12.1" touch
    RideRunner; w/ mobilephone.net, OBDMPG, mediaart, RRMedia, DFXVoice and more...
    cmdRR tall skin creator

    86 Pontiac Fiero SE 2m6
    possible carpc install

  8. #8
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    We can add a prevention for it, but really it's a limitation imposed by the OS forcing the mouse to always stay somewhere in the screen. When you press a button in RR, we move the mouse out of the way so we the next screen doesn't show up with anything highlighted (in the position you clicked) -- but where to put the mouse when the screen may have controls anywhere ? This is the main issue. I'll have to play with some ideas to see what can be done, but for now you can either just reduce the height (by ONE pixel) of your bottom-left most button of the screen and it should take care of it -- the change is minimal and should not have any visual side effect.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  9. #9
    North of the land of Hey Huns
    Auto Apps:loading...

    Join Date
    Jun 2004
    Location
    Westminster, MD
    Posts
    2,144
    guino: are you familiar with calling API functions? I'm fairly certain this works in vb6
    Private Declare Function ShowCursor Lib "user32" (ByVal bShow As Long) As Long
    ShowCursor False ' Hides the mouse
    ShowCursor True ' Un-Hides the mouse
    "stop with the REINSTALLS, what do you think we got some lame-o installer!!!" - mitchjs
    RevFE
    My Shop

  10. #10
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    Quote Originally Posted by malcom2073 View Post
    guino: are you familiar with calling API functions? I'm fairly certain this works in vb6
    Private Declare Function ShowCursor Lib "user32" (ByVal bShow As Long) As Long
    ShowCursor False ' Hides the mouse
    ShowCursor True ' Un-Hides the mouse
    Thanks for the tip, but that only HIDES the cursor, but does NOT stop reporting mouse movements to any application whatsoever. By the way, this showcursor call has been in RR since the very first versions in 2004..
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

Page 1 of 2 12 LastLast

Similar Threads

  1. GPS and RR problem =p
    By darkomen64 in forum Road Runner
    Replies: 3
    Last Post: 09-02-2007, 10:51 PM
  2. Problem with WINAMP in RR - Needs help!
    By Visions in forum RR Bug Tracker
    Replies: 2
    Last Post: 08-18-2007, 12:03 PM
  3. problem with avercard radio and RR
    By prnit in forum Road Runner
    Replies: 1
    Last Post: 07-23-2007, 03:06 PM
  4. RR & Iguidance problem
    By tsx004 in forum Road Runner
    Replies: 49
    Last Post: 12-05-2006, 04:57 PM
  5. Video problem (maybe) RR 9-5-06
    By vinzer in forum Road Runner
    Replies: 5
    Last Post: 09-09-2006, 01:29 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •