Results 1 to 4 of 4

Thread: Little issue i've been having with my playlist format

  1. #1
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,121
    Blog Entries
    51

    Little issue i've been having with my playlist format

    Lemme start off by saying this is semi related to my own skin but maybe can answer questions for those who choose to go this same route....

    I've had this very annoying bug that i cant seem to fix myself with the way my playlist is displayed in my flash skin. First i wanna show the same system running the non-flash void playlist to show that the music is formatted properly for what i'm tryin to accomplish.



    shows my playlist format is ARTIST - TITLE

    now in my skin i've decided to have the title on the top bar and the artist name just underneath it. I did this by simply spliting the CUSTOMPL then further spliting each line in CUSTOMPL at the "-". In Testing the song playing is always formatted correctly.. however each other item in the list is NOT (title line is blank... artist line shows song title)



    Why is this? I have no idea. Sometimes other lines appear as they should other times they dont. However if i PLAY the song the issue fixes itself. In this last image i've played the 3 songs at the top of the playlist and each item is formatted correctly



    Guino or anyone else who may understand this... does this make sense? Are subsequent entries in the playlist handled differently upon first load into the playlist? Sometimes it appears as the first song is wrong at first then fixes itself a split second later.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  2. #2
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    When making a flash list, you have to be ready for "playlist updates" -- that is, RR may send you an "initial" playlist that does not have all the final information in it, then it may update the playlist and send you an updated list, and may do that more times afterwards. What I recommend is to monitor _rood.CUSTOMPL, then if it's not empty, parse it, then set it to empty ( = "" ) then keep monitoring it, and whenever it changes, parse it again. This typically happens when you use tags (and specially the lazytag option). Another possibility is that the code you're using to split the text may have a little glitch in it.. the other possibility is that the playlist object in your skin (the one required so you receive custompl updates) has fewer lines than your flash list is trying to display -- in that case, RR is only going to update the items it thinks are "visible" in its standard playlist, and may not send you updates to all the items you're actually showing in yout flash list. To check this issue, simply increase the height of your playlist in that screen to where it fits at least as many lineas as you display in your flash list, then see how it goes.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #3
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,121
    Blog Entries
    51
    amazing.. i'm thinking its somethin to do with an .ini setting or my flash code but all it was is the deminion of an invisible list needed to be changed. Demensions were 0,0,0,0 but i switched it to -1000,-1000,1000,1000 in the .skin file and it works fine.. good call guino!
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  4. #4
    FLAC Sal R.'s Avatar
    Join Date
    Aug 2006
    Location
    Sun Diego
    Posts
    1,448
    Wow. That's cool. I wish I could get my playlist to display like that.
    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

Similar Threads

  1. Replies: 10
    Last Post: 09-03-2007, 10:19 AM
  2. Girder & winamp playlist question
    By michaelrj9 in forum Software & Software Development
    Replies: 0
    Last Post: 03-12-2006, 08:11 PM
  3. Format Options?
    By Cheekz185 in forum General MP3Car Discussion
    Replies: 1
    Last Post: 09-29-2005, 06:15 PM
  4. playlist
    By robr in forum MediaCar
    Replies: 0
    Last Post: 05-27-2004, 12:40 PM
  5. playlist necessary? (philosophical)
    By crippy in forum Software & Software Development
    Replies: 22
    Last Post: 10-16-2003, 02:39 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •