Results 1 to 7 of 7

Thread: Does SETLIST actually SELECT the item in the list?

  1. #1
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,169
    Blog Entries
    53

    Does SETLIST actually SELECT the item in the list?

    Trying to get some clarification on the SETLIST command. I understand how to use it and what it does basically... i'm just tryin to figure out if it actually selects the item being jumped to in the playlist. For some reason my flash audio browser code no longer works as intend. the command run is "SETLIST;$LISTNUM||SELECT" but this no longer loads a playlist of the list number set by SETLIST. Used to.. but doesnt anymore. What gives?
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  2. #2
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,169
    Blog Entries
    53
    i did some more testing.. this only seems to be a problem when i'm trying to load directories. Playlist files and audio files still work as they used to.. but if i wanna load my entire "Country" folder it doesnt load like it used to.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  3. #3
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,169
    Blog Entries
    53
    more testing.. it definitely has something to do with the "BROWSE" command.. apparently.. it no longer updates the CUSTOMDL label. My code for this skin hasnt changed in months and now:

    1. i cant use SELECT on a folder to play that folder
    2. i cant use BROWSE to see the subdirectories in that folder.

    I'm wondering why other people using flash skins arent having the same problem. I basically use the same playlist code that CDR used in most of his flash stuff.
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  4. #4
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,169
    Blog Entries
    53
    Issue solved.. it was sometin in the .skin file causing the problem!
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  5. #5
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    WOW...an entire thread for a prob and only has 4 posts by the same person, starting at the prob and ending with a solution..w/o any interuptions....LOL

    Talk to yourself often do ya...
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  6. #6
    Variable Bitrate proph's Avatar
    Join Date
    Aug 2005
    Location
    Little Elm, Texas
    Posts
    422
    hey be quiet Blue... he's not talking to you...
    Setup:
    Dynaudio 240GT
    PPI PC4100, PPI PC2350
    Zapco DSP6
    ADS DAC
    Testing new board (Albatron KI690-AM2)

    "I dont know if complaints were filed, or mistakes were made, but feelings were hurt." -Krystal Washington

  7. #7
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,169
    Blog Entries
    53
    Quote Originally Posted by Blue ZX3 View Post
    WOW...an entire thread for a prob and only has 4 posts by the same person, starting at the prob and ending with a solution..w/o any interuptions....LOL

    Talk to yourself often do ya...

    the really sad part is i spent 3 hours destroying about 10 hours worth of flash code that i didnt back up while going thru this crap. The problem ended up being nothing but an (SD) line in the .skin file i must have added when trying the coverflow plugin lol. So now its back to the drawing board~!
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

Similar Threads

  1. iGuidance Hacks
    By pbarrette in forum GPS
    Replies: 47
    Last Post: 12-28-2007, 04:06 PM
  2. Multiple Font Colors in List Panel
    By Ioloughlin in forum DigitalMods (Scripts / API)
    Replies: 0
    Last Post: 09-05-2007, 12:48 PM
  3. XM list highlight lags behind current station
    By Hark in forum Road Runner
    Replies: 4
    Last Post: 04-20-2006, 03:00 PM
  4. Software announcement for small composite LCDs
    By chainsaw76 in forum Software & Software Development
    Replies: 4
    Last Post: 07-15-2000, 08:00 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •