Results 1 to 8 of 8

Thread: text color problem

  1. #1
    Variable Bitrate
    Join Date
    Jan 2007
    Location
    East Central FLA
    Posts
    241

    text color problem

    I have managed to get RoadRunner working perfectly on 4 machines now. However I just switched to a new machine at home that I use to work on skin ideas among other tasks. Everything functions fine except that I can't get text colors to come out right. When I move the skin to my car, the colors come out as intended.

    I seem to be stuck in the blues (both literally and figuratively). I get blue text when I tried for red in a label on the menu.skin

    It's also happening in a directory list I use in my audio browser. Black text seems to work, and white text seems to work, but if I put in reds, oranges, greens, they all come out the same shade of blue.

    No other program seems affected, including both graphics (Photoshop, Irfanview), text (Word), and browsers like I'm typing this into now.

    It's pretty much a basic install, no tweaking of anything except through RoadRunner Config - and those settings mimic what's working fine in the car.

    Any ideas on what I may have screwed up?

  2. #2
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Weird issue... try making a screenshot of how it looks in a machine that works right, then another of the machine that doesn't work right... before anything, I would check the screenshot files in different machines to see if they look different.. Most labels in RR use standard VB6 functions to choose the color, so it should not be an issue. In any case, check your display settings for color depth -- it may have something to do with that.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #3
    Variable Bitrate
    Join Date
    Jan 2007
    Location
    East Central FLA
    Posts
    241
    Thanks for looking in Guino.

    Here's a line I added, just to illustrate, from the machine that I'm having trouble with:

    L,302,125,457,51,255,0,0,28,"Arial:B","PLAYLIST"," CENTER"

    and here's a screen cap of the display on the "bad" machine (the text in question is the "In the Studio").



    I tried changing the color depth from 32 to 16 (the only choices I see in the ATI control panel). No help, still a shade of blue (and it's always this same shade). You can see that black text comes out OK as the song length and remaining time, as well as the artist name and song title come out OK. Text labeled as white comes out OK too. But if I pick any color other than black or white, I get this shade of blue.

    In my car (Dell laptop), the text comes out red, as one would expect with a color setting of 255,0,0

  4. #4
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    This is puzzling.. seems like VB6 is not being aware of the correct colorspace.

    Would you change "CENTER" to "SCROLL" And see if it works ? (Scroll labels are API-Based -- non-dependent of VB6's handling).
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  5. #5
    Variable Bitrate
    Join Date
    Jan 2007
    Location
    East Central FLA
    Posts
    241
    Let me be the 1 millionth customer - You be the man

    That fixed it...now if you can do one more thing to help a fool like me, what files do I need to load to bring VB6 to full functionality?

  6. #6
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    I dont recommend (by any means) making a bunch of scrolling labels on your skin.

    If you're talking about fixing the issue, all I can suggest is that you try to download the latest VB6 runtime files from Micro$oft.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  7. #7
    Variable Bitrate
    Join Date
    Jan 2007
    Location
    East Central FLA
    Posts
    241
    Quote Originally Posted by guino View Post
    I dont recommend (by any means) making a bunch of scrolling labels on your skin.

    If you're talking about fixing the issue, all I can suggest is that you try to download the latest VB6 runtime files from Micro$oft.
    thanks, that makes sense as one or more may have gotten corrupted overwritten as I installed software on the machine.

  8. #8
    Variable Bitrate
    Join Date
    Jan 2007
    Location
    East Central FLA
    Posts
    241
    Update: Turns out the problem is with the ATI Catalyst Control Center software (ATI PCI-E video card) that I use to drive an extended desktop across two LCDs. I have no idea why it's stepping on RR like that, but I can live with it since it doesn't do anything to the files themselves, so they look OK in the car.

Similar Threads

  1. Phone style text input applet (with Source code!)
    By Dominik in forum Software & Software Development
    Replies: 48
    Last Post: 05-19-2008, 06:58 PM
  2. iGuidance Hacks
    By pbarrette in forum GPS
    Replies: 47
    Last Post: 12-28-2007, 04:06 PM
  3. changing pictures & names on skins
    By michaelrj9 in forum RR Skins
    Replies: 24
    Last Post: 01-10-2007, 01:48 PM
  4. Centrafuse 1.6 Bugs
    By Mbai2 in forum CF Bug Reports
    Replies: 57
    Last Post: 05-10-2006, 11:30 AM
  5. mouse over text (feature req)
    By liquid_smoke in forum Road Runner
    Replies: 2
    Last Post: 12-11-2005, 07:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •