Results 1 to 10 of 10

Thread: Skin Embedding Application Problem

  1. #1
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,701
    Blog Entries
    1

    Skin Embedding Application Problem

    Has anyone else experienced problems embedding applications into RR? What I mean, is I have a Program that I wrote in AutoIt. The AutoIt GUI is 800 x 525. This allows the 75 pixels at the bottom of the screen, for the skin buttons. I then created an Application area in the skin that is 800 x 525. When I load the skin, the application embeds, but it is not staying in the defined application area, and is roughly 575 in height, covering all but a small portion of the buttons at the bottom of the screen.

    How can an application extend outside of an embedded app area, defined in the skin, and still actually be embedding?

    Any help is greatly appreciated!
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  2. #2
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,166
    Blog Entries
    52
    i have no idea HOW it does it but i noticed the same behavior in b8boi's businav application. I never saw any solutions to it though. Thats coded in auto it too fwiw
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  3. #3
    MySQL Error MatrixPC's Avatar
    Join Date
    Sep 2003
    Location
    Beach City, Socal
    Posts
    4,053
    I think it got something to do with auto it.
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 600E@750/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

  4. #4
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,701
    Blog Entries
    1
    Possibly, just strange how you set the dimensions of the window, and they are perfect outside of RR, then when you try to embed, it overlaps the application area that is defined in the skin.
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  5. #5
    THE EXPERIMENTER
    Auto Apps:loading...
    carputer1's Avatar
    Join Date
    Sep 2007
    Location
    UK,Surrey
    Posts
    1,979

    i had this

    with Trafficcams
    Riderunner / Genesis
    Plugin Breaker in test BassRR Plugin Player, Wifiman_NET
    New Home for Genesis & BassRR :adding to site ,, Hellfyre night
    Bassrr Beta Release :Version 1.3.7
    Movie_info Release :Version 3.1.0
    Wifiman_NET:Version 1.0.0

    Every Future, Needs A Beginning

  6. #6
    Super Moderator
    Auto Apps:loading...
    JohnWPB's Avatar
    Join Date
    Sep 2005
    Location
    West Palm Beach, Florida
    Posts
    4,701
    Blog Entries
    1
    I have had this happen with Traffic Cams(Not sure what its written in), Google Earth, Road Runner Cam(Written in VB6), multiple AutoIt GUI's.... So I do not thing that it's strictly an AI problem at this point.
    Front End of Choice: Ride Runner (Is there anything else??? ) & Powered by the DFX5.1 Skin Available in the Mobile App Mart

    My Fiero Build Thread

  7. #7
    FLAC djmickyg's Avatar
    Join Date
    Feb 2004
    Posts
    1,314
    is this a new problem you are seeing??
    because i just formated my desktop PC so I've re installed RR with the newest version, and i was trying to embed destinator 7 into a window, something I've done many times with different apps. and the window was sizing larger than the size in the skin file also.. i thought it was a little strange, but then i read this.

  8. #8
    THE EXPERIMENTER
    Auto Apps:loading...
    carputer1's Avatar
    Join Date
    Sep 2007
    Location
    UK,Surrey
    Posts
    1,979

    D7

    Quote Originally Posted by djmickyg View Post
    is this a new problem you are seeing??
    because i just formated my desktop PC so I've re installed RR with the newest version, and i was trying to embed destinator 7 into a window, something I've done many times with different apps. and the window was sizing larger than the size in the skin file also.. i thought it was a little strange, but then i read this.
    dose not like to be embeded like you would some other app, i had to use skinbedder app created by someone else to get it to work right. its different to D6 which can be embeded correctly.
    Riderunner / Genesis
    Plugin Breaker in test BassRR Plugin Player, Wifiman_NET
    New Home for Genesis & BassRR :adding to site ,, Hellfyre night
    Bassrr Beta Release :Version 1.3.7
    Movie_info Release :Version 3.1.0
    Wifiman_NET:Version 1.0.0

    Every Future, Needs A Beginning

  9. #9
    Variable Bitrate chevyn8's Avatar
    Join Date
    Oct 2006
    Location
    small town nebraska
    Posts
    263
    On my snes9x embed, I have to give snes9x a 'fullscreen' command to get it to embed correctly. When I do that RR grabs it and embeds correctly. Also, if I don't do the fullscreen...the app doesn't embed correctly...then as soon as I move the app just the smallest amount...RR grabs it and embeds. This may or may not be the same issue you are having.
    CarPC in my 82 Camaro. Dual core atom, M4-ATX, 7 lilliput, bu353 GPS, Reborn skin, punch 40/100ix
    MediaLaunch for RR
    Online Check for RR
    Locker for RR

  10. #10
    Wants to make it harder monkeyracer's Avatar
    Join Date
    May 2007
    Location
    Lakehood, CO
    Posts
    1,463
    Did you try to make the embed area 25 pixels shorter to compensate? I know that's not an ultimate fix, but maybe something temporary.

    I know I had an issue with an app, but only when I first tried to get into that screen. I'd go back to the previous and reload the screen I wanted and it embedded correctly...
    2007 Chrysler PT Cruiser TE
    Car PC Progress:
    Planning.......[---------X-] 95%
    Parts...........[---------X-] 90%
    Fabrication...[---------X-] 90%
    RR Skin........[---------X-] 95%
    View my
    Worklog
    Road Runner Skins
    Website
    Favorite thread EVER!

Similar Threads

  1. problems with navigation in streetdeck
    By customaudioman in forum StreetDeck
    Replies: 3
    Last Post: 01-25-2008, 12:46 PM
  2. How to load a defined application into a skin?
    By JohnWPB in forum Road Runner
    Replies: 9
    Last Post: 09-05-2006, 09:18 AM
  3. Roadrunner Skinning Tutorial
    By Meelobee in forum RR Skins
    Replies: 14
    Last Post: 12-30-2005, 07:28 PM
  4. Rescaling skin an song position slider problem
    By Passe in forum RR Bug Tracker
    Replies: 3
    Last Post: 02-23-2005, 11:34 PM
  5. "Lagging" problem with skin?
    By Jisc in forum Road Runner
    Replies: 1
    Last Post: 02-21-2005, 10:35 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •