Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Why does RR seem like its in slow motion?

  1. #1
    Maximum Bitrate CarComp's Avatar
    Join Date
    Oct 2001
    Location
    Indiana
    Posts
    515

    Why does RR seem like its in slow motion?

    I'm running a PIII 1.x GHZ with 512 MB of ram, winXP pro, geforce 3 video, and an ata100 hard drive. I was trying out RR to see what all the talk is about. I am impressed with abundance of features, but why is it so slow? When I load a flash skin it won't even load right, (crystal blue) and when I use a normal one (like LSX void), it seems like there is a lot of lag when you click buttons. I looked through the source and I haven't noticed anything that would cause it to slow up, unless the graphics are huge and getting loaded on command, and not beforehand.

    Would using that pre-load stuff in the rrconfig help with this issue? How would that do anything for flash skins?

    Also, why does rrconfig take 10 seconds to load before anything even shows? It should have a splash screen so you don't try to run it again if its going to take that long. A lot of working class people can't afford a new dual core 2 ghz machine or even the latest mini itx wonders. I'd think anything written in an older language (like vb6) should take into consideration the age of its language.

    I'm not dogging on roadrunner, but I wanted to give it a good try (i've been playing with it for about 30 minutes a day before work for 2 weeks now trying skins and such) and while its got a LOT of well functioning features, and hardly any bugs, its kinda slow? Any conferrance for people using similarly paced PCs?
    Get MediaEngine !!!
    Media Engine Download

  2. #2
    Wants to make it harder monkeyracer's Avatar
    Join Date
    May 2007
    Location
    Lakehood, CO
    Posts
    1,463
    Try out a smaller skin first, say for example my mAv1c skin, just to see if it works faster. It's got no flash, and it's only 2.5MB total, so the CPU doesn't have to load a whole bunch of images. It was designed for the average joe shmoe carpc user. If it is still slow with a skin like that, then something is configured wrong.
    RR Config shouldn't take 10 sec. to start, it's a fairly simple program, and that's why there's no splash screen. Spend a few minutes in the RR FAQ, the answer may already be waiting for you.

    Not sure you've seen this:

    http://www.mp3car.com/vbulletin/rr-f...-too-fast.html

    or this:

    http://www.mp3car.com/vbulletin/rr-f...ad-runner.html
    2007 Chrysler PT Cruiser TE
    Car PC Progress:
    Planning.......[---------X-] 95%
    Parts...........[---------X-] 90%
    Fabrication...[---------X-] 90%
    RR Skin........[---------X-] 95%
    View my
    Worklog
    Road Runner Skins
    Website
    Favorite thread EVER!

  3. #3
    FLAC -zip-'s Avatar
    Join Date
    Sep 2004
    Location
    Ontario/Canada
    Posts
    1,293
    You have a PIII running XPPro, what do you expect? Do yourself a favor, if you can afford it upgrade. A new Little Valley mobo is only 70 bucks, mem is cheap etc. Can you afford about 300 bucks? I know it may not be an option, but if possible I highly recommend it.
    2008 350z GT Installed since April 22nd 2011 - Worklog
    2000 Protege Installed Since April 2, 2005 - Intel D201GLY|Fusion Brain|ODBPros ODBII|Engenius|GPS Rikaline|Powermate|Motorized Lilli
    Sound Stage
    Eclipse|MTX|Infinity

  4. #4
    Maximum Bitrate CarComp's Avatar
    Join Date
    Oct 2001
    Location
    Indiana
    Posts
    515
    I expect a simple program like RR with flash to run at warp speed. thats what I expect. I don't think its my processor b/c I don't have any trouble with any other programs. I compile MediaEngine, open photoshop, open websites and play fullscreen games (unrelated hardware speed to 2d) with no speed issues.

    My older computer runs circles around my other P4 pc. Its like comparing a vintage ferarri to a brand new (put your bland vanilla car here). Back in the day a PIII 1.x ghz machine with 512Kb cache and 512 mb pc133 and a 250 GB HD running at ata100 with XP should be able to handle anything. The only thing that bogs it down is compiling XPembedded stuff.

    As for trying different settings, I suspected as much. Visual basic is kinda crappy at managing memory with images, and the images for some reason just slow it down. I had that problem with MediaEngine, and it turned out that some of the skins had HUGE images (like 1440x1200) or something similar that were being scaled down to fit whatever small monitor they were being shown on (800x600), but they would still eat up a huge image's worth of ram. So my answer was to either re-render the skin's images in photoshop, or live with slowness. I think a cool feature for rr would be able to re-render the images from RRconfig, or have it be a separate program. Again I want to stress that I am at work, and don't have my pc with RR installed so i'm just going by what I know and have seen lately.

    And one last question... WHY THE HECK IS FLASH SLOW? I mean its not 3d, its simple effects, and it will bring almost any computer to its knees if there is enough of it (try opening multiple browsers with games on them on your super duper dual core whatevers) and watch it slow to a crawl.
    Get MediaEngine !!!
    Media Engine Download

  5. #5
    Wants to make it harder monkeyracer's Avatar
    Join Date
    May 2007
    Location
    Lakehood, CO
    Posts
    1,463
    most of the images in the mAv1c skin are under 100kb, and the largest overall file to load is an overlay menu that is 346kb. Try out this skin to see if it is still slow.

    Quote Originally Posted by treetop777 View Post
    Darn thing downloaded in a second - Amazing!
    Quote Originally Posted by treetop777 View Post
    It's just getting better and better.
    As usual, she's still responsive and lighning quick. Let me go load her up in the truck and give her a workout.
    I've yet to have anyone report anything running slow.

    Not trying to endorse using my skin, but if it's still slow on one of the lightest skins ever, then there's something wrong with your system.
    2007 Chrysler PT Cruiser TE
    Car PC Progress:
    Planning.......[---------X-] 95%
    Parts...........[---------X-] 90%
    Fabrication...[---------X-] 90%
    RR Skin........[---------X-] 95%
    View my
    Worklog
    Road Runner Skins
    Website
    Favorite thread EVER!

  6. #6
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,049
    As for why flash is slow, do you have the ocx file registered?

    I think it is mentioned in the 100% CPU with RR thread.
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

  7. #7
    Variable Bitrate Jebus's Avatar
    Join Date
    Dec 2007
    Location
    Washington, USA
    Posts
    312
    I'm running RR and DFX3 on a P3 400 mhz Kontron card PC with 256 megs of ram and it runs flawlessly. You have to get the flash.ocx issue taken care of. Read the FAQ's and that p3 1000 will fly. When you get it going in DFX you can change it to remove some of the flash that you dont care for.
    ...JJG

  8. #8
    Wants to make it harder monkeyracer's Avatar
    Join Date
    May 2007
    Location
    Lakehood, CO
    Posts
    1,463
    I vote for the fact he has something configured wrong. I've seen some crazy skins runs fine on "lesser" systems. It's all a matter of making sure it's set up right.
    2007 Chrysler PT Cruiser TE
    Car PC Progress:
    Planning.......[---------X-] 95%
    Parts...........[---------X-] 90%
    Fabrication...[---------X-] 90%
    RR Skin........[---------X-] 95%
    View my
    Worklog
    Road Runner Skins
    Website
    Favorite thread EVER!

  9. #9
    FLAC
    Auto Apps:loading...
    EL CAMINO's Avatar
    Join Date
    Jul 2005
    Location
    upland california us
    Posts
    1,283
    i have tested a couple of skins in a PIII 850 with 512mb ram, and didnt have any issues with DFX nor LSX VOID, so like every one is suggesting , might be something on your setup. i would even try to make an nlited xp(thats what i did to make my PIII faster) or another way cut be to just boot directly to RR.

  10. #10
    Variable Bitrate chevyn8's Avatar
    Join Date
    Oct 2006
    Location
    small town nebraska
    Posts
    263
    Yep, look at the performance tweaks... What fixed mine was lowering the Hardware acceleration a couple notches.

    "Back in the day a PIII 1.x ghz machine with 512Kb cache and 512 mb pc133 and a 250 GB HD running at ata100 with XP should be able to handle anything."
    That was Back in the day, not present time. However RR should work ok with those specs. My P4 will handle it and isn't much better (if any) than your P3.
    CarPC in my 82 Camaro. Dual core atom, M4-ATX, 7 lilliput, bu353 GPS, Reborn skin, punch 40/100ix
    MediaLaunch for RR
    Online Check for RR
    Locker for RR

Page 1 of 2 12 LastLast

Similar Threads

  1. Lsx Void 3.0
    By liquid_smoke in forum RR Skins No Longer Supported
    Replies: 3171
    Last Post: 12-11-2013, 03:05 AM
  2. RR Video Issue.....
    By grnLude in forum Road Runner
    Replies: 9
    Last Post: 05-20-2008, 12:24 PM
  3. Three questions regarding RR, winamp, gps
    By Profozone in forum Road Runner
    Replies: 6
    Last Post: 02-18-2008, 07:53 AM
  4. Replies: 11
    Last Post: 11-26-2007, 01:22 AM
  5. RR really slow and unresponsive..
    By Pheebs'67 in forum Road Runner
    Replies: 2
    Last Post: 01-04-2006, 11:25 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •