Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: Winamp randomize in roadrunner

  1. #11
    Maximum Bitrate Valheru's Avatar
    Join Date
    Jul 2007
    Location
    Ireland
    Posts
    604
    Quote Originally Posted by 4puteruser View Post
    Is there a way to automatically have this button/action be performed every time the computer resumes from Hibernation. That way the user doesn't have to do anything.
    Yes ... in the file called "ExecTBL.ini" in the skin folder put this line ...
    "ONSKINSTART","ACTIVATE;Playlist Editor||SENDKEY;^+r||RELOADLIST"


    Quote Originally Posted by 4puteruser View Post
    And I am having issues with the Video random/shuffle feature. It doesn't seem like it is working properly. I did a quick search, and nothing substantial regarding the video shuffle issue..

    Thanks
    I don;t think the "SHUFFLE" function works on video. Looking at the skin commands this is what is in there for the "SHUFFLE" command ...
    "SHUFFLE/REPEAT"- Cycles through the Shuffle/Repeat settings (Music only)

    There are commands available in the Media Player Classic to Shuffle and Randomize, but there are no shortcuts (or keystrokes) available to do this which could be sent from RR ... so I'm not sure how you'll manage to do this for video.
    -------------------------------
    The TEKNIK Family ... Teknik 1 & Teknik 2, Teknik T-3, Teknik v4.0, Teknik-X.

  2. #12
    THE EXPERIMENTER
    Auto Apps:loading...
    carputer1's Avatar
    Join Date
    Sep 2007
    Location
    UK,Surrey
    Posts
    1,978
    for video shuffle this is the rr cmd for it

    SHUFFLEVIDEO

    but i have never seen it used as of yet or tryed it myself, so i'm not sure if it will work with MPC or the rr built in player. its trial and error on that 1.
    Riderunner / Genesis
    Plugin Breaker in test BassRR Plugin Player, Wifiman_NET
    New Home for Genesis & BassRR :adding to site ,, Hellfyre night
    Bassrr Beta Release :Version 1.3.7
    Movie_info Release :Version 3.1.0
    Wifiman_NET:Version 1.0.0

    Every Future, Needs A Beginning

  3. #13
    Newbie
    Join Date
    May 2007
    Location
    Duarte, CA
    Posts
    27
    I hate to sound like a pain, but after I added the code
    "ONSKINSTART","ACTIVATE;Playlist Editor||SENDKEY;^+r||RELOADLIST"

    all my button text disappeared and the buttons don't work (except for audiopause, forward, etc.) Music, video, radio, gps, buttons are not responding. if i remove the code, everything works fine. i have tested this on two seperate computers. is this a bug that has been posted, but I haven't found the solution for?
    the music is re-shuffled on every RESUME, which was the ultimate goal, but not very beneficial if none of the other features work.
    thanks for all your help.

  4. #14
    THE EXPERIMENTER
    Auto Apps:loading...
    carputer1's Avatar
    Join Date
    Sep 2007
    Location
    UK,Surrey
    Posts
    1,978
    do you have an onskinstart line already in your exctbl file, you can only have 1 line called onskinstart,

    you must add the line in the above to your origanal onskinstart line just || , then your line.
    Riderunner / Genesis
    Plugin Breaker in test BassRR Plugin Player, Wifiman_NET
    New Home for Genesis & BassRR :adding to site ,, Hellfyre night
    Bassrr Beta Release :Version 1.3.7
    Movie_info Release :Version 3.1.0
    Wifiman_NET:Version 1.0.0

    Every Future, Needs A Beginning

  5. #15
    Maximum Bitrate Valheru's Avatar
    Join Date
    Jul 2007
    Location
    Ireland
    Posts
    604
    hummm I hadn't though of that carputer1 ,,, but if that doesnt work, then I'm out of ideas apart from putting the cde onto a button and manually sending a random command to winamp ...
    -------------------------------
    The TEKNIK Family ... Teknik 1 & Teknik 2, Teknik T-3, Teknik v4.0, Teknik-X.

  6. #16
    Newbie
    Join Date
    May 2007
    Location
    Duarte, CA
    Posts
    27
    Quote Originally Posted by carputer1 View Post
    do you have an onskinstart line already in your exctbl file, you can only have 1 line called onskinstart,

    you must add the line in the above to your origanal onskinstart line just || , then your line.
    Ok, well here is a really stupid question...
    I added the code inside the RRConfig, but there are two ExecTbl files... one in RoadRunner root directory, and one in the DigitalFX skin folder. The RRConfig sub-menu doesn't have any code already written in it, except for the code supplied by Valheru.

    This is the only thing preventing me from continue to using HORM... and I really want the 10second start up time. Please help!!

  7. #17
    Maximum Bitrate Valheru's Avatar
    Join Date
    Jul 2007
    Location
    Ireland
    Posts
    604
    you need to add the code to the exectbl.ini file that is inside the DigitalFX folder. Do this by hand. RRConfig looks at the exectbl.ini file in the main roadrunner folder - which is NOT the one you want.

    remove any code you have in the exectbl.ini section of the rrconfig program as well ...
    -------------------------------
    The TEKNIK Family ... Teknik 1 & Teknik 2, Teknik T-3, Teknik v4.0, Teknik-X.

  8. #18
    THE EXPERIMENTER
    Auto Apps:loading...
    carputer1's Avatar
    Join Date
    Sep 2007
    Location
    UK,Surrey
    Posts
    1,978
    the 1st line in DFX skin exectble looks like this add val's line like this

    "OnSkinStart","ExtraPrograms||RMBVars||SetApps||Se tCommandLabels01||SetAppLabels||SetIcons||PresetLo ader||IGSettingLoader||SetLottoBlank||Randomize"

    then below add this

    "Randomize","ACTIVATE;Playlist Editor||SENDKEY;^+r||RELOADLIST"

    should do the job for you
    Riderunner / Genesis
    Plugin Breaker in test BassRR Plugin Player, Wifiman_NET
    New Home for Genesis & BassRR :adding to site ,, Hellfyre night
    Bassrr Beta Release :Version 1.3.7
    Movie_info Release :Version 3.1.0
    Wifiman_NET:Version 1.0.0

    Every Future, Needs A Beginning

  9. #19
    Newbie
    Join Date
    May 2007
    Location
    Duarte, CA
    Posts
    27
    that certainly fixed the missing text and no activity on the buttons, but i also forgot to mention that the text for mp3 info does not match with the song that is playing. The text will correct itself once you go into the music button -> playlist view. but if i exit out of RoadRunner, and return, the same song is playing, and once i skip to the next track in the main menu, the next song does not match with the mp3 info displayed at the top.

    how can i "refresh" the mp3 info after the playlist has been reshuffled? better yet... where do you guys pick up all this information so i can stop bugging you for a fix. i feel like i am cheating with you guys doing all the work, and i just have to implement it

  10. #20
    THE EXPERIMENTER
    Auto Apps:loading...
    carputer1's Avatar
    Join Date
    Sep 2007
    Location
    UK,Surrey
    Posts
    1,978
    Quote Originally Posted by 4puteruser View Post
    where do you guys pick up all this information so i can stop bugging you for a fix. i feel like i am cheating with you guys doing all the work, and i just have to implement it
    1= i had that problem as well at some point but i forgot what i did to solve it

    2= its all about the forums , questions are always asked repeatedly, but its a matter of find the info you want, you may have an idea what to do, the code is out there but not in they way you want it to do your idea, its a matter of working out work part of 1 code and maybe another part of another code. its really like a jigsaw puzzle.

    but the more you read and play the easyier it gets,

    also reading skin files works really good, load the skin up press a button, and mmmm
    i could do somthing with that ,then start to follow the code till you find the start and finish,

    9 times out of 10 the button is a call cmd, the call cmd and code you will find in the exectl.ini, or no call cmd ,but code in skin file instead.

    at the end of the day, thier are people who are more advanced at this and newbies (sorry bad name really)just learning, but we are all learning all the time

    sorry going on a bit lol...
    Riderunner / Genesis
    Plugin Breaker in test BassRR Plugin Player, Wifiman_NET
    New Home for Genesis & BassRR :adding to site ,, Hellfyre night
    Bassrr Beta Release :Version 1.3.7
    Movie_info Release :Version 3.1.0
    Wifiman_NET:Version 1.0.0

    Every Future, Needs A Beginning

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. Problem: Winamp don't start from Roadrunner
    By l1nk in forum Road Runner
    Replies: 9
    Last Post: 09-09-2008, 04:46 PM
  2. Winamp Higher cpu Usage with Roadrunner
    By same0l679 in forum Newbie
    Replies: 1
    Last Post: 02-04-2008, 10:07 AM
  3. Roadrunner, Winamp, Playlists and RIPing...
    By N6BER in forum Road Runner
    Replies: 4
    Last Post: 04-24-2007, 10:56 AM
  4. RoadRunner, Winamp, PhoneCo, Bluetooth, Window Hibernation, which one?
    By MatrixPC in forum Software & Software Development
    Replies: 9
    Last Post: 11-25-2005, 10:25 AM
  5. Running RoadRunner and Winamp
    By MatrixPC in forum Road Runner
    Replies: 7
    Last Post: 02-09-2005, 08:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •