Results 1 to 9 of 9

Thread: volume level on resume from hibernate

  1. #1
    Variable Bitrate
    Join Date
    Apr 2004
    Posts
    409

    volume level on resume from hibernate

    sometimes when I resume from hibernate the volume level in the mixer for whatever I'm using i.e. digital in for Sirius, or winamp for music is all the way down. What would lower the volume on these things when I resume from hibernate? I tried "roadrunner is aware of hibernate etc etc" in the config tool and it really doesn't seem to affect anything.

    thanks

  2. #2
    Maximum Bitrate fixerofallthing's Avatar
    Join Date
    May 2005
    Location
    Lawrenceville GA
    Posts
    769
    Quote Originally Posted by turbochris View Post
    sometimes when I resume from hibernate the volume level in the mixer for whatever I'm using i.e. digital in for Sirius, or winamp for music is all the way down. What would lower the volume on these things when I resume from hibernate? I tried "roadrunner is aware of hibernate etc etc" in the config tool and it really doesn't seem to affect anything.

    thanks
    try turning off the fade in volume on resume setting in RRConfig. It fixed it for me.
    The Car 2005 Scion xB

    The Truck 2004 GMC Canyon

  3. #3
    FLAC Griff1's Avatar
    Join Date
    Nov 2005
    Location
    Midlands
    Posts
    1,052
    Yeah i had the same thing.
    P4 2.8 HT, 512Mb Ram, 60Gb 2.5 HD, M4-ATX, SB Audigy2, BU353, Lilliput TS,Soundgraph Imon VFD,SONY Optiarc dvd Burner,RideRunner, iGo8, Custom Freedom 2.1

  4. #4
    Maximum Bitrate
    Join Date
    Nov 2005
    Posts
    597
    RR raises the volume of winamp from 0 up to where it was previously. you can actually watch winamps vol slider go up (if the winamp window is visible). you may also try disabling volume control (Preferences>output plugins>Directsound>configure>Other>Volume Control) on the winamp side of things, and it might make winamp locked into full (100%) volume at all times.

  5. #5
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    DONT USE VOLUME FADE!!!! its conceptually bugged... would need a complete rewrite of audio management in RR

    fadeinvolume=false

    UNLESS!
    you are using winamp FOR ALL AUDIO MANAGEMENT
    ie. all sources use winamp, like XM, Sirius, HD and etc. must use the WINAMP LINE IN PLUGIN
    and NOT the Windows mixer
    THEN fade would be OK
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  6. #6
    Newbie
    Join Date
    Feb 2007
    Posts
    30
    Quote Originally Posted by mitchjs View Post
    DONT USE VOLUME FADE!!!! its conceptually bugged... would need a complete rewrite of audio management in RR

    fadeinvolume=false

    UNLESS!
    you are using winamp FOR ALL AUDIO MANAGEMENT
    ie. all sources use winamp, like XM, Sirius, HD and etc. must use the WINAMP LINE IN PLUGIN
    and NOT the Windows mixer
    THEN fade would be OK
    Mitch,
    Do you know why it works sometimes but not others? I don't mind turning it off, but I do enjoy the effect. Thanks!

  7. #7
    Maximum Bitrate
    Join Date
    Nov 2005
    Posts
    597
    I think it has something to do with not getting focus on the winamp window for long enough to issue the fade=in command. It switches back to RR focus to early, in some cases. But thats only a guess based on what I have observed.

  8. #8
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    yes... i know exactly why it doesnt work...
    hard to explain... i would rewrite it if it was easy...
    its because how audio is managed in RR all together
    some audio is MIXER managed, and MP3s are WINAMP managed
    prob should all be dumped, for say a single audio system, like BASS Audio Library
    but if u use winamp for EVERYTHING (XM, HD, Sirius) and RR not touching the mixer for volume... it might work... its also tied to the fact that RR resumes last source as MP3 (now thats fixed in my version)

    also the volume isnt tracked by RR, it assumed to be in winamp... and winamp volume 0-255 has NOTHING to do win MIXER VOLUMES 0 -65535, so i see the mixer volumes get so messed up

    just dont use it

    audio VOLUME should be managed at 1 point!! which its not

    prob could do a work around fix, the keep RR from touching the LINE IN VOLUMES
    but then they wouldnt fade up, just like i dont think it should be touching WINAMP volume, volume should be controled at the OUTPUT side, not on a SOURCE
    source meaning mixer input, winamp

    not to mention VISTA audio management, which is ACTUALLY AWESOME!

    maybe a rewrite to RR to fade volume with MASTER, it might work

    i know, i dont know enough about RR, i dont use RR (im not carpc nut, hehe), but i have been deep in RR code alot lately


    mitch

    mitch
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  9. #9
    Newbie
    Join Date
    Feb 2007
    Posts
    30
    Yeah, I think taking the Hardware Abstraction Layer away in Vista was a good move, even if a lot of manufacturer's hated it. Simpler for applications. Thanks for the information.

Similar Threads

  1. Hibernate and Vis and Resume
    By RichP714 in forum RR Bug Tracker
    Replies: 7
    Last Post: 09-22-2007, 02:43 AM
  2. Set Volume at Start and Resume from Hibernate
    By efficinet in forum Software & Software Development
    Replies: 3
    Last Post: 02-01-2007, 09:33 AM
  3. Resume after hibernate scrutinized
    By ldave in forum PowerVoice
    Replies: 6
    Last Post: 02-09-2006, 11:04 PM
  4. Resume from hibernation, Volume level at 0
    By blackflux in forum General Hardware Discussion
    Replies: 13
    Last Post: 04-08-2005, 02:19 PM
  5. Audigy 2 NX full volume after resume
    By STI_FFY in forum Car Audio
    Replies: 4
    Last Post: 11-22-2004, 09:38 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •