Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: How can I get Garmin and HD Radio to start when RR starts?

  1. #1
    Constant Bitrate mstaedt's Avatar
    Join Date
    Dec 2007
    Posts
    164

    Question How can I get Garmin and HD Radio to start when RR starts?

    The way it currently works is.. when I open RR to the menu.skin, the radio doesn't come on, I have to go to the radio_player.skin first. Also, I want Garmin Mobile PC to start up in the background and get past its splash screen so when I open the GPS skin, GMPC is already there. I tried to preload radio_player.skin, but that doesn't start the radio. Maybe I'm not doing it right.

    I'm using my own skin which includes Monkeyracer/ElCamino/Thunderstick's GMPC overlay and OSK and MitchJS's cable and Visteon for the radio.

    Thanks....
    Mark
    --------------------------------
    Project completed! (almost)

    My Truck as featured in Custom Classic Trucks magazine.

  2. #2
    FLAC Machinehead's Avatar
    Join Date
    Jun 2007
    Location
    hijacks small portable city
    Posts
    1,381
    You want to add the radio skin to the ONSTART command in the exectbl.ini.

    Pre-loading the GMPC skin will fix your other issue.

  3. #3
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,114
    Blog Entries
    49
    what version (date) of RR are you using? The latest version will resume whatever device was last played (mp3, xm, radio)
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  4. #4
    FLAC Machinehead's Avatar
    Join Date
    Jun 2007
    Location
    hijacks small portable city
    Posts
    1,381
    That only works if the resume.ini file gets written.

  5. #5
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,114
    Blog Entries
    49
    Quote Originally Posted by Machinehead View Post
    That only works if the resume.ini file gets written.
    wellt hats true.. so make sure resume.ini isnt read-only
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  6. #6
    FLAC Machinehead's Avatar
    Join Date
    Jun 2007
    Location
    hijacks small portable city
    Posts
    1,381
    The other issue (which happens to be a problem I'm trying to deal with) is if Windows force shuts down RR and winamp the resume.ini file doesn't get written.

  7. #7
    Constant Bitrate mstaedt's Avatar
    Join Date
    Dec 2007
    Posts
    164
    Quote Originally Posted by Sonicxtacy02 View Post
    what version (date) of RR are you using? The latest version will resume whatever device was last played (mp3, xm, radio)

    I think it's the latest....my RoadRunner.exe file is dated 12-13-2007

    My resume.ini is dated today, so apparently it gets updated.
    --------------------------------
    Project completed! (almost)

    My Truck as featured in Custom Classic Trucks magazine.

  8. #8
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,114
    Blog Entries
    49
    Quote Originally Posted by mstaedt View Post
    I think it's the latest....my RoadRunner.exe file is dated 12-13-2007

    My resume.ini is dated today, so apparently it gets updated.
    the latest is dated 9/10/08.. but there could be another release sometime this week. Check the sticky
    mp3Car.com Senior Tech Blogger (Want a product reviewed? Contact me.)
    Find my plugins on the MP3Car App Store!
    Follow Me on Twitter or Facebook
    Live mp3Car Facebook Chat

  9. #9
    FLAC Sal R.'s Avatar
    Join Date
    Aug 2006
    Location
    Sun Diego
    Posts
    1,448
    Quote Originally Posted by Sonicxtacy02 View Post
    what version (date) of RR are you using? The latest version will resume whatever device was last played (mp3, xm, radio)
    To clarify, is this true on startup? Not resume? (i.e. standby, hibernate)

    I haven't tested this yet, but if so, man, this is gonna screw up my skin layout...
    Pico-ITX / XP Home with EWF-HORM / RR v12/02/2009 / Winamp v5.13 / RRMedia v1.2.2

  10. #10
    Constant Bitrate mstaedt's Avatar
    Join Date
    Dec 2007
    Posts
    164
    Quote Originally Posted by Sal R. View Post
    To clarify, is this true on startup? Not resume? (i.e. standby, hibernate)

    I haven't tested this yet, but if so, man, this is gonna screw up my skin layout...
    My issues are with startup. It seems to be ok when resuming from hibernate.

    That raises a question (to myself, I guess) as to how I ultimately plan to implement this sytem. For now I am developing the software on a laptop (which doesn't always even have the HD radio cord plugged in) while I assemble the hardware that will eventually end up going into the truck. I almost always exit RR, then cold start it when I get going again. If the standard method of shutting down and starting up is to hibernate and resume, then I may be trying to solve problems with my software that won't be a problem once I permanently install the system.

    I appreciate the help so far. It sounds like I may have missed some upgrades to RR that will help.

    Thanks....
    Mark
    --------------------------------
    Project completed! (almost)

    My Truck as featured in Custom Classic Trucks magazine.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •