Page 1 of 4 1234 LastLast
Results 1 to 10 of 34

Thread: RR does not intercept shutdown - Resume not working

  1. #1
    Constant Bitrate
    Join Date
    May 2005
    Location
    Toronto, ON
    Posts
    179

    RR does not intercept shutdown - Resume not working

    I'm having an issue with the Resume function in Road Runner. If I exit the application though RR or shut down through Road Runner, it will save to the resume.ini file. However, if I shut down using the power button the resume function does not work.

    This was not an issue in the past, when I set my CarPC to hibernate every time I shut off my car. I recently switched to a EWF HORM setup for my CarPC, but this issue can also be replicated on my regular PC.

    It seems like RR does not intercept the command to shut down, and execute the exit command. As a result, no changes are written to the resume.ini file. Looking at the debug log confirms this.

    Any workarounds? or ideas? I was able to replicate this issue on multiple computers.

  2. #2
    Constant Bitrate
    Join Date
    Mar 2007
    Location
    Atlanta, GA
    Posts
    126
    I've got the same issue. I don't use Hibernate, but I've noticed when I'm playing music and I shut down using the power button inside RR, it doesn't save my spot where I've been playing music and when I start up RR again, its all the way back where I was first playing my music last time - it's a bit annoying I must say as I always play the same song every time I start RR.

    And like you said, if I shut down RR and exit it completely, it does save the resume spot correctly.

    I'm using the latest Oct (11?) 2008 build of RR.

  3. #3
    Constant Bitrate
    Join Date
    May 2005
    Location
    Toronto, ON
    Posts
    179
    I was using an older build of RR before this one (pretty old). It too did not resume after restarting/shutting down with the power button. I'm unable to verify if this functionality ever existed.

    I do notice in the logs that there was no "shutdown" logged in the debug log, when using the power button. It's logged when using the exit command though.

  4. #4
    Constant Bitrate
    Join Date
    May 2005
    Location
    Toronto, ON
    Posts
    179
    Just to clairfy, the Road Runner directory is not on the EWF protected drive.

  5. #5
    FLAC Machinehead's Avatar
    Join Date
    Jun 2007
    Location
    hijacks small portable city
    Posts
    1,381
    This had to do with Windows forcing RR and winamp down. The programs aren't shutting down properly and hence aren't saving the resume.ini file. There are windows registry settings that can be changed to lengthen the time it takes windows to force programs to close.

  6. #6
    Constant Bitrate
    Join Date
    May 2005
    Location
    Toronto, ON
    Posts
    179
    I've changed these values already, with no effect. I've also verified that it is not setup to force terminate hung applications.

    I've also verified that this resume issue occurs on multiple PCs.

  7. #7
    FLAC Machinehead's Avatar
    Join Date
    Jun 2007
    Location
    hijacks small portable city
    Posts
    1,381
    That's good to know, I've resisted making those registry changes on my own set up because it shuts down quickly as is.

    There was another thread about this a while back and there was no resolution. Maybe this is something Mitch can look at.

  8. #8
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    EWF can be a real problem sometimes. I can only assume that when you ask the system to shutdown windows is not requesting the applications to close down properly knowing that it will simply "resume" to a previously state anyway (so why would it bother to close anything properly?). Without proper notification and time to save the resume file, there's not much we can do (by code) to save this data, however, there's a "SAVERESUME" command you can use for saving resume.ini at request (before turning it off).
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  9. #9
    Constant Bitrate
    Join Date
    May 2005
    Location
    Toronto, ON
    Posts
    179
    So now I have a different issue. RoadRunner is now interpreting the shutdown sequence (I'm not sure how it started working). However, when it saves the resume.ini file, the very first line has "-1". The time index and all other settings are saved properly. Any ideas? Because of the "-1", the songs are not playing at startup.

  10. #10
    Constant Bitrate
    Join Date
    May 2005
    Location
    Toronto, ON
    Posts
    179
    I forgot to mention, that if I exit the program through Road Runner (not using the power button), the playlist index and track index are saved properly.

Page 1 of 4 1234 LastLast

Similar Threads

  1. New RR Version - GPS Not Working
    By mnetwork in forum Road Runner
    Replies: 2
    Last Post: 12-28-2007, 09:56 AM
  2. Set RR resolution on resume from hibernation?
    By htsource in forum Road Runner
    Replies: 5
    Last Post: 08-08-2007, 03:05 PM
  3. Phoco not working in RR Win 2000, help...
    By couteau in forum Road Runner
    Replies: 3
    Last Post: 09-06-2005, 09:04 PM
  4. ME to resume mp3 upon shutdown
    By Kamakazie2 in forum Media Engine
    Replies: 6
    Last Post: 11-28-2004, 02:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •