Results 1 to 3 of 3

Thread: Funny clipping issue on embedded apps

  1. #1
    Low Bitrate
    Join Date
    Jun 2007
    Posts
    77

    Funny clipping issue on embedded apps

    Hey everyone -

    I'm having a strange clipping issue on all of my screens that contain an embedded app: On first load of the screen when RR launches and embeds the window, portions of the original window clip over the non-application area in RR:

    On following loads of that screen it looks fine; it's only on app launch that it gets hosed like this. The button I'm using to launch this is as follows:
    Code:
    ,660,155,106,110,"LOAD;freefone.skin;FreeFone;$skinpath$\FreeFone.EXE;FreeFone"
    An the skin for this screen is just the standard freefone skin:
    Code:
    RoadRunner Skin
    RRScreen "FreeFone"
    freefone.jpg,freefone.jpg,freefone.jpg,freefone.jpg
     
    /, B, x, y, w, h, Command;COMMANDCODES, Tooltip
    B01,690,0,44,54,"CLOSE","Close"
    B02,745,0,54,54,"EXIT","Exit"
     
    /, L, x, y, w, h, color R;RGB, G, B, font size;FONT, font name, Code;LABELCODES, Tooltip;LABELALIGNMENT
    L01,10,3,100,25,255,255,255,15,"Arial Narrow:B","TIME","Time"
     
    /, B, x, y, w, h, Command;COMMANDCODES, Tooltip
    B,529,502,75,96,"PREV",
    B,605,505,62,93,"STOP",
     
    /, L, x, y, w, h, color R;RGB, G, B, font size;FONT, font name, Code;LABELCODES, Tooltip;LABELALIGNMENT
    L03,231,10,450,40,255,245,000,22,"Tahoma:B","TRACKNAME","scroll-center"
    L12,142,5,35,25,255,255,255,15,"Arial Narrow:B","=Car:",""
    L13,142,30,35,25,255,255,255,15,"Arial Narrow:B","=Out:",""
    L14,180,5,45,25,128,255,128,15,"Arial Narrow:B","TEMP1",""
    L15,180,30,45,25,128,255,128,15,"Arial Narrow:B","TEMP2",""
    L06,710,40,0,0,128,255,128,18,"Arial Narrow:B","CUSTOMFREEFONE", ""
     
    /, F, x, y, w, h, Movie name
    F,33,29,78,35,"Foneind.swf"
     
    /, B, x, y, w, h, Command;COMMANDCODES, Tooltip
    B,734,505,65,91,"NEXT",
    B,668,503,65,95,"PLAY",
     
    /, S, x, y, w, h, x1, y1, w1, h1, O, Style, Pointer file path, h2, Code;SLIDERCODES, Tooltip
    S01,90,542,428,34,90,542,True,24,H,01,"POINTER2.gif",12,"SONGPOS",""
     
    /, A, x, y, w, h, color R;RGB, G, B
    A01,2,103,795,400,000,000,000,"FreeFone"
    
    END
    What the heck am I doing wrong?

    Oh yeah, I'm using the 12/1/08 RoadRunner, but this also occurred with the prior version (10/1?)

  2. #2
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    I can see you've edited the original size of the application -- many applications don't like to be resized to odd values and "fight back". I am unsure this is the case here, but you may want to use the original example included with freefone and see if that works, then if you want to make changes, make them 1 change at a time to see if anything weird happens, and if so, you may want to leave that specific item as it is or play with it until you get it to work the way you want -- but that may be beyond the design of the application.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #3
    Low Bitrate
    Join Date
    Jun 2007
    Posts
    77
    Quote Originally Posted by guino View Post
    I can see you've edited the original size of the application -- many applications don't like to be resized to odd values and "fight back". I am unsure this is the case here, but you may want to use the original example included with freefone and see if that works, then if you want to make changes, make them 1 change at a time to see if anything weird happens, and if so, you may want to leave that specific item as it is or play with it until you get it to work the way you want -- but that may be beyond the design of the application.
    No dice, it's happening with the original freefone skin on both my test bench and actual carPC. Seems to work just fine with notepad though. The other strange thing about it is that it leaves artifacts from the original window (just prior to embedding) around on my test bench outside the RR window. Weird...

    -Justin

Similar Threads

  1. Centrafuse OSK with Embedded Apps
    By siliconkibou in forum Centrafuse
    Replies: 4
    Last Post: 10-03-2005, 03:13 PM
  2. Centrafuse Embedded Apps Launch on Startup?
    By siliconkibou in forum Centrafuse
    Replies: 3
    Last Post: 10-03-2005, 07:54 AM
  3. Replies: 1
    Last Post: 08-14-2005, 02:31 AM
  4. Funny bug- I embedded Internet explorer to music player!
    By organasised in forum Road Runner
    Replies: 8
    Last Post: 02-25-2005, 06:30 PM
  5. Running Embedded External Apps Like Mediacar
    By badandy4you in forum FrodoPlayer
    Replies: 3
    Last Post: 05-26-2004, 04:10 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •