Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Road Runner on Windows 7 beta

  1. #1
    Maximum Bitrate DaveDog's Avatar
    Join Date
    Mar 2004
    Location
    Greenacres, WA
    Posts
    604

    Road Runner on Windows 7 beta

    This post has become a bit dated with all the recent work that has been done on Ride Runner.

    Thanks to Guino, Mitch and the rest of the team working to make Ride Runner compatible with Win7.




    Well I decided to take the plunge, and I thought I would provide some feedback to help out others.


    System Specs:

    Acer Power 1000
    2.4G Athlon,
    1G DRAM
    80G G.Skill SSD


    Carputer accessories:

    Carnetix 2140
    Lilliput 619
    XM Direct w/ MP3car USB adapter
    IOGear 2 port serial - USB
    Directed HD radio w/ MitchJS cable
    Belkin 4 port powered USB hub
    unknown old GPS unit - USB
    logitec webcam
    license plate reverse cam



    This system worked great on XP, so lets see what happens with Win 7


    Win 7

    Many people have installed Win 7 written reviews and I found the experience pretty much along the lines of what I read. Win 7 had all the required drivers for the system, I did not have to dig up any, although to make things work right with XM and HDradio I installed the realtek audio drivers for vista. The most annoying thing I found was UAC, but glad to hear there will be additional changes there before it gets released.

    Running apps on startup is done by adding them into the registry, however you need to set the apps to run as administrator.


    Road Runner + DFX 4

    Installs fine, but would not run until I set it to run as administrator.
    Road Runner config doesn't like running as a non admin either, and it doesn't recognize the audio ports with the driver included in Win7, had to set them manually in RR.ini using Notepad. Worked like it was supposed to when I instaled the Realtek Vista drivers (rear pink input).

    Remember to give any txt files full access, or you cannot save them. I ended up giving full rights to the riderunner directory.

    *when adding a plugin that you need to register a dll for, you need to run the command prompt as administrator, start, all programs, accessories, right click command prompt, run as administrator


    IGuidance 4

    Installed easily, embeds properly, no issues there.


    HDRadio

    I used the vista drivers on the IOGear install disk for the USB-serial converter HDradio works fine. Initially I had to manually set the audio line in rr.ini but after I downgraded the realtek audio driver to the vista driver, I could select the appropriate audio input with RRConfig.


    XM Radio

    The MP3Car drivers installed fine and XM works great,


    Logitech Webcam

    Win7 reports the logitech drivers have a compatability issue but let me install them anyway, system acted very funny, so removed them.

    Lilliput

    Win 7 recognized the touchscreen, however calibration is off, running the Win7 calibration utility had no effect, installed the touchkit drivers and everything works ok.

    Carnetix

    The drivers installed and the PSuMoni app installed and runs, but the device never shows as connected, found a workaround on the carnetix site - going to Device Manager and into the Carnetix device, then on the power tab just check both options off . still issues there, looks like they need to have an update


    GPS mouse

    The installer for the drivers finishes without error, but on reboot the device shows up in system manager as an unknown device, finally ran the installer in XP compatability mode, It worked!!!
    I did order a BU-353

    XPort 3

    Doesn't quite work like it does in XP, it will not start automatically in Win7, so I added it into the registry



    Thats where I'm at. I'll update this post as I get more stuff figured out.
    TruckPC - gutted, being used for test setup
    BoatPC - All in 1 in cuddy, N7 using VNC on dash, RR
    BlazerPC - Nexus 7 with Timur's USBROM

  2. #2
    FLAC Machinehead's Avatar
    Join Date
    Jun 2007
    Location
    hijacks small portable city
    Posts
    1,381
    Do you have volume control?

    I know that's an issue for many in Vista.

  3. #3
    Maximum Bitrate DaveDog's Avatar
    Join Date
    Mar 2004
    Location
    Greenacres, WA
    Posts
    604
    yes, volume control works fine
    TruckPC - gutted, being used for test setup
    BoatPC - All in 1 in cuddy, N7 using VNC on dash, RR
    BlazerPC - Nexus 7 with Timur's USBROM

  4. #4
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    WIN7 = VISTA
    (not exactly, but in its backend yes.. the audio system is same as vista)

    RR is FAR from being UAC compliant software... one day this might change
    (its a bit of work)

    RRConfig was not written with VISTA/WIN7 in mind, it will not be able to enumerate audio... but RR will with its vista volume control, and its all in the debug.txt

    THE NEW RRCONFG (supplied with 3/2009) RideRunner now supports VISTA AUDIO!!!

    TY BLUE!
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  5. #5
    Maximum Bitrate DaveDog's Avatar
    Join Date
    Mar 2004
    Location
    Greenacres, WA
    Posts
    604
    solved the dll issue, need to run command prompt as administrator
    TruckPC - gutted, being used for test setup
    BoatPC - All in 1 in cuddy, N7 using VNC on dash, RR
    BlazerPC - Nexus 7 with Timur's USBROM

  6. #6
    Maximum Bitrate DaveDog's Avatar
    Join Date
    Mar 2004
    Location
    Greenacres, WA
    Posts
    604
    update on the audio driver, see first post
    TruckPC - gutted, being used for test setup
    BoatPC - All in 1 in cuddy, N7 using VNC on dash, RR
    BlazerPC - Nexus 7 with Timur's USBROM

  7. #7
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    make sure u ELEVATE EVERTHING u RUN

    any _Install.cmd scripts
    installers

    u name it, run as admin

    cause RR and worse the plugins are FAR form NEW security compliant rules
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  8. #8
    Low Bitrate
    Join Date
    Dec 2006
    Location
    maine
    Posts
    57
    Hate to dig up an old thread, but just wanted to say thanks
    first place I found that verifies iguidance 4 working properly in windows 7 (going on a roadtrip, dont need any surprises... was about to install the software and thought I'd check around for known problems)

  9. #9
    Mod - all of it.
    Join Date
    Jul 2007
    Location
    Buena Park, So Cali
    Posts
    524
    Have you been able to get button changes to work. I use DFX4 and when you press and hold a menu screen button you can change what that button does. Everything works in terms of switching to the menu button screen, but when it switches back to the main menu screen, nothing has happened.

    Also in DFX4 I use the cover art thumbnail browser to pick albums to listen too, and get an error when I choose an album. I am not running 7 right now so will have to check and get back to you on the exact error.

  10. #10
    Low Bitrate
    Join Date
    Mar 2006
    Posts
    71
    Don't think the audio in win7 is the same as vista. I think they added an extra layer to it as compatibility

Page 1 of 2 12 LastLast

Similar Threads

  1. Install Windows XP on a USB Flash Drive
    By kingofl337 in forum WinNT Based
    Replies: 8
    Last Post: 01-11-2012, 12:26 PM
  2. Road Runner Shell Issue
    By B|ade in forum Road Runner
    Replies: 4
    Last Post: 05-24-2007, 05:00 AM
  3. road runner freezing on startup :(
    By skiman in forum Road Runner
    Replies: 6
    Last Post: 03-13-2007, 09:37 AM
  4. Run WinCE & XP together
    By ShawJohn in forum Software & Software Development
    Replies: 12
    Last Post: 11-07-2005, 05:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •