Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: working on xm issue after resume.... mp3car adaptor

  1. #1
    Variable Bitrate navputer's Avatar
    Join Date
    Jan 2007
    Location
    DFW Area
    Posts
    303

    Arrow working on xm issue after resume.... mp3car adaptor

    [QUOTE=Sonicxtacy02;1299725]i'd say 80% of the time my radio resumes when rr resumes at hibernation. The other 20% of the time rr resumes but my directed unit will not connect. Most of the time it requires me to exit rr, remove power from the HD radio, then restart it and RR. On some occasions i have to power down the HDRadio and completely reboot the computer.

    I don't mean to hijack this thread but this is the same problem that I am having on the XM side. I have to unplug the MP3 USB Adapter or the 8 Pin connector to the XM Tuner (for about 10-15 secs) and it will work. I tried a different XM Tuner (I thought my tuner was bad) but it did the same thing. My USB adapter is getting power from my M2-ATX.

    Tks...
    Gee

  2. #2
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,256
    nav, we can start a new thread...

    there are some things you can do

    the power to the xm tuner, needs to be ON when the pc is on
    i dont know what connections the mp3 usb adaptor has
    but make sure its powered with pc , NOT IGNITION..
    now since its FTDI based, i bet its using OLD drivers, i dont know if mp3car has updated them, i could do it for you
    also... do you have any resume delay set?, this gives USB devices more time to get back in play after a resume
    in rr.ini resumedelay=xxx (where xxx = 0 to 10sec) or in RRCONFIG page 3
    and i assume you have rr hibernation aware...
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  3. #3
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Only bad things come when assuming....
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  4. #4
    Variable Bitrate navputer's Avatar
    Join Date
    Jan 2007
    Location
    DFW Area
    Posts
    303
    Quote Originally Posted by mitchjs View Post
    nav, we can start a new thread...

    there are some things you can do

    the power to the xm tuner, needs to be ON when the pc is on
    i dont know what connections the mp3 usb adaptor has
    but make sure its powered with pc , NOT IGNITION..
    now since its FTDI based, i bet its using OLD drivers, i dont know if mp3car has updated them, i could do it for you
    also... do you have any resume delay set?, this gives USB devices more time to get back in play after a resume
    in rr.ini resumedelay=xxx (where xxx = 0 to 10sec) or in RRCONFIG page 3
    and i assume you have rr hibernation aware...
    We can start a new thread...

    The MP3 USB Adapter has power. However, I got it connected to Ignition not Constant Power - will make that change (it was working fine coming from resume but after rr updates - saw change). The drivers are old and there are no new updates on MP3's site (http://store.mp3car.com/ProductDetai...7&Show=ExtInfo)

    I do have resume set to 2 from the pull down menu in RRconfig.
    Yes - have rr hibernation aware

    FYI - I have the HDRadio with your cable and it resumes fine - no problems just XM.
    Gee

  5. #5
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,256
    hmm, lets rewire it to constant... i havent touched XM code in MONTHS, so since i did the redoes on XM, nothing changed... not that i know of
    but for sure, if the tuner turns off with the key, and the pc is still doing its hibernation, it could hang.... a debug.txt log with xmdebug on would help
    but change it to constant... for now at least... my recomendation would be like Hard drive power, then u know its on when pc is on, and off when pc is off

    mitch
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  6. #6
    Variable Bitrate navputer's Avatar
    Join Date
    Jan 2007
    Location
    DFW Area
    Posts
    303
    Quote Originally Posted by mitchjs View Post
    hmm, lets rewire it to constant... i havent touched XM code in MONTHS, so since i did the redoes on XM, nothing changed... not that i know of
    but for sure, if the tuner turns off with the key, and the pc is still doing its hibernation, it could hang.... a debug.txt log with xmdebug on would help
    but change it to constant... for now at least... my recomendation would be like Hard drive power, then u know its on when pc is on, and off when pc is off

    mitch
    Mitch,

    Thanks for helping on this and I will re-wire it to constant. It makes sense what you said, i turn the key to off (XM is on ignition) and XM powers off. If its on constant power, it will be read by RR that is on, save settings as normal and be able to come back to the normal state. I will post up my debug and xmdebug settings.

    Thanks again
    Gee

  7. #7
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,256
    xmdebug means turn it on, xmdebug=true, or do it in rrconfig
    then debug.txt will have info on XM for us to eval

    im not sure i would go with constant power, i dont know if the mp3car product properlly controls the tuner's power, it would be a large draw, and u could end up with dead battery... thats why i suggest, pc's Hard Drive power (yellow wire)
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  8. #8
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,256
    also i made you a up to date driver set, it prob wont solve the problem
    but its much newer
    the ones you are using are from 2006. this is from 2009

    i dont want to post it, till you confirm it
    so.. email me... (pm has my email)
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  9. #9
    Variable Bitrate navputer's Avatar
    Join Date
    Jan 2007
    Location
    DFW Area
    Posts
    303
    Quote Originally Posted by mitchjs View Post
    also i made you a up to date driver set, it prob wont solve the problem
    but its much newer
    the ones you are using are from 2006. this is from 2009

    i dont want to post it, till you confirm it
    so.. email me... (pm has my email)
    I changed the MP3 Adapter connection to Constant Power on the M2ATX (red wire), turn off ignition, turn back on after 30 seconds, it came back from Hibernation and the XM did resume.

    I have attached my debug txt file.

    Edit: I saw the change about how to power up the XM. I checked the adapter after power down and the MP3 Adapter is off (no light on adapter). It normally has a green light when it is power on. I also have the setting to power down device in Device Manager.
    Attached Files Attached Files
    Gee

  10. #10
    Variable Bitrate navputer's Avatar
    Join Date
    Jan 2007
    Location
    DFW Area
    Posts
    303
    So far, the XM is resuming properly but I have not rewired my HDRadio yet. I will do that this weekend.

    I will post up my results.

    NOTE: I think other people might have their wires connected wrong as well. My MP3 USB adapter(changed now) and HDRadio was connected to the ignition wire. So, it powers off when vehicle is off, so nothing to save properly and it fails coming back from resume.
    Gee

Page 1 of 2 12 LastLast

Similar Threads

  1. XM resume issue
    By aerotight31 in forum Road Runner
    Replies: 7
    Last Post: 06-30-2008, 11:39 AM
  2. Resume issue with new 9-9-07 version
    By jarred in forum Road Runner
    Replies: 5
    Last Post: 09-13-2007, 12:50 AM
  3. working with xm direct and macxm
    By lovedamacmini in forum MacCar
    Replies: 9
    Last Post: 11-02-2005, 02:29 PM
  4. XM Direct Audio Issue
    By beckkl in forum General Hardware Discussion
    Replies: 9
    Last Post: 01-18-2005, 10:14 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •