Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Riderunner issue with XM

  1. #1
    Newbie
    Join Date
    Apr 2007
    Posts
    28

    Riderunner issue with XM

    Loaded the new version of riderunner (3-09) earlier this week into a new program files\ride runner directory. I also loaded John's DigitalFX4 skin into the ride runner directory. Everything ran great with my skin, Dig FX, and the default skin up until today.

    For no apparent reason, i started getting an error when starting riderunner that says riderunner needs to close. I changed to the default skin to see if the skin had an issue and got an additonal error from it. (see image) Nothing has changed on my install and automatic updates are turned off.

    It is apparently related to the xm port. When I change the port to 0, the program starts. anytime it is set to port 3 the program fails. I have road runner (9-07) version installed and it still works just as it has for the last couple of years using port 3.

    I have done tons of searching and have tried several steps to repair it including:
    uninstall, reboot, reinstall
    install mjs gadgets again
    change the xm port
    tried the rrcom cleanup tool
    reinstall .net 2.0
    patched XP (SP3) fully


    I am at loss but would really like to get it working.

    Any suggestons?

    Thanks
    Chris
    Attached Images Attached Images  

  2. #2
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    i have never seen RideRunner crash in that fashion...

    .net framework installation problem

    or
    like it says xm isnt registered
    in the mjsgadgets dir, xmradio dir, runme1st.cmd
    run that... look for error messages...

    i got a hunch...

    something tells me, DXF4 is suppling a an .net assembly
    this is VERY VERY WRONG, john is this is the case, please remove it from the installer
    but i bet u got more then 1 copy of
    XMComm.dll
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  3. #3
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    yes, i just installed DXF4

    its a VERY dangerous installer

    I CANNOT recomend this skin.... not with its installer in its current state

    it did install OLD version of HDRADIO on the machine, and will be incompatable
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  4. #4
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    u can fix up, hd radio

    go into the hdradio dir the one created by the installer
    and run UnRegMe.cmd

    then go into the MJS Gadgets/HDRadio dir, and run runme1st

    i see alot messy here with this installer

    SOOO MANY system .dlls are in this installer
    hopefully the installer at least checks if exits
    else it will break winamp fixes

    the smartest thing to do, would be to uninstall DXF4
    then reinstall RideRunner

    that should fix up any mess

    a bunch of work on this skin should be done to get it up to spec

    it is very popular, wouldnt take that much to clean it up
    and make it safe

    yeash, it even brings back the zips.dat file

    play it safe, dont use this skin
    at least not with its installer
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  5. #5
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    oh good god

    no DXF4 uninstall

    and my system is now a mess

    i should be able to delete, and reinstall Riderunner from installer
    to get a repaired system

    yep... a simple reinstall of riderunner, using the installer...
    everything is working...

    then i used com explorer 2.0 to remove all the dead com entries
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  6. #6
    Newbie
    Join Date
    Apr 2007
    Posts
    28
    Quote Originally Posted by mitchjs View Post
    u can fix up, hd radio

    go into the hdradio dir the one created by the installer
    and run UnRegMe.cmd

    then go into the MJS Gadgets/HDRadio dir, and run runme1st

    i see alot messy here with this installer

    SOOO MANY system .dlls are in this installer
    hopefully the installer at least checks if exits
    else it will break winamp fixes

    the smartest thing to do, would be to uninstall DXF4
    then reinstall RideRunner

    that should fix up any mess

    a bunch of work on this skin should be done to get it up to spec

    it is very popular, wouldnt take that much to clean it up
    and make it safe

    yeash, it even brings back the zips.dat file

    play it safe, dont use this skin
    at least not with its installer
    Thanks for the info, Ill try this tonight or tomorrow

    XM radio is the same dll as HD radio? I have an issue with xm, and don't have hd radio installed.

    Thanks again. Ill touch base with John and see if he is aware of the problem....

    Chris

  7. #7
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    no,

    sorry, i just got confused when i saw, that he dropped in HDRADIO
    it might do XM too!!!

    i already cleaned up my system

    but u can do the same in the mjs gadgets/XMRadio...
    there will a runme1st.cmd


    i should have looked....
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  8. #8
    Maximum Bitrate wysocki's Avatar
    Join Date
    Mar 2004
    Location
    Los Angeles Area
    Posts
    467
    I'm getting the "XMradio control assembly is not registered message" too. I have had RR installed for years but it's been working so well, I've had no need to check back here for any updates ("if it works...").
    Anyway, I just was back browsing the forum and came across the recent feature for mp3art and decided to get it. I d/l the latest zip from the stickies and unzipped it in my RR folder, and I registered a couple of dll's that were in the readme.txt. However, I don't remember seeing anything about the "gadgets". I'm using my own skin and XM works, but I get the error on startup. I don't have any MJSgadgets folder in my install.

    It'd be nice if RR had an easy to understand install and update location - for newbs as well as people like me who've had RR for years but just don't have the time/need to watch the forum every day for all the updates. I'm pretty sure I'm missing some interim update and probably the config utility as well, but it's a full time job keeping track of all the apps on all my PCs for updates.
    Epia-M II M10000 Nehemiah WinXP sp2 Travla C134 case Carnetix 1260 power Xenarc 700TS XM Direct Toslink Extigy USB 5.1 Garmin GPS18 Linksys 802.11g wireless Nokia 6230 Bluetooth Memphis Amps Focal Speakers Frontend: RoadRunner

  9. #9
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    you are mixing up versions!!!!!

    use the installer!!!!!!!
    DOWNLOAD THE INSTALLER!!!
    INSTALLER!
    INSTALLER!

    XM IS COMPLETELY NEW SINCE 2008!

    OH
    INSTALLER!!!

    THATS WHAT ITS THERE FOR

    OH YEA... USE THE INSTALLER!

    DOWNLOAD LINK IN THIS POST:
    http://www.mp3car.com/vbulletin/road...t-hot-fix.html

    HOT FIX:
    http://www.mp3car.com/vbulletin/road...9-hot-fix.html
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  10. #10
    Maximum Bitrate wysocki's Avatar
    Join Date
    Mar 2004
    Location
    Los Angeles Area
    Posts
    467
    Thanks for the answer, Mitch. I normally would go that route except that the other option was "upgrade" which I figured I wanted since I already had an existing installation and didn't want to lose any of my configuration. When I took the upgrade I thought that it would recognize which older version I had and make the appropriate upgrades. I was suspicious since there was no .exe file to run, just some files and folder to be replaced.

    Anyway, I ran the install program but there was an issue with the install regarding .NET Framework. It told me I needed .net and asked if I wanted to install it and then re-run the RR install afterwards. I replied YES, but the RR install just continued on to the end right away, making me wonder if I had to indeed run it a second time (which I did anyway). I would have thought RR install would have waited for .net install to finish first.

    Although I dread having to redo all my settings that work so nicely in the old version, I decided to do a fresh install in the new RideRunner folder to get rid of any trash I've built up over the years - so I installed as if I was a newbie. Biggest problem I have so far is documentation. The new config app is great but are there any docs for it outside of searching the forums for each parameter? Many of the items I just copied from my old install, but there are new things like the MJS Gadgets that were confusing until I searched the forums. Also:

    - I enabled Voice Control but then I got an error starting RR saying VoiceControl.dll was missing. Evidently, that's another package I have to locate and install/update.

    - When I tried a preview for the Carwings_Dynamic skin I got a message that a "Menu_off" image was not found, even though it was in the folder.

    PS: Sorry for going off topic!
    Epia-M II M10000 Nehemiah WinXP sp2 Travla C134 case Carnetix 1260 power Xenarc 700TS XM Direct Toslink Extigy USB 5.1 Garmin GPS18 Linksys 802.11g wireless Nokia 6230 Bluetooth Memphis Amps Focal Speakers Frontend: RoadRunner

Page 1 of 2 12 LastLast

Similar Threads

  1. xm channel list issue
    By juve021 in forum RR Skins
    Replies: 1
    Last Post: 10-17-2006, 10:49 AM
  2. xm issue with proximo's cf skin
    By juve021 in forum Road Runner
    Replies: 1
    Last Post: 09-28-2006, 05:23 PM
  3. mobile impact xm issue
    By hilltop79 in forum Software & Software Development
    Replies: 1
    Last Post: 09-12-2006, 09:50 PM
  4. XM changing channel issue and more
    By tmar89 in forum Media Engine
    Replies: 9
    Last Post: 04-24-2006, 02:09 PM
  5. XM Satellite Radio to Unveil XM Advanced Services at 2006 Consumer
    By Will Albers in forum General MP3Car Discussion
    Replies: 2
    Last Post: 03-27-2006, 08:49 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •