Results 1 to 9 of 9

Thread: multiple command stored in a variable

  1. #1
    Variable Bitrate chevyn8's Avatar
    Join Date
    Oct 2006
    Location
    small town nebraska
    Posts
    263

    multiple command stored in a variable

    This is an old script (medialaunch), the var is created using ++ and seems ok. Nothing executes. Here is the debug:

    5/31/2009 11:13:04 PM: Que Exec: True, menu_2.skin, "$CMDMEDIA2$", False
    5/31/2009 11:13:04 PM: Executing: MUTE||VIDEO||WAIT;3||STOP||LIST||SETPATH;U:\||MUTE
    5/31/2009 11:13:04 PM: Command not executed: MUTE||VIDEO||WAIT;3||STOP||LIST||SETPATH;U:\||MUTE
    5/31/2009 11:13:04 PM: Que Exec: True, menu_2.skin, "ONCOMMANDINVALID", False
    5/31/2009 11:13:04 PM: Executing: ONCOMMANDINVALID
    5/31/2009 11:13:04 PM: Leave Exec: False, menu_2.skin, ONCOMMANDINVALID, False

    any ideas before I do a reinstall? this has worked for a couple of years...



    OK, this is the example from skincommands.txt

    6/1/2009 6:30:29 AM: Que Exec: True, menu_2.skin, "SETVAR;MYCMD;AUDIO++PAUSE", False
    6/1/2009 6:30:29 AM: Executing: SETVAR;MYCMD;AUDIO++PAUSE
    6/1/2009 6:30:29 AM: Leave Exec: False, menu_2.skin, SETVAR;MYCMD;AUDIO++PAUSE, False
    6/1/2009 6:30:33 AM: Enter Exec: False, menu_2.skin, , False
    6/1/2009 6:30:33 AM: Que Exec: True, menu_2.skin, "", False
    6/1/2009 6:30:33 AM: Executing:
    6/1/2009 6:30:33 AM: Leave Exec: False, menu_2.skin, , False
    6/1/2009 6:30:35 AM: Enter Exec: False, menu_2.skin, , False
    6/1/2009 6:30:35 AM: Que Exec: True, menu_2.skin, "$MYCMD$", False
    6/1/2009 6:30:35 AM: Executing: AUDIO||PAUSE
    6/1/2009 6:30:35 AM: Command not executed: AUDIO||PAUSE
    6/1/2009 6:30:35 AM: Que Exec: True, menu_2.skin, "ONCOMMANDINVALID", False
    6/1/2009 6:30:35 AM: Executing: ONCOMMANDINVALID
    6/1/2009 6:30:35 AM: Leave Exec: False, menu_2.skin, ONCOMMANDINVALID, False
    6/1/2009 6:30:41 AM: Enter Exec: False, menu_2.skin, , False
    CarPC in my 82 Camaro. Dual core atom, M4-ATX, 7 lilliput, bu353 GPS, Reborn skin, punch 40/100ix
    MediaLaunch for RR
    Online Check for RR
    Locker for RR

  2. #2
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    I'm looking into this right now -- there IS an issue for sure.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #3
    Variable Bitrate chevyn8's Avatar
    Join Date
    Oct 2006
    Location
    small town nebraska
    Posts
    263
    Thanks, much appreciated.
    CarPC in my 82 Camaro. Dual core atom, M4-ATX, 7 lilliput, bu353 GPS, Reborn skin, punch 40/100ix
    MediaLaunch for RR
    Online Check for RR
    Locker for RR

  4. #4
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    chevyn8, I have looked at the code

    I see exctly whats happening.... but im not sure i should change it
    when did it work, any versions of RideRunner?

    i prob could change it, and add some saftey code
    i just want to be sure i dont break anything else
    i cant see how, but i want to me sure
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  5. #5
    Variable Bitrate chevyn8's Avatar
    Join Date
    Oct 2006
    Location
    small town nebraska
    Posts
    263
    I'm not really sure what version introduced the problem. I thought at least the first version of riderunner worked, as I tested and updated medialaunch with that one.
    CarPC in my 82 Camaro. Dual core atom, M4-ATX, 7 lilliput, bu353 GPS, Reborn skin, punch 40/100ix
    MediaLaunch for RR
    Online Check for RR
    Locker for RR

  6. #6
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    man i fixed, it i would love to send u the new build, you can test if for me
    that ok? can u pm me, i prob can put the build on my ftp

    i just find it odd, that it could ever work...i will try to research
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  7. #7
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    I got it, and see where I broke it!
    yep my fault

    i cleaned up the code to the Exectbl translation... and thats where it broke
    its fixed, and in the new release (soon)
    but pm, me and we can hook up, and i can get it to ya

    THANKS for reporting the bug, its a rarley used feature, no skin i had used it, so i didnt notice it...
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  8. #8
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    i actually fixed something, that if u exectble translated a command to a command with a var that has multiple command, it will work now

    "ETEST","$mycmd$"

    (and in mycmd say was, "dothis||dothat" )

    so I fixed a OLD bug too... if u can call it that
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  9. #9
    Variable Bitrate chevyn8's Avatar
    Join Date
    Oct 2006
    Location
    small town nebraska
    Posts
    263
    Thanks!! I'll send you a PM and give it a go.
    CarPC in my 82 Camaro. Dual core atom, M4-ATX, 7 lilliput, bu353 GPS, Reborn skin, punch 40/100ix
    MediaLaunch for RR
    Online Check for RR
    Locker for RR

Similar Threads

  1. Variable syntax questions
    By Iamthehor in forum FB Software
    Replies: 14
    Last Post: 02-25-2009, 09:58 PM
  2. REQUEST: Run Multiple RR instances
    By Jarrod in forum Road Runner
    Replies: 33
    Last Post: 12-21-2008, 07:54 AM
  3. Multiple ECU responses
    By mctodd00 in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 3
    Last Post: 11-16-2008, 07:16 AM
  4. found in fperrorlog
    By 510SX in forum FP Bug Reports
    Replies: 3
    Last Post: 09-21-2006, 08:01 AM
  5. yet another frodo install with problems.
    By Marsupial in forum FrodoPlayer
    Replies: 10
    Last Post: 08-27-2004, 06:28 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •