Results 1 to 10 of 10

Thread: RR doesnt always see my HU commands

  1. #1
    Newbie
    Join Date
    Jun 2006
    Posts
    29

    RR doesnt always see my HU commands

    Hiya,

    I have just finished upgrading my carpc. I am now tring to use the carpc.exe in RR to send commands to my HU.

    I have not installed the HUMP3 plugin and have checked that the rr.ini file has the line usecar2pc=true. I have used myhutest.exe to see the commands that are being sent from the HU and steering wheel commands. Which works great thank you!

    I edited my exectbl.ini file to the correct commands. However, rr only responds to the button presses occasionally. There doesnt even seem to be any repeatability, sometimes it take one keypress to change tack, other times 2 or 3 etc.

    I read somewhere that there is a car2pc and a car2pcOLD which works with the older adapters, how can I tell if I have the older adapter? According to myhutest my adapter constantly sends out "PL", "MX 0" etc, does this mean it is the older type of adapter?

    I have now installed HUMP3 and configured winamp, and a button press is registered everytime by winamp so I am pretty sure its something to do with car2pc.exe or rr.

    Can anyone help?

    Thanks!

  2. #2
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    If you have bought it recently (as in not longer than 2 years ago), then you have the new model. However, the winamp plugin should not be installed when using RR, please remove/disable it and try RR with car2pc alone.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #3
    Newbie
    Join Date
    Jun 2006
    Posts
    29
    Ok so I have the old adapter. But with the rr I used (i think it was last months release) there was no car2pcOLD only car2pc. Do you know where I can get the older version?

    When I originally tried it, I did it without the HUMP3. I only installed HUMP3 as a tempoary thing while I seeked help about the car2pc.exe.

    And can I just say a big thanks to Guino... the software is awesome! THANK YOU!

  4. #4
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    I have attached what I'm pretty sure is the old version of car2pc.exe. You should try both the new and the old one without any other car2pc software installed (winamp plugin etc) -- leave only the drivers. BE SURE to rename car2pcold.exe to car2pc.exe or it will not work. Also, be sure you have the latest RR installed as there were issues with some versions of the RoadRunner.exe (Compatibility module).
    Attached Files Attached Files
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  5. #5
    Newbie
    Join Date
    Jun 2006
    Posts
    29
    Thanks for the Car2PCOLD. I have updated rr to the version released on the 1st June 2009. I have uninstalled HUMP3. Since doing this I haven't much luck with various versions of car2pc, please see below:

    Car2PC supplied with the rr install:
    The command from my HU only seem to register occasionally. For example, using the skip command the following would happen, skip, skip, no-skip, no-skip, skip, no-skip, skip, skip, skip, skip, no-skip, etc.

    Car2PCOLD as supplied above (but renamed to car2pc):
    This didn't seem to get any of the commands of my HU.

    Car2PC from "How do I get the Car2PC adapter to work in RR?" thread, post #44:
    This behaved as the car2PC supplied with the rr install.

    Car2PC from "How do I get the Car2PC adapter to work in RR?" thread, post #60:
    This kept pausing / playing music every second and still had the same skipping issue as described.


    Thanks for your help this far. I am now at a loss of what to do next. Any suggestions?

    Thanks!

  6. #6
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Chances are that you need the one that is working partially (missing some commands), however you may want to try different versions of that driver if you can. I honestly haven't done any work towards that in a very long time, but this could be an isolated issue with the HU and your car2pc adapter itself -- does it work ALWAYS with using just the HUMP3 plugin ? (If so, then your hardware should be fine, if not then it would be a hardware issue)..
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  7. #7
    Newbie
    Join Date
    Jun 2006
    Posts
    29
    Yeh all the buttons work fine with the HUMP3 plugin. As for the driver (I assume you mean the FTD2XX driver, according to the release info that hasn't been changed since Oct 2004. So I dont know if that would help.

    Perhaps it would be a good idea for me to have a fiddle with the source code? See if I can do anything with the car2pc exe?

    Thanks!

  8. #8
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Attached is the last source code I worked on. The new EXE version was made by a user (unsure if a user here or from the forums of indashpc.org). You may also look at this thread (if you like .NET): http://indashpc.org/vbullettin/viewt...ghlight=car2pc

    I know for a fact that you can use the HUMP3 plugin correctly without any problems as long as you don't use the car2pc.exe from RR, but it won't give you the same features as you'd get with cae2pc and RR without the HUMP3 plugin.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  9. #9
    Newbie
    Join Date
    Jun 2006
    Posts
    29
    Am I missing something? I cant see the attached files :-s. Thanks for the .net fix, tbh I'm much more of an embeded programmer, i.e. C.

    I have used rr and HUMP3 togethr for a while. They work quite well together except for the play lists. When you change the playlist using my HU then rr doent update and gets all out of sync. That is really the only reason I am trying to use car2pc instead.

    Thanks!

  10. #10
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    I believe you need to register/login to view the files on that forum.

    If you're fond of C, then I'd recommend getting the HUMP3 plugin source and change that to your liking... if you like the way it works, you can probably just change it so it sends a "RELOADLIST" command to RR when after you execute something that causes RR to get out of sync.

    If you do update the code, I'm sure others would appreciate it if you posted the results (so others can use it).
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

Similar Threads

  1. Switching between RR and copilot
    By CombatCQB in forum Road Runner
    Replies: 13
    Last Post: 01-26-2009, 06:27 PM
  2. XMD RR Hibernation & XMRESET
    By hank_kls65 in forum Road Runner
    Replies: 17
    Last Post: 10-25-2007, 04:14 PM
  3. RR Embedded IGuidance causes RR to lose focus
    By durwood in forum Road Runner
    Replies: 2
    Last Post: 11-10-2006, 10:31 AM
  4. send commands to apps not working?
    By liquid_smoke in forum Road Runner
    Replies: 15
    Last Post: 10-27-2005, 05:42 AM
  5. status update....
    By 0l33l in forum PowerVoice
    Replies: 17
    Last Post: 05-05-2005, 01:22 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •