Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: RideRunner crash on resume

  1. #1
    Variable Bitrate
    Join Date
    Mar 2007
    Location
    Nashua, NH
    Posts
    243

    RideRunner crash on resume

    I am running RR release 4/18/09. When I resume from standby, things usually work fine, but sometimes they don't. RR appears to crash on resume. The RR process is not in task manager and winamp is still running.

    I finally had debug turned on when it happened. Here's the end where it happened (I also attached the full debug.txt):

    6/5/2009 6:11:49 PM: SpeedVol Mode=line OldVol=51090 NewVol=50435 Speed=38.009364 BaseVol=0
    6/5/2009 6:11:51 PM: SpeedVol Mode=line OldVol=50435 NewVol=48470 Speed=33.161896 BaseVol=0
    6/5/2009 6:11:52 PM: SpeedVol Mode=line OldVol=48470 NewVol=45850 Speed=28.112944 BaseVol=0
    6/5/2009 6:11:53 PM: SpeedVol Mode=line OldVol=45850 NewVol=45195 Speed=26.915892 BaseVol=0
    6/5/2009 6:11:54 PM: SpeedVol Mode=line OldVol=45195 NewVol=45850 Speed=28.172204 BaseVol=0
    6/5/2009 6:11:55 PM: SpeedVol Mode=line OldVol=45850 NewVol=45850 Speed=28.172204 BaseVol=0
    6/5/2009 6:11:56 PM: SpeedVol Mode=line OldVol=45850 NewVol=47160 Speed=30.850756 BaseVol=0
    6/5/2009 6:11:57 PM: SpeedVol Mode=line OldVol=47160 NewVol=47815 Speed=32.77078 BaseVol=0
    6/5/2009 6:11:58 PM: WM_POWERBROADCAST: wParam=0
    6/5/2009 6:11:58 PM: WM_POWERBROADCAST: wParam=0
    6/5/2009 6:11:58 PM: SpeedVol Mode=line OldVol=47815 NewVol=49125 Speed=34.6671 BaseVol=0
    6/5/2009 6:11:59 PM: WM_POWERBROADCAST: wParam=PBT_APMSUSPEND
    6/5/2009 6:11:59 PM: PrepareForHibernate: (Start)
    6/5/2009 6:11:59 PM: Enter Exec: False, audio_player.skin, "ONSUSPEND", False
    6/5/2009 6:11:59 PM: Que Exec: True, audio_player.skin, "ONSUSPEND", False
    6/5/2009 6:11:59 PM: Leave Exec: False, audio_player.skin, ONSUSPEND, False
    6/5/2009 6:12:01 PM: PrepareForHibernate: (After radio power's)
    6/5/2009 6:12:01 PM: PrepareForHibernate: Event/File Flush (end sub)
    6/5/2009 6:12:04 PM: WM_POWERBROADCAST: wParam=PBT_APMSUSPEND
    6/5/2009 6:19:49 PM: WM_POWERBROADCAST: wParam=PBT_APMRESUMEAUTOMATIC
    6/5/2009 6:19:49 PM: WM_POWERBROADCAST: wParam=PBT_APMRESUMESUSPEND
    6/5/2009 6:19:49 PM: ---------------------------->
    6/5/2009 6:19:49 PM: ResumeFromHibernate: (start)
    6/5/2009 6:19:49 PM: WM_POWERBROADCAST: wParam=PBT_APMRESUMESUSPEND
    6/5/2009 6:19:49 PM: ResumeFromHibernate: (Resuming = true)
    6/5/2009 6:19:49 PM: WM_POWERBROADCAST: wParam=PBT_APMRESUMEAUTOMATIC
    6/5/2009 6:19:49 PM: WM_POWERBROADCAST: wParam=PBT_APMRESUMESUSPEND
    6/5/2009 6:19:49 PM: ResumeFromHibernate: (Resuming = true)
    6/5/2009 6:19:49 PM: WM_POWERBROADCAST: wParam=PBT_APMRESUMESUSPEND
    6/5/2009 6:19:49 PM: ResumeFromHibernate: (Resuming = true)
    6/5/2009 6:19:49 PM: WM_POWERBROADCAST: wParam=PBT_APMRESUMESUSPEND
    6/5/2009 6:19:49 PM: ResumeFromHibernate: (Resuming = true)
    6/5/2009 6:19:53 PM: ResumeFromHibernate: (after resume delay)
    6/5/2009 6:19:53 PM: Enter Exec: False, audio_player.skin, "ONRESUME", False
    6/5/2009 6:19:53 PM: Que Exec: True, audio_player.skin, "ONRESUME", False
    6/5/2009 6:19:53 PM: Leave Exec: False, audio_player.skin, ONRESUME, False
    6/5/2009 6:19:53 PM: ResumeFromHibernate: Start tuners... Sirius, XM, & HD
    6/5/2009 6:19:53 PM: CheckResume: ResumeMusic=2 WasRadio=0
    6/5/2009 6:19:53 PM: SpeedVol Mode=line OldVol=49125 NewVol=49125 Speed=34.6671 BaseVol=0
    6/5/2009 6:19:53 PM: SpeedVol Mode=line OldVol=49125 NewVol=49125 Speed=34.6671 BaseVol=0
    6/5/2009 6:19:53 PM: ResumeFromHibernate: (End Sub)
    Attached Files Attached Files

  2. #2
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    Update to 6/1 version... you are 2 months behind.. and we did fix an issue with the roadrunner compatibility .exe

    ALSO USE THE INSTALLER, or you will not be getting ALL the newest files.. and in this case the one you need...

    and try again...

    the debug log looks clean...
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  3. #3
    Variable Bitrate
    Join Date
    Mar 2007
    Location
    Nashua, NH
    Posts
    243
    Thanks for the quick reply Mitch!

    On NISU.com, there is an updater and an installer. Are you saying to use the installer and not the updater? Or is the updater fine?

  4. #4
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    The recommendation is to use the installer to ensure you always have the latest of everything. The update is generally ok if you have the very last version (which you don't).
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  5. #5
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    exactly what gunio said,

    I have said this many times ALWAYS USE THE INSTALLER!!!!!!!

    The INSTALLER will update you to the NEWEST of EVERYTHING!
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  6. #6
    Variable Bitrate
    Join Date
    Mar 2007
    Location
    Nashua, NH
    Posts
    243
    I used the installer (and not the updater) last night and had 3 good standby/resume sequences. Then this morning it failed again on the resume. When Windows resumes, I see no desktop (it is set to hidden in rr.ini) and Winamp. Ctrl-Alt-Del brings up Task Manager and I can see RideRunner is gone.

    Anything else I should try?

    BTW, I am running TinyXP rev 9 and using the included CarWings skin.

  7. #7
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    can u look at you're event log for applications
    lets see what crashed


    also lets see that debug log of the crash...
    save it next crash

    also lets remove plug ins: obdmpg, RRGas, & movietimes

    just incase its crashing inside one of them,
    obdmpg... for sure, since it talks to some kind of external hardware
    that mgiht not be ready, when u resume
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  8. #8
    Variable Bitrate
    Join Date
    Mar 2007
    Location
    Nashua, NH
    Posts
    243
    Well, while trying some different things, I started getting pop-ups showing OBDMPG encountering errors on resume. I completely removed OBDMPG from the plugin folder (at first I just disabled it...this lead to the pop-ups). and have not seen any more problems resuming from a standby.

    I don't think it has anything to do with the hardware being available since it is using a real com port and not a USB to serial adapter.

    Thanks Mitch!!

    Now I just have to figure out how to restore the DTR toggle on the com port to raise/lower the power antenna when HDRadio is selected. I had this working before...

  9. #9
    High Voltage blk02si's Avatar
    Join Date
    Jul 2005
    Location
    Motorcity
    Posts
    2,267
    Blog Entries
    1
    It's not a RR issue, Windows is just generally unstable and unpredictable with hibernate, standby and resume in my experiences.
    Build Things, it keeps your brain busy.

    AutoPC v1 (Retired) - AutoPC v2 (in progress) - www.shocknet.us

  10. #10
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    great meisner...
    yes, disabling it, doesnt totally free it up, + disable is only supported if the plugin actally supports the disable, since it was a feature I added a few months ago

    i dont know anything about this plugin
    but it does look like it got updated on 6/7/2009!!!!

    i just looked at 1.4 source, its not up to current extension plugin standards(loose term)
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

Page 1 of 2 12 LastLast

Similar Threads

  1. Resume command throws RR to 100% - All fixed
    By obrienj in forum RR Bug Tracker
    Replies: 3
    Last Post: 08-25-2008, 08:37 PM
  2. Music plays no matter what on resume
    By fewman in forum Road Runner
    Replies: 6
    Last Post: 01-28-2007, 12:17 PM
  3. Resume after hibernate scrutinized
    By ldave in forum PowerVoice
    Replies: 6
    Last Post: 02-09-2006, 11:04 PM
  4. Appsthat don't resume right
    By Cat Monkey in forum General Hardware Discussion
    Replies: 2
    Last Post: 12-01-2004, 05:47 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •