Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: RR not displaying ID3 from playlist load

  1. #11
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    did you try using the LOALIST command?
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  2. #12
    Constant Bitrate Stealth915's Avatar
    Join Date
    Apr 2004
    Location
    Bay Area, CA
    Posts
    137
    The LOADLIST command works but doesn't it requires an absolute path to the m3u file?
    Code:
    "LOADLIST;D:\Music\~Playlists\test.m3u;my playlist"
    Is there a way to get it to load the currently selected playlist file in the load_playlist skin?
    2004 Mazda3 Carputer Worklog - Update 5/17/11: Carputer 2.0 Hardware Selection

  3. #13
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Yes, "SELECT"
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  4. #14
    Constant Bitrate Stealth915's Avatar
    Join Date
    Apr 2004
    Location
    Bay Area, CA
    Posts
    137
    Hmm, "SELECT" is the command being used by the skins, and using it to load a playlist doesn't load the ID3 tags.

    Does RR handle loading a playlist with SELECT differently from using LOADLIST? Is anyone else having this problem?
    2004 Mazda3 Carputer Worklog - Update 5/17/11: Carputer 2.0 Hardware Selection

  5. #15
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    If you highlight the M3U file and hit "SELECT" then it should be exactly the same as LOADLIST. If you go INTO the playlist (using "BROWSE") then hit "SELECT" it will NOT be the same thing.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  6. #16
    Constant Bitrate Stealth915's Avatar
    Join Date
    Apr 2004
    Location
    Bay Area, CA
    Posts
    137
    I FIGURED IT OUT!

    All of my M3U playlists use relative paths:
    Code:
    #EXTM3U
    #EXTINF:236,Avant - When It Hurts
    ..\new\04-avant-when_it_hurts.mp3
    #EXTINF:319,Eminem - My Mom
    ..\new\03 My Mom.mp3
    #EXTINF:243,Flo Rida (feat. Ne-Yo) - Be On You
    ..\new\07  Flo Rida - Be On You [Feat. Ne-Yo].mp3
    If I change it to use the absolute path of the files, everything works fine:
    Code:
    #EXTM3U
    #EXTINF:236,Avant - When It Hurts
    E:\new\04-avant-when_it_hurts.mp3
    #EXTINF:319,Eminem - My Mom
    E:\new\03 My Mom.mp3
    #EXTINF:243,Flo Rida (feat. Ne-Yo) - Be On You
    E:\new\07  Flo Rida - Be On You [Feat. Ne-Yo].mp3
    Still, this seems to be a strange problem. In summary:

    Using relative paths in an m3u playlist will cause the ID3 tags to not display properly. When this happens I have found 2 ways to get it to display the tags correctly:
    1) Exit RR and reload it
    2) Go into HD Radio and change the channel a few times (not quite sure why this works)

    Anyways, I'm not sure if this would be considered a bug in RR, but would it be easy to fix? In the meantime, I'll convert all my playlists to use absolute paths.
    2004 Mazda3 Carputer Worklog - Update 5/17/11: Carputer 2.0 Hardware Selection

  7. #17
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,256
    rel path seems bad to me, the question would be relative to WHAT
    when rr is running, the current drive is RR root
    rr is prob not gonna know where to open those files for tag...
    but in winamp... i dont know whats the current drive


    also... if you are using winamp...
    you know, u could and prob should let winamp process tags
    try that, ive posted it a few times how to set winamp up to do the tags
    its an option in winamp->preferences->titles
    on the new winamp, i chose the last option, read metadata in the backgound...
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  8. #18
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Relative paths are not really supported in RR (because like mitch said -- relative to WHAT path?), however, when you close/exit RR and re-open it , it will tell winamp to save the playlist (for resuming later) and it will likely save it without relative paths, that's why it works the next time around.. this happens in a similar fashion when you use TV/HD/Video etc where RR asks the player to save the playlist so it can resume later.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

Page 2 of 2 FirstFirst 12

Similar Threads

  1. ID3 versions, what does RR use?
    By Dougw133 in forum Road Runner
    Replies: 18
    Last Post: 03-16-2009, 12:23 PM
  2. Displaying IBUS information on RR
    By wookie_g in forum Road Runner
    Replies: 3
    Last Post: 07-14-2007, 08:59 PM
  3. RR fails to load / vis display glitch
    By RhinoT16S in forum RR Bug Tracker
    Replies: 23
    Last Post: 02-23-2005, 08:14 PM
  4. Playlist Load bugs
    By teedty1 in forum MediaCar
    Replies: 5
    Last Post: 03-07-2004, 11:42 PM
  5. Slow playlist load at winamp startup
    By xa0s in forum Software & Software Development
    Replies: 6
    Last Post: 08-18-2000, 10:16 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •