Results 1 to 6 of 6

Thread: Sendkey not working

  1. #1
    Low Bitrate
    Join Date
    Mar 2006
    Posts
    105

    Sendkey not working

    I've got my pc configured so that a "Ctrl-Q" command launches my nvidia nview screen that lets me change my desktop mode from dual view to extended.

    When I'm using RR and I push the Ctrl-Q on my keyboard, the nview screen appears and I am able to do what I want. I've created a button on a RR screen and given it the following command:
    "SENDKEY;^{q}" and when I use it nothing happens. I've read about the "ACTIVATE" command, but I'm not sure what I should be activating. The Ctrl-Q command is sent to windows....how to I use the sendkey command to send to windows and not a specific app?

    Any help would be greatly appreciated.

  2. #2
    Low Bitrate
    Join Date
    Jan 2008
    Posts
    87
    try sending to explorer.exe, i am not sure wether that will work but i think it should.

    why not trying usong the button in rr to open the navida screen rather than send crtl q

  3. #3
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Sendkeys does NOT work for everything. In any case..

    How did you map CTRL+Q ? If you did it by a windows shortcut, all you have to do is copy the command line used to open the screen and use the RUN command on a button to execute the same thing.

    For the nview application itself, you may want to check this:
    http://www.dtvforum.info/index.php?showtopic=39689

    From the above, you should be able to at least make 2 buttons to switch between a profile and another directly (using the RUN command on each with the desired parameters).
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  4. #4
    Low Bitrate
    Join Date
    Mar 2006
    Posts
    105
    Quote Originally Posted by guino View Post
    Sendkeys does NOT work for everything. In any case..

    How did you map CTRL+Q ? If you did it by a windows shortcut, all you have to do is copy the command line used to open the screen and use the RUN command on a button to execute the same thing.

    For the nview application itself, you may want to check this:
    http://www.dtvforum.info/index.php?showtopic=39689

    From the above, you should be able to at least make 2 buttons to switch between a profile and another directly (using the RUN command on each with the desired parameters).
    The ctrl+q was mapped in the nview software itself. I did try activating the "explorer.exe" before posting this, but was unsuccessful. I'll read through the above post and see what I can figure out.

    Thanx guino.

  5. #5
    MGD
    MGD is offline
    FLAC
    Auto Apps:loading...
    MGD's Avatar
    Join Date
    Feb 2005
    Location
    Los Angeles
    Posts
    1,756
    Try this one "SENDKEY;(^+q)"

  6. #6
    Low Bitrate
    Join Date
    Mar 2006
    Posts
    105
    Quote Originally Posted by MGD View Post
    Try this one "SENDKEY;(^+q)"
    Thanx...tried it but it didn't work.

    I took another approach with it. When pressing Ctrl-Q, the nvidia driver was actually launching an exe named "nvdspsch.exe". When I call this executable directly from the command line is works as desired. So instead of using sendkeys with the ctrl-q, I'm using a custom command setup in the ExecTBL file that executes RR's RUN command with the appropriate path/filename.

    Thanx everyone for the help/suggestions.

Similar Threads

  1. No USB Devices Working Out of the Blue
    By tbird2340 in forum General MP3Car Discussion
    Replies: 6
    Last Post: 10-17-2007, 12:21 PM
  2. -DisableWindowHooks not working - 1.1.0.0
    By Indy in forum StreetDeck Bug Reports
    Replies: 3
    Last Post: 07-31-2007, 09:40 AM
  3. SPV M700 / HTC P3600 not working with Phonecontrol
    By Tracert in forum PhoneControl
    Replies: 0
    Last Post: 07-13-2007, 11:16 PM
  4. Anyone currently working with 18f2550
    By lez in forum General Hardware Discussion
    Replies: 17
    Last Post: 11-03-2006, 08:44 AM
  5. Sendkey not working
    By ThunderStick in forum Road Runner
    Replies: 8
    Last Post: 09-12-2006, 07:28 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •