Results 1 to 9 of 9

Thread: RR and Unicode

  1. #1
    Variable Bitrate ryuandwings's Avatar
    Join Date
    Nov 2003
    Location
    TN
    Posts
    273

    RR and Unicode

    I think I have proplem with unicode in RR.
    Basically some fonts are not correctlly displaying in RR.
    Please see attached images.
    First image is the folder name as it appears in Windows and it is displayed correctly.
    Second image is from browse page in RR and the folder name is not correct. There are many other instances.

    Becouse it is not correct, I can not select the folder to do anything.

    As I understand, I don't have to set "international" and "locale" in setting anymore, at least the option is not part of the configuration.
    I have set the Unicode to Japanese in control panel, regioal setting.

    Can someone tell me what I am doing wrong?

    Thanks

    Ryu
    Attached Images Attached Images   

  2. #2
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,244
    we dont even know what version of RR you're running...
    really need to post some info
    alot of work has been done on unicode

    what version of RR
    if winamp as player what version

    things like that

    Guino, prob knows what better questions need to be asked
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  3. #3
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,244
    from another POST... i see u menu using winamp 5.13

    winamp that OLD doesnt support unicode


    i would make sure you install the NEWEST winamp
    also... you should have RideRunner 10/5/2009!

    mitch
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  4. #4
    Variable Bitrate ryuandwings's Avatar
    Join Date
    Nov 2003
    Location
    TN
    Posts
    273
    Mitchjs

    I updated winamp to 5.56. Still the same thing...
    RR should be the latest, it says 10/06/09.

    What other information should I give you?

    Thank you for your help.

    Ryu

  5. #5
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    can you please try different skins ? this could easily be a font issue, meaning the font used in that specific skin doesn't have the characters you're trying to display. I would also suggest trying to change the font name in the skin directly/manually to use a font that you KNOW works with your specific text.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  6. #6
    Variable Bitrate ryuandwings's Avatar
    Join Date
    Nov 2003
    Location
    TN
    Posts
    273
    guino,

    I changed the font in each skin file with two fonts that are standard Japanese Windows fonts and same result.
    Also tried with Carwings and Omega skins and same result.

    Are there anything else I can try?

    Thanks

    Ryu

  7. #7
    Variable Bitrate ryuandwings's Avatar
    Join Date
    Nov 2003
    Location
    TN
    Posts
    273
    guino,

    After playing around for more, I noticed a pattern.
    When I select a folder and add entire folder contents in "browse" page, then all songs are displyed correctly in Audio Player Play list.
    But if I try to select same songs in the same folder individually, then I can not select the song.
    It seems like the audio browse page is causing this problem.

    I hope this make sense.

    Ryu

  8. #8
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,244
    i did a bunch of work on unicode...
    i found and fixed some things
    i need a tester

    pm me
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  9. #9
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,244
    i think i got this nailed...
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

Similar Threads

  1. RR 09-22-2009 Release
    By mitchjs in forum Road Runner
    Replies: 96
    Last Post: 10-01-2009, 06:50 PM
  2. RR 08-01-2009 Release (Updated: 8/21)
    By mitchjs in forum Road Runner
    Replies: 78
    Last Post: 09-07-2009, 07:44 AM
  3. Unicode - My findings and maybe a bug?
    By RS200Z in forum Road Runner
    Replies: 1
    Last Post: 06-01-2008, 11:21 AM
  4. RR 09-02-2007 ... Way Overdue update ..
    By guino in forum Road Runner
    Replies: 170
    Last Post: 02-05-2008, 07:34 PM
  5. Replies: 0
    Last Post: 11-04-2005, 05:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •