Results 1 to 8 of 8

Thread: [Visualizations] Getting it to work right with winamp 5.56 in windows 7?

  1. #1
    Variable Bitrate Wayne613's Avatar
    Join Date
    Apr 2009
    Location
    Delaware
    Posts
    306

    [Visualizations] Getting it to work right with winamp 5.56 in windows 7?

    It's possible this has already been addressed, but I could not find anything relevant. Even milkdrop in the newer 5.56 winamp doesn't seem to work right with the milkdrop setting in rrconfig with my setups for some reason (both win7-64bit). I'm unsure from the helpfiles and such what the best version of winamp to use is, as it appears to be a bit dated.

    Something's not quite right, perhaps with the winamp interface dll in Win7? I never tried to get this to work when I had XP going..

    This is for Milkdrop 2.1:
    I set rrconfig for milkdrop. The RR screen will not show the winamp playlist right away. Usually have to play, or click the music button to get it to show the track. But, if I click play it will start, then eventually display the track at the top.

    If I click the music button and then wait a second for it to initialize correctly, then afterwards click the visualize button, it will then work (embed the visualization screen). ANY other way and it won't embed. Ideas?

    The same symptoms are present for AVS as well.

    Should I just get an older version of winamp?
    2008 Ford Mustang GT/CS CARPC(99%)
    Software: Ride/Road-Runner, Digital FX skin 5.x, iGuidance 2011, GPSgate on Win7 64bit

  2. #2
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    This is odd.. does it work for you with an earlier version of winamp ?
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #3
    Variable Bitrate Wayne613's Avatar
    Join Date
    Apr 2009
    Location
    Delaware
    Posts
    306
    Quote Originally Posted by guino View Post
    This is odd.. does it work for you with an earlier version of winamp ?
    I just have the latest, I will try with the latest listed version in the help file and check. Hopefully it'll work. =)

    This has been driving me nuts now for the past day or so. I thought I had it sussed out a little while ago after installing autoit to grab the class name and window names for the AVS embedding. But was wrong. Think the rrconfig tool works fine for what the instructions are, it's just something screwy with win7 again.

    Back in a few to edit this with results:

    Using the listed 5.13 of winamp in the help file/instructions:
    It's more than a bit "off", as in the main buttons show the desktop background as does the logo center screen(which doesn't come back when visualization is on) when switching from the music section back to the main menu. And it gives a nice incompatibility message when you try to install it in win7, but it DOES embed each time. The opacity is reversed it seems, since the RR screens seem to be made transparent, but the visual is totally obscuring the art and track info on the main screen. Clicking menu for the second menu screen comes up fubar as well. But then when going back to the first it's fixed temporarily (you can then see the center screen logo area again).

    The playlist/track listing behavior and scrambled transparency is consistant for both versions though. If I startup, click music, allow the track name to show/list properly, then go back to the main menu the visualization will embed correctly at the top. It must be disabled before clicking any other menu buttons though, same for the actual music menu. Inside it, wait, click visualize, works, if I don't turn it back off before exiting that menu the main screen will get messed up.

    Milkdrop doesn't give transparency no matter what I do (art, trackname in main screen are always obscured), but setting up AVS from the help file in DFX4 helpfiles folder will. Of course this is all dependent on altering the appropriate rrconfig/rr.ini entries for each, and the less obvious of having to enter the music menu after starting up RR to get the trackname to list properly before starting a visualization.

    Edit:
    I set the same thing up, but with windows media player and the visualizations work seamlessly without causing screen issues, but I still have the same needing to click the music button and waiting a second or two for it to load. This is also present in the carwings skin.
    2008 Ford Mustang GT/CS CARPC(99%)
    Software: Ride/Road-Runner, Digital FX skin 5.x, iGuidance 2011, GPSgate on Win7 64bit

  4. #4
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Well, I just installed and tested Winamp 5.56 and everything seems to work as expected (at least on XP). The only thing you need to verify is that for Milkdrop 2 you must disable the "Integrate with winamp Skin" option in milkdrop settings (default ON).

    On Vista/Win7 I HIGHLY recommend you go in the compatibility tab of RideRunner.exe and Disable Visual Themes, Disable Desktop Composition and disable DPI scaling (Win7), then see if it helps - then you can try re-enabling one by one to see if it changes.

    Please note that TRANSPARENCY on some visualizations (i.e. Milkdrop) may require a quite powerful machine as the visualization itself is quite demanding already. I know on my machine for instance, Milkdrop will just keep flashing but no transparency will work, while AVS transparency works fine.

    If all the above fails, then I'd like you to make some screenshots or a video of the issues you're seeing.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  5. #5
    Variable Bitrate Wayne613's Avatar
    Join Date
    Apr 2009
    Location
    Delaware
    Posts
    306
    Yeah, the disable integration I knew of. I haven't set compatabilty modes up, so will try that. Power really shouldn't be much of an issue with the setups I'm running and testing on.

    I just got it working the exact same as WMP12 with foobar2000. Visualization works great, figures. All but the one I want.

    This solves the issue of it causing all sorts of transparency havoc with the screens, and it'll put the visualization in the embedded window now even if I don't get the track to show first. It's still more than a little flaky however. Milkdrop still has no transparency for either screen, so track and album art can't be seen, both visualization types take a second to re-embed, switching from music to the main menu screen and visa-verse as well as others results in it disappearing, and then needing to be restarted with the hidden tap, or the vis button in the music menu.

    Haven't used foobar for quite some time, think it might be time to switch. =)
    2008 Ford Mustang GT/CS CARPC(99%)
    Software: Ride/Road-Runner, Digital FX skin 5.x, iGuidance 2011, GPSgate on Win7 64bit

  6. #6
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Quote Originally Posted by Wayne613 View Post
    Yeah, the disable integration I knew of. I haven't set compatabilty modes up, so will try that.

    I just got it working the exact same as WMP12 with foobar2000. Visualization works great, figures. All but the one I want.
    If you post the visualization you're trying to use, we may try to help. It's a given that some visualizations may not work 100%, but sometimes it's just a setting (and others may already have settings for it).
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  7. #7
    Variable Bitrate Wayne613's Avatar
    Join Date
    Apr 2009
    Location
    Delaware
    Posts
    306
    Quote Originally Posted by guino View Post
    If you post the visualization you're trying to use, we may try to help. It's a given that some visualizations may not work 100%, but sometimes it's just a setting (and others may already have settings for it).
    I was trying to get Milkdrop and/or AVS to work right in winamp 5.56.

    The comment you quoted was just another test of mine. I can use foobar just fine it seems for everything I need as I went through the instructions you gave for it, and everything works perfectly in Win7 here; so I think I'm just going to scrap the winamp install.

    Yeah, I'm sold. Just as good, lower footprint, and I can change menu's and keep the cool visualizations without any weirdness. =)
    2008 Ford Mustang GT/CS CARPC(99%)
    Software: Ride/Road-Runner, Digital FX skin 5.x, iGuidance 2011, GPSgate on Win7 64bit

  8. #8
    Variable Bitrate Wayne613's Avatar
    Join Date
    Apr 2009
    Location
    Delaware
    Posts
    306
    The irony is that the foo_vis_shpeck component someone made will do the winamp visualizations in a wrapper without having winamp even installed with some tweaking. Running milkdrop outside of RR while RR uses the default foobar visual. Still seamless. Nice.
    2008 Ford Mustang GT/CS CARPC(99%)
    Software: Ride/Road-Runner, Digital FX skin 5.x, iGuidance 2011, GPSgate on Win7 64bit

Similar Threads

  1. How to make Winamp TV Plugin work with RR
    By ramez75 in forum Road Runner
    Replies: 28
    Last Post: 09-03-2010, 01:17 AM
  2. Stealthy surfing at work?
    By e_z_street in forum Off Topic
    Replies: 15
    Last Post: 10-07-2009, 03:30 AM
  3. Quality of work
    By BMVEE in forum RR Skins
    Replies: 3
    Last Post: 03-14-2007, 09:38 AM
  4. Prison vs Work
    By ACHIEVER in forum Off Topic
    Replies: 20
    Last Post: 04-15-2005, 02:53 PM
  5. Replies: 4
    Last Post: 11-18-2002, 09:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •