Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Riderunner and Creative X-FI Audio

  1. #1
    Constant Bitrate l1nk's Avatar
    Join Date
    Jun 2007
    Location
    Sardinia Island
    Posts
    166

    Riderunner and Creative X-FI Audio

    I've bought this soundcard some time ago to replace my carpc integrated one (intel D945GCLF2 mb).
    Today, after disabling the old soundcard from the bios setup, I've installed the new soundcard then I switched all the connections (5.1 setup) from old audio card to new one and tested.
    Sounds better, it's undeniable and it's a lot better on silence test (i.e. when playing nothing).
    However, I now have some doubt. The RR mixer I've created on my skin with controls for front, rear and subwoofer volume (using RR VOL command) it's malfunctioning; the front, rear and subwoofer controls refuse to respond! I guess it depends on the fact that the windows mixer for the creative x-fi soundcard don't show the classic labels "front", "rear", etc that I used together with the RR VOL command in my mixer.skin file.
    Any advice on how to handle this issue? Is there some other guy out there using this creative soundcard?

  2. #2
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    This isn't an "issue" -- it's simply the fact that this card doesn't have the same mixer audio lines OR they may be there under different names. Many cards just don't have support for Front/Rear/Sub lines (this could be one of those) in which case there's just no way to control anything like that. You can make a debug line and see all the audio lines available (listed in the beginning of the debug file) or you can use the windows mixer to see which lines are available for control, if there's some sort of rear/front control, then it may be just a matter of finding the right names for the audio lines and adjusting the skin accordingly.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #3
    Constant Bitrate popi79's Avatar
    Join Date
    Sep 2006
    Posts
    150

    x-fi

    I use the same card x-fi xtreme music and yes the sound is far better.
    I don't use the mixer in RR I use the x-fi console in entertainment mode with all controls...
    now maybe is a driver issue, try to uninstall and install again.

    "Most of the users you'll see in this site are still learning specially me"

  4. #4
    Constant Bitrate l1nk's Avatar
    Join Date
    Jun 2007
    Location
    Sardinia Island
    Posts
    166
    Quote Originally Posted by guino
    Many cards just don't have support for Front/Rear/Sub lines (this could be one of those) in which case there's just no way to control anything like that.
    OMG!!

    Tomorrow I'll try to take a look at the rr debug file then...

    Quote Originally Posted by popi79
    now maybe is a driver issue, try to uninstall and install again.
    ...I'll try to install updated drivers because at current time I only have master, wave, midi (etc.) controls on the windows mixer.


    Any other creative x-fi user opinion is appreciated.

  5. #5
    Constant Bitrate l1nk's Avatar
    Join Date
    Jun 2007
    Location
    Sardinia Island
    Posts
    166
    Quote Originally Posted by popi79 View Post
    I use the same card x-fi xtreme music and yes the sound is far better.
    I don't use the mixer in RR I use the x-fi console in entertainment mode with all controls...
    now maybe is a driver issue, try to uninstall and install again.


    A question for you: can you please check your windows mixer and tell me if you have such controls as in the picture?


  6. #6
    Constant Bitrate popi79's Avatar
    Join Date
    Sep 2006
    Posts
    150

    my carputer x-fi control panel

    This is what my sound control panel looks like....

    using 6.0.1.1301 3/3/2009 driver.
    Attached Images Attached Images  
    "Most of the users you'll see in this site are still learning specially me"

  7. #7
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    OT...

    @|1nk
    Great avatar! I like that character the best...
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  8. #8
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Quote Originally Posted by popi79 View Post
    This is what my sound control panel looks like....

    using 6.0.1.1301 3/3/2009 driver.
    Is this win98 or something ? the driver version can definitely make a difference.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  9. #9
    Constant Bitrate l1nk's Avatar
    Join Date
    Jun 2007
    Location
    Sardinia Island
    Posts
    166
    Quote Originally Posted by popi79 View Post
    This is what my sound control panel looks like....

    using 6.0.1.1301 3/3/2009 driver.

    Ok, same here! I've installed latest drivers for win xp from creative but no change on windows mixer.

    So, I think Guino was right and this specific audio card drivers does not provide "classic" audio controls on windows mixer even if configured for 5.1 channels.
    The software provided with the card supplies some kind of control (not tested yet) on various channels but it isn't fully integrated with the o.s. controls.

    At this point I think I'll proceed with a complete restyle of my mixer leaving only the master and wave volume, joining the eq controls in the same screen, as I have a lot of extra space!

    It's really a shame that I can't control front, rear and subwoofer volume directly from the frontend interface, expecially because it's a simple software lack from creative!


    @Blue ZX3: Thank you, I like Achmed a lot but also José Jalapeño (on a Stick) is not bad

  10. #10
    Variable Bitrate jessekilner's Avatar
    Join Date
    Aug 2008
    Posts
    266
    I have a very similar problem with the x-fi 5.1 (USB) it worked fine all levels responded in Xp, but now Im running a dualcore setup and finding Xp drivers is turning out difficult. So I switched to Win7 Ult. Well now RR only raises the two fronts none of the rears or sub will raise. I triied changing the setting in config (master...Line) but no luck. It does this on both Home PC's as well with latest RR. I triied different Creative drivers also. I triied Centrafuse demo to see if that would work & it does but if I touch any of the mixer settings then it unbalances the left and right and the volume then stops working within Centrafuse. I would simply switch back to XP but the motherboard is a pain to find drivers thats are'nt supported. I would hate to use onboard as the X-fi has 24bit-96khz any suggestions would be awsome.
    Did it.. Done it... now I got to keep the neighbors kids away!!

Page 1 of 3 123 LastLast

Similar Threads

  1. Why does (MY) audio suck?
    By nitefallz in forum Car Audio
    Replies: 71
    Last Post: 09-28-2009, 11:53 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •