Results 1 to 7 of 7

Thread: Winamp not staring with RR

  1. #1
    Variable Bitrate
    Join Date
    Feb 2006
    Posts
    393

    Winamp not staring with RR

    RR version 3/2/10
    Winamp V5.13
    I just went through a complete reinstall from operating system on up. I use RR and DFX 4.0. I remember this happening every time I start from scratch but I can't remember the resolution. When I start RR winamp does not start with it. If I look at the task list winampa.exe is running before and after but winamp never starts. Config is set to winamp (auto) and winamp is installed in default location V5.13.

    Also, posibly related, I cannot get the skin to accept a "Select" command. I hit the button but the playlist never loads any songs. This is true even if I manually load Winamp before or after RR has loaded. Winamp and RR are not speaking to eachother.

    Any ideas on how to solve/debug?

  2. #2
    Maximum Bitrate bratnetwork's Avatar
    Join Date
    Oct 2007
    Location
    Haledon, NJ
    Posts
    503
    Try that manual option for winamp... I had an issue with it once and I did it manual and it worked for me.

  3. #3
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    whats "winampa.exe"

    also v5.13 is very old, doesnt support unicode, just a FYI
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  4. #4
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    winampa is the winamp agent.. it's a silly taskbar icon. Update to the latest winamp and run RRconfig to set the winamp to manual like suggested above, and set the path to it.

    If that still doesn't work, it could be something wrong with your install (or maybe you did not use the installer?) -- if this is the case you'd have to register the winamp player in the RR folder before using it (regsvr32 winamp.dll)
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  5. #5
    Variable Bitrate
    Join Date
    Feb 2006
    Posts
    393
    I did use the installer but now that you say that I remember that registering the dll is what fixes it. I did that and all is well.

    Q. I thought Winamp 5.13 was the desired version to use with RR. Is that no longer the case?

  6. #6
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    for sure not, if you are dealing with Unicode
    not to mention the security bugs in a old version like that
    update to the newest it works find with rr..and is UAC compliant
    that true way back in RoadRunner days, when the winamp module didn't know about
    winamps placement of the settings file... but not anymore
    i use the latest winamp...

    and as guino said, install RideRunner with the latest installer
    (which would register all needed dlls, there should not be a need to manually register)
    and install winamp with its installer
    and if you do, auto should work

    debug.txt will also tell you info
    if you see...
    3/27/2010 8:52:08 PM: PLAYER: Winamp Version: 5.57
    then RR, successfully found and started winamp
    (if ur hiding the player, if not, you will know anyway )
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  7. #7
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Quote Originally Posted by EricE View Post
    I did use the installer but now that you say that I remember that registering the dll is what fixes it. I did that and all is well.

    Q. I thought Winamp 5.13 was the desired version to use with RR. Is that no longer the case?
    A few versions after 5.13 were very unstable, so we were suggesting 5.13 for awhile (until new stable versions came out). These days the latest versions should be very stable and work best with unicode. If you don't need unicode, then 2.95 should still be ok.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

Similar Threads

  1. Replies: 11
    Last Post: 09-06-2009, 08:20 AM
  2. Update RR with changes from Winamp
    By drewbp in forum Road Runner
    Replies: 1
    Last Post: 05-22-2009, 01:29 PM
  3. Three questions regarding RR, winamp, gps
    By Profozone in forum Road Runner
    Replies: 6
    Last Post: 02-18-2008, 07:53 AM
  4. Problem with WINAMP in RR - Needs help!
    By Visions in forum RR Bug Tracker
    Replies: 2
    Last Post: 08-18-2007, 12:03 PM
  5. status update....
    By 0l33l in forum PowerVoice
    Replies: 17
    Last Post: 05-05-2005, 12:22 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •