Results 1 to 7 of 7

Thread: Question about RTUNE

  1. #1
    Variable Bitrate GF-ler's Avatar
    Join Date
    Aug 2005
    Location
    germany
    Posts
    336

    Question about RTUNE

    after a while i work again with riderunner.

    older skins i try to give a upgrade with the FMPRESET function.
    all i can search is, that its changing to RTUNE and have a look to carwings.

    inside carwings i found the command line
    "RTUNE;$FMP01$",@SETVARBYCODE;FMP01;FREQUENCE||SAV ETOSKIN;FMP01;$FMP01$@

    so i change all presets into commandline FMP01....FMP09
    after presets all 9 stations i take a look inside the skin.ini and it shows

    FMP01=87,6
    FMP02=93,4
    FMP03=95,0
    .
    .
    if i want to change the station by pressing one of the preset buttons it lost the commata and value behind it.
    out of 87,6 it will start 8700....93,4 it will start 9300 and so on. only 95,0 will start correct.

    did i miss anything to change ?

    another part is....because my ADS stick shows me NO RDSTEXT (problem is the USBRADIO.dll, while other frontends shows all infos correct) i use a CINERGY 600 too.
    This Card shows me the RDSTEXT but NO stereo information.
    is this normal ?

  2. #2
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    I just did a quick test here and despite of having code to prevent this kind of issue on a machine that uses comma ( , ) as the decimal point, it doesn't seem like the conversion is working correctly. The only quick fix I have for you is to set the regional settings format to US/English (so . is used instead of ,) but we'll have to fix this in the radio modules.

    Regarding the Cinergy 600 stereo, the code is in place -- I have one of those but it will be a few weeks before I get to try it (cause I'm 5000 miles away right now) -- have you tried a different skin and/or are you able to see the stereo indication correctly with another radio card (i.e. ADS) ?
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #3
    Variable Bitrate GF-ler's Avatar
    Join Date
    Aug 2005
    Location
    germany
    Posts
    336
    Quote Originally Posted by guino View Post
    I just did a quick test here and despite of having code to prevent this kind of issue on a machine that uses comma ( , ) as the decimal point, it doesn't seem like the conversion is working correctly. The only quick fix I have for you is to set the regional settings format to US/English (so . is used instead of ,) but we'll have to fix this in the radio modules.

    Regarding the Cinergy 600 stereo, the code is in place -- I have one of those but it will be a few weeks before I get to try it (cause I'm 5000 miles away right now) -- have you tried a different skin and/or are you able to see the stereo indication correctly with another radio card (i.e. ADS) ?
    thanks for your quick answer, guino.

    i have a short try with changing the language into english, and its not better. now it only shows two digits of the frequence. if you change it, i will wait for it.

    in point of CINERGY or ADS, the skin and the code is the same, i change it only with the config of ZX3.

    so the ADS shows me NO RDSTEXT but all indicators...STEREO,TA....
    the CINERGY shows me RDSTEXT but no STEREO indicator.


    for the future of the radio driver, is there any possibility to get the information what GENRE the song is ?

  4. #4
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,212
    comma system fixed in all radios...

    this should be posted in bug section
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  5. #5
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,212
    GF-ler, for your ADS, the Radio Text please use skintool

    put in a LABEL of "rdstext", check auto update... and change to some rds stations
    works here for Silabs, which ADS is a clone of
    Attached Images Attached Images  
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  6. #6
    Variable Bitrate GF-ler's Avatar
    Join Date
    Aug 2005
    Location
    germany
    Posts
    336
    Quote Originally Posted by mitchjs View Post
    GF-ler, for your ADS, the Radio Text please use skintool

    put in a LABEL of "rdstext", check auto update... and change to some rds stations
    works here for Silabs, which ADS is a clone of

    if i select the ADS stick it shows <contains no data>
    if i use the CINERGY it shows the text the station gives.

    i hve tons of USBRADIO.dll, only one of them worked perfect in my region.
    but this USBRADIO.dll is for very old versions of RoadRunner. and i dont want to go back.

    so i use the CINERGY in my car and the ADS at home. the reason for it is not the RDSTEXT, its the better work with the impendance of the car antenna. the ADS stick only worked perfect with his own antenna, all other are a problem.

  7. #7
    Variable Bitrate GF-ler's Avatar
    Join Date
    Aug 2005
    Location
    germany
    Posts
    336
    Quote Originally Posted by mitchjs View Post
    comma system fixed in all radios...

    this should be posted in bug section
    sorry, i didnt found it.

    and i search a lot.
    the same is with the pink graphic boxes. for what did some coder use them.

Similar Threads

  1. heavy-duty OBD standards support question
    By Michael2006 in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 0
    Last Post: 01-07-2007, 04:13 AM
  2. Replies: 2
    Last Post: 05-02-2006, 05:15 PM
  3. Forum Etiquette
    By Enforcer in forum Newbie
    Replies: 5
    Last Post: 01-09-2006, 05:58 PM
  4. Paint And Polish Question
    By gboy in forum Fabrication
    Replies: 8
    Last Post: 08-13-2005, 07:22 PM
  5. FM Card Question....
    By Superbike1k in forum Car Audio
    Replies: 1
    Last Post: 05-16-2005, 09:03 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •