Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: "resume" problem of ride runner,need help!

  1. #1
    Newbie
    Join Date
    Jul 2009
    Posts
    6

    Angry "resume" problem of ride runner,need help!

    "resume" problem of ride runner,need help!

    As we knew, Car PC control the ACC power throuth the "ITPS",so,when we pull out the car key,the power of car pc automatically down after few seconds.

    My problem is,when I pull out my car key,turn the car pc off,the ride runner will never resume my playlist at that position when my PC power off,

    But ,if I just exit ride runner (whitout turn off my PC),the "resume" works fine!

    So,I checked the resume.ini in the ride runner directory after I pull out car key,turn off the PC,I saw this:

    [Music Player]
    PLPosition=0
    TrackPosition=0
    Repeat=True
    Shuffle=False

    I found that, PLPosition and TrackPosition ALWAYS keep in 0 (zero),so the player ALWAYS play the list from the first one!

    if I just exit ride runner (whitout turn off my PC),I saw this:

    [Music Player]
    PLPosition=5
    TrackPosition=8857
    Repeat=True
    Shuffle=False

    Means,it's fine!

    Please,anyone who can help?

    Thanks

  2. #2
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    This is a symptom that your shutdown is not working "gracefully" or in my own terms "correctly". Either your computer is doing a hard shut off or windows is killing RR before it has a chance to save the resume info -- this could happen if you have used some of those "optimization" registry settings for xp shutdown specially the ones that reduce the amount of time that an application has to close on shutdown before windows kills it. If you have used anything like that, please remove those settings and try again.

    If you can do this, I advise you to simply WATCH the shutdown process to see if anything seems weird, but RR itself should be doing the same when you shutdown windows as it does when you exit it.

    Lastly, I don't believe this matters, but be sure that you have "RR is aware of hibernation/shutdown procedures" setting CHECKED in RRConfig.

    I use the exact same procedure (Shutdown controller) and have never had any issues with restarting -- I do in fact power off instead of hibernate.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #3
    Newbie
    Join Date
    Jul 2009
    Posts
    6
    Quote Originally Posted by guino View Post
    Either your computer is doing a hard shut off or windows is killing RR before it has a chance to save the resume info -- this could happen if you have used some of those "optimization" registry settings for xp shutdown specially the ones that reduce the amount of time that an application has to close on shutdown before windows kills it. If you have used anything like that, please remove those settings and try again.
    Thanks for the VERY professional answer,I do have "optimization" registry settings ,I will reduce it later and tell you the result.

    Thanks again

  4. #4
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    here is something to understand

    MOST LIKELY:

    when a PC is asked to shutdown, all APPLICATIONS are sent a close message
    in this case, WINAMP is closing!!!
    before RR is...

    now we have trap code, for just this possible issue, to use the last known PL position...

    you dont mention what version of riderunner you are using
    i would normally blast ya for that and tell you to test with carwings

    for sure dont over optimize shutdown times!!!


    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  5. #5
    Newbie
    Join Date
    Jul 2009
    Posts
    6
    Mission is failure.................

    I have set the shutdown "optimization" registry back to default:

    WaitToKillAppTimeout ,back to 20000

    HungAppTimeout,back to 5000

    AutoEndTasks,back to disable , (0)

    anythins elae?

    I am useing the most recent version of ride runner 9,2010, skin is elite lite 1.6.6

    Thanks

  6. #6
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    well... i assume... how you are shutting down... is signaling RR
    how about posting something we can look at, aka the debug.txt
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  7. #7
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    i missed this...

    what player are u using????!?!?!

    post that debug.txt before u go any further
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  8. #8
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    What, did you only add that fix to the winamp player plugin, and not the others as they are more special would gracisly wait for RR to be done with them before closing...hehehe
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  9. #9
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    this is a long long long long ago add to winamp.dll

    and wont be in issue with WMP
    since we manage its PL &
    since wmp becomes part of rr

    and prob not an issue with foobar
    since we manage its PL
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  10. #10
    Newbie
    Join Date
    Jul 2009
    Posts
    6
    Sorry guys...I forgot to tell you my player is foobar2000 ver.0.96...sorry for that

    Winamp works fine,I've just checked it,but foobar still doesn't work.

    Here is the debug:

    2010-09-18 13:48:07: Start -- Version: 2010-09-01
    2010-09-18 13:48:07: OS Type: Windows XP
    2010-09-18 13:48:07: FileManager: FileMode = Legacy
    2010-09-18 13:48:07: FileManager: mypath = C:\Program Files\RideRunner\
    2010-09-18 13:48:07: FileManager: ProfilePath = C:\Documents and Settings\Administrator\My Documents\RideRunner\
    2010-09-18 13:48:26: PLAYER: Foobar2000 Version: foobar2000 v0.9.6.9
    2010-09-18 13:48:27: Master Vol: main/4
    2010-09-18 13:48:27: Master Vol reports number of channels =2
    2010-09-18 13:48:27: GetLineControl Failed: 401
    2010-09-18 13:48:27: No Treble Support
    2010-09-18 13:48:27: GetLineControl Failed: 401
    2010-09-18 13:48:27: No Bass Support
    2010-09-18 13:48:27: GetLineControl Failed: 401
    2010-09-18 13:48:27: No Master ON/OFF
    2010-09-18 13:48:27: Source: Mixer line #1: wav=&H1008
    2010-09-18 13:48:27: Source: Mixer line #2: softmix=&H1004
    2010-09-18 13:48:27: Source: Mixer line #3: CD player=&H1005
    2010-09-18 13:48:27: Source: Mixer line #4: Micphone=&H1003
    2010-09-18 13:48:27: Source: Mixer line #5: PC Beep=&H100A
    2010-09-18 13:48:28: DirectDraw Count: 2 - [] [{67685559-3106-11D0-B971-00AA00342F9F}]
    2010-09-18 13:48:28: No Phidgets interface detected.
    2010-09-18 13:48:28: Plugin Manager: loading Global Plugins...
    2010-09-18 13:48:28: Plugin Manager: Plugin Found: SkinTool
    2010-09-18 13:48:28: Plugin Manager: Plugin loaded (Global): SkinTool
    2010-09-18 13:48:28: Plugin Manager: loading Global Plugins Completed.
    2010-09-18 13:48:28: LoadSkin: C:\Program Files\RideRunner\Skins\eLite Lite\
    2010-09-18 13:48:28: Plugin Manager: loading SkinDir Plugins...
    2010-09-18 13:48:28: Plugin Manager: loading SkinDir Plugins Completed.
    2010-09-18 13:48:30: CheckResume: ResumeMusic=2 WasRadio=0
    2010-09-18 13:48:30: CheckResume: Resuming to music player: PLPosition=0 TrackPosition=0
    2010-09-18 13:48:30: PlayItem Error:
    2010-09-18 13:48:30: Enter Exec: False, menu.skin, , False
    2010-09-18 13:48:30: Que Exec: True, menu.skin, "ONLINE", False
    2010-09-18 13:48:30: Leave Exec: False, menu.skin, ONLINE, False
    2010-09-18 13:48:31: Enter Exec: False, menu.skin, , False
    2010-09-18 13:48:31: Que Exec: True, menu.skin, "ONSKINSTART", False
    2010-09-18 13:48:31: EXECTBL Translation: ONSKINSTART -> $default$
    2010-09-18 13:48:31: Executing:
    2010-09-18 13:48:31: Que Exec: True, menu.skin, "ONSOURCECHANGE", False
    2010-09-18 13:48:31: Leave Exec: False, menu.skin, ONSOURCECHANGE, False
    2010-09-18 13:48:31: Enter Exec: False, menu.skin, , False
    2010-09-18 13:48:31: Que Exec: True, menu.skin, "ONSONGSTART", False
    2010-09-18 13:48:31: Leave Exec: False, menu.skin, ONSONGSTART, False
    2010-09-18 13:48:33: Enter Exec: False, menu.skin, "ONBTNPRESS||$MENUBUTTON01$", False
    2010-09-18 13:48:33: Que Exec: True, menu.skin, "ONBTNPRESS||$MENUBUTTON01$", False
    2010-09-18 13:48:33: Que Exec: True, menu.skin, "$MENUBUTTON01$", False
    2010-09-18 13:48:33: Executing: AUDIO
    2010-09-18 13:48:34: CheckResume: ResumeMusic=2 WasRadio=0
    2010-09-18 13:48:34: Enter Exec: True, audio_player.skin, , False
    2010-09-18 13:48:34: Que Exec: True, audio_player.skin, "ONSCREENCHANGE", False
    2010-09-18 13:48:34: Leave Exec: False, audio_player.skin, ONSCREENCHANGE, False
    2010-09-18 13:48:36: Enter Exec: False, audio_player.skin, "ONBTNPRESS||LOAD;audio_currentplaylist.SKIN", False
    2010-09-18 13:48:36: Que Exec: True, audio_player.skin, "ONBTNPRESS||LOAD;audio_currentplaylist.SKIN", False
    2010-09-18 13:48:36: Que Exec: True, audio_player.skin, "LOAD;audio_currentplaylist.SKIN", False
    2010-09-18 13:48:36: Executing: LOAD;audio_currentplaylist.SKIN
    2010-09-18 13:48:36: CheckResume: ResumeMusic=2 WasRadio=0
    2010-09-18 13:48:37: Enter Exec: True, audio_currentplaylist.skin, , False
    2010-09-18 13:48:37: Que Exec: True, audio_currentplaylist.skin, "ONSCREENCHANGE", False
    2010-09-18 13:48:37: Leave Exec: False, audio_currentplaylist.skin, ONSCREENCHANGE, False
    2010-09-18 13:48:39: Enter Exec: False, audio_currentplaylist.skin, "ONBTNPRESS||EXIT", False
    2010-09-18 13:48:39: Que Exec: True, audio_currentplaylist.skin, "ONBTNPRESS||EXIT", False
    2010-09-18 13:48:39: Que Exec: True, audio_currentplaylist.skin, "EXIT", False
    2010-09-18 13:48:39: Executing: EXIT
    2010-09-18 13:48:39: CheckResume: ResumeMusic=2 WasRadio=0
    2010-09-18 13:48:39: Que Exec: True, audio_player.skin, "ONSCREENCHANGE", False
    2010-09-18 13:48:39: Leave Exec: False, audio_player.skin, ONSCREENCHANGE, False
    2010-09-18 13:48:39: Enter Exec: False, audio_player.skin, "ONBTNPRESS||EXIT", False
    2010-09-18 13:48:39: Que Exec: True, audio_player.skin, "ONBTNPRESS||EXIT", False
    2010-09-18 13:48:39: Que Exec: True, audio_player.skin, "EXIT", False
    2010-09-18 13:48:39: Executing: EXIT
    2010-09-18 13:48:39: CheckResume: ResumeMusic=2 WasRadio=0
    2010-09-18 13:48:39: Que Exec: True, menu.skin, "ONSCREENCHANGE", False
    2010-09-18 13:48:39: Leave Exec: False, menu.skin, ONSCREENCHANGE, False
    2010-09-18 13:48:41: Enter Exec: False, menu.skin, "ONBTNPRESS||LOAD;settings.skin", False
    2010-09-18 13:48:41: Que Exec: True, menu.skin, "ONBTNPRESS||LOAD;settings.skin", False
    2010-09-18 13:48:41: Que Exec: True, menu.skin, "LOAD;settings.skin", False
    2010-09-18 13:48:41: Executing: LOAD;settings.skin
    2010-09-18 13:48:41: CheckResume: ResumeMusic=2 WasRadio=0
    2010-09-18 13:48:42: Que Exec: True, settings.skin, "ONSCREENCHANGE", False
    2010-09-18 13:48:42: Leave Exec: False, settings.skin, ONSCREENCHANGE, False
    2010-09-18 13:48:44: Enter Exec: False, settings.skin, "ONBTNPRESS||$MENUBUTTON27$", False
    2010-09-18 13:48:44: Que Exec: True, settings.skin, "ONBTNPRESS||$MENUBUTTON27$", False
    2010-09-18 13:48:44: Que Exec: True, settings.skin, "$MENUBUTTON27$", False
    2010-09-18 13:48:44: Executing: LOAD;shutdown.skin
    2010-09-18 13:48:45: CheckResume: ResumeMusic=2 WasRadio=0
    2010-09-18 13:48:45: Que Exec: True, shutdown.skin, "ONSCREENCHANGE", False
    2010-09-18 13:48:45: Leave Exec: False, shutdown.skin, ONSCREENCHANGE, False
    2010-09-18 13:48:47: Enter Exec: False, shutdown.skin, "ONBTNPRESS||$MENUBUTTON40$", False
    2010-09-18 13:48:47: Que Exec: True, shutdown.skin, "ONBTNPRESS||$MENUBUTTON40$", False
    2010-09-18 13:48:47: Que Exec: True, shutdown.skin, "$MENUBUTTON40$", False
    2010-09-18 13:48:47: Executing: QUIT
    2010-09-18 13:48:47: Enter Exec: True, shutdown.skin, "ONEXIT", False
    2010-09-18 13:48:47: Queued: "ONEXIT"
    2010-09-18 13:48:47: Shutdown: (1)
    2010-09-18 13:48:47: Shutdown: (2)
    2010-09-18 13:48:47: Shutdown: (3)
    2010-09-18 13:48:47: Shutdown: (4)
    2010-09-18 13:48:47: Plugin Manager: Warning Plugin skintool does not support Terminate Method
    2010-09-18 13:48:47: Plugin Manager: ALL Plugins unloaded.
    2010-09-18 13:48:47: Shutdown: (5)
    2010-09-18 13:48:48: Shutdown: (6)
    2010-09-18 13:48:48: Shutdown: (7)
    2010-09-18 13:48:48: OSUnloadMode: 1
    2010-09-18 13:48:48: Shutdown

Page 1 of 2 12 LastLast

Similar Threads

  1. Lilliput TouchKit problem solved!
    By AAVfReaK in forum LCD/Display
    Replies: 4
    Last Post: 11-07-2010, 08:29 AM
  2. Major problem with my car pc, BSOD.. killing me..
    By Ryann in forum General MP3Car Discussion
    Replies: 36
    Last Post: 08-02-2010, 07:49 AM
  3. reconnected puter and now audio problem..
    By NYCdesignkid in forum Car Audio
    Replies: 2
    Last Post: 05-30-2006, 11:09 PM
  4. gps navilock and com problem
    By lele67 in forum GPS
    Replies: 0
    Last Post: 04-01-2006, 07:41 PM
  5. Problem with directshow filter and WMP
    By EricE in forum Software & Software Development
    Replies: 0
    Last Post: 03-01-2006, 10:38 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •