Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Disable Video "Auto-Hide" scrolloff?

  1. #1
    Low Bitrate
    Join Date
    Jan 2010
    Posts
    64

    Disable Video "Auto-Hide" scrolloff?

    I am having tons of problems with the various video player options. Using Feb 2011 build with eLite Lite 1.66 skin. Win7 x64, 4gb ram.

    "Built In" worked best, but at some point after an update, the Auto-Hide function in Video did a neat trick where the interface would slide down to disappear instead of just blink off. Unfortunately this now introduces huge tearing issues where I see the top bar all the way down and pieces of video all over.

    Windows Media Player doesn't support ZOOM functionality, which renders all small videos useless.

    Media Player Classic won't show the time playing on the track or length of the video. It also leaves the mouse visible on the top left of the screen.

    VLC crashes RR completely.

    MS Directshow Player shifts the entire video up, pushing it off the screen and leaving a blank bar on the bottom. It also will not regain focus if i go into playlist/library and hit Back - it leaves the non-functional playlist on display instead.

    I would prefer to use Built In but I don't know how to disable the sliding trick. I've already turned off the menu sliding UI, but it didn't affect video auto-hide. Where do I go to do this?

    FWIW, Winamp visualizations quit working too. All of these seem to be video related but I don't know the common thread ..
    Last edited by ninja6o4; 02-22-2011 at 12:30 AM.

  2. #2
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    man you got issues...

    well in my win7 x64 set up im using VideoLan V1.1.5 and videos
    playback perfectly... mouse hides... UI auto hides...
    no issues...
    now V1.1.7, does crash once in a while...


    now for the auto hide... right now its a bit hard coded....
    but i never seen any tearing on my system...
    so 1st thought it VIDEO DRIVERS, i assume your not using the microsoft drivers, but the manufactures drivers
    so check that out...
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  3. #3
    Low Bitrate
    Join Date
    Jan 2010
    Posts
    64
    Thanks for the reply. In my next update I will take some pics to demonstrate what it's doing.

    I'll try a video driver update (I am using nvidia drivers, not MS, as you correctly predicted), but the problem started after an RR update. Generally, nothing changes in the PC, only the RR build. Each time an RR update breaks something, then I try to fix by updating everything else, MS patches, Flash update, .NET, modify the skin code, etc. until it's mostly right again.

    Auto-Hide - I can see from a development perspective that it's separate from the normal window transition options, but it would be nice to have an option to disable "Smooth Auto-Hide" or something similar.

    I recently tried VLC (since trying to fix this problem) so I am running the newest version, if that's 1.1.7 or whatever. At this point I'd rather focus on trying to get built in working like it used to.

    Out of curiousity - why do you use VLC rather than the built in?

  4. #4
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    actually, i do use builtin, but since im developing RR, i switch often...
    v1.1.5, works fine...
    v1.1.7 does crash... dont know why yet...

    but im now on built-in...
    i also use msvideo...

    did you read your PM

    there is a new skin option

    /EFFECTVIDEOHIDE=

    which lets you change how the video controls hide

    ---------- Post added at 03:46 PM ---------- Previous post was at 03:45 PM ----------

    one thing you must know video is soooo dependent on 3rd party, and its stablity and performace is up to the player you choose
    and your codecs... and that can get a mess... generally i have nothing installed but ffdshow and i see to have no isssues

    ---------- Post added at 03:48 PM ---------- Previous post was at 03:46 PM ----------

    ther has been NO change to video in a long long time... read history.txt... i have found when someone says, all i did was update RR, in most cases there was other changes to their system
    a new winamp, installed some directshow filters...something....
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  5. #5
    Low Bitrate
    Join Date
    Jan 2010
    Posts
    64
    Got the PM, thanks. Will let you know how it works tonight or the next day.

    For codecs I know what you mean - the less codecs you have installed, the better. I have an HTPC for in home, and my regular PC has digital output to AV Receiver via Optical, so I am no stranger to weird codec and output issues. It takes hours to configure but once it's running, it's great. I am running FFDshow but not sure if anything else. I'll check and report back.

    Worst case, I'll also give VLC 1.1.5 a shot to see if it's any better.

  6. #6
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    funny... i did a complete uninstall of 1.1.7, then reinstall and now it hasnt crashed since...
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  7. #7
    Low Bitrate
    Join Date
    Jan 2010
    Posts
    64
    OK.. spent some quality time with the carpc this afternoon. My setup used to have AC3filter, Haali splitter, and FFDshow from march 2010 (when I first built it.)

    Updated to your test build. Using value 0 for the fade effect, works flawlessly! No more tearing.

    However, been using MPC for so long I didn't realize that the built-in player wasn't using DXVA to decode like MPC was for my 1080p movies. Did some more testing..
    - reinstalling vlc 1.1.7 twice, no change, still crashes.
    - In MPC (I am using MPC-HC, latest x64 build), CPU usage is around 11% playing 1080p mkv. In all others, it's between 50-90% usage.
    - Removed all my codecs and installed the Shark codecs for Win7 (http://shark007.net/win7codecs.html) to try and get DXVA working for built-in player.
    - Fiddled with MPC-HC codec, FFDshow dxva codec. nothing seems to activate DXVA for built in. I got various video playback results, but none ever got me DXVA. I know it's using the codecs, because I turned on Subs under FFD dxva and the subs were played, but still high cpu.
    - When MPC-HC codec was selected, high cpu and bad aspect ratio (wouldn't resize automatically). Video/audio wouldn't sync up and got poor frame rate, blockiness, etc.
    - When FFDShow was selected, high cpu, good aspect ratio detection. Video/audio sync is fine, but I am losing frames. No blockiness though.

    I wouldn't mind using MPC in RR, but again, downside being the mouse cursor in top left and no display of time or progress bar of the video. Any thoughts?

  8. #8
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    I should try the new MPC, then id have some thoughts
    i use MPC HomeTheater and nothing from FFDSHOW (i think)
    since it has all the codecs i need built in, i use the x86 version, even though im on x64, it seems to work



    ill see about mouse,

    not sure what you mean about time progress bar, if you mean seek bar, we hide that on purpose
    not good to use anyway while in car
    is that what u mean?

    ---------- Post added at 01:54 AM ---------- Previous post was at 12:54 AM ----------

    I found an interesting solution!!!
    Last edited by mitchjs; 02-27-2011 at 12:51 AM.
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  9. #9
    Low Bitrate
    Join Date
    Jan 2010
    Posts
    64
    the progress bar i'm talking about the blue bar (in elite skin) that shows the total length of the video, then has the bar that slowly moves forward, and that you can click on to forward/rewind the video. This bar works in built in and MS directshow, but not MPC - just shows 0:00 and the bar can't be clicked on - so video playlists do not work (never knows when to start next video). If this doesn't make sense let me know, i'll take a screenshot for you to explain it better.

    I'll give the new build a try for MPC. Just wondering, is DXVA supported in built in player at all? I still prefer built in, because it is much smarter about how to interact with RR and skins in general, but I'll use MPC if i can get everything working in that.
    Last edited by ninja6o4; 02-27-2011 at 02:31 AM.

  10. #10
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    yes new mpc-hc is DXVA

    built in is using 10 year old MCI media calls... you would get limited or no control of how the video filters work... but it does work
    for most videos, as long as your machine isnt a mess of codecs!

    i use carwing_dynamic as reference, the blue bar dont mean much to me
    but you are possibly talking about the seek bar
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

Page 1 of 3 123 LastLast

Similar Threads

  1. Video Auto Hide no longer working?
    By CuzMan1 in forum Road Runner
    Replies: 5
    Last Post: 06-02-2010, 08:00 AM
  2. How to make video auto hide in custom skin?
    By nir_nissan in forum Road Runner
    Replies: 0
    Last Post: 05-18-2010, 03:58 PM
  3. How to make video auto hide in custom skin?
    By efun in forum Road Runner
    Replies: 6
    Last Post: 04-05-2009, 09:28 PM
  4. Replies: 1
    Last Post: 04-04-2006, 03:00 PM
  5. assign keyshortcut to "hide" button
    By mashina in forum FrodoPlayer
    Replies: 0
    Last Post: 06-27-2005, 05:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •