Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Upcoming RR 7-1-2011 Release

  1. #11
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    so.. if u set top line of video.ini to

    say

    00:05:00
    0
    1

    when you go into video, it should take the last played video
    which is in videos.m3u8
    (the 3rd line is 1, so it takes 1st item in videos.m3u8)

    mine is working every time... i could add some code to log when the seek happens...
    if you like

    in your debug.txt confirm...

    6/29/2011 11:39:58 PM: Executing: VIDEO
    6/29/2011 11:39:59 PM: VidPlayer: Using Player MPCHCVidRR
    6/29/2011 11:39:59 PM: VidPlayer: Play video: E:\_RideRunnerTestMedia\Video\Transporter.mpg
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  2. #12
    Confusion Master
    Auto Apps:loading...
    Enforcer's Avatar
    Join Date
    Sep 2003
    Location
    If you go down to the woods today, You're sure of
    Posts
    14,622
    Yep, all the above is correct.

    VIDEO then using player MPCHCVidRR and then play video followed by the correct path to the video.


    *edit, yeah maybe some extra debug code like for the audio listings.



    Don't suppose MPC has a debug setting, so we can see what it is doing?

  3. #13
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    sorry, i got tied up on something else...then hit the sack
    i put on ftp, new installer that adds 2 log items

    like
    6/30/2011 1:01:31 PM: Executing: VIDEO
    6/30/2011 1:01:31 PM: VidPlayer: Using Player MPCHCVidRR
    6/30/2011 1:01:31 PM: VidPlayer: Play video: E:\_RideRunnerTestMedia\Video\Transporter.mpg
    6/30/2011 1:01:31 PM: VideoPlayer: Movie.setPositionTo=8

    6/30/2011 1:01:31 PM: Que Exec: True, video_player.skin, "ONSCREENCHANGE", False
    6/30/2011 1:01:31 PM: Que Exec: True, video_player.skin, "ONSOURCECHANGE", False
    6/30/2011 1:01:31 PM: Leave Exec: False, video_player.skin, ONSOURCECHANGE, False
    6/30/2011 1:01:31 PM: Enter Exec: False, video_player.skin, , False
    6/30/2011 1:01:31 PM: Que Exec: True, video_player.skin, "ONSONGSTART", False
    6/30/2011 1:01:31 PM: Leave Exec: False, video_player.skin, ONSONGSTART, False
    6/30/2011 1:01:32 PM: VidPlayer: Video Seek Request: 8
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  4. #14
    Confusion Master
    Auto Apps:loading...
    Enforcer's Avatar
    Join Date
    Sep 2003
    Location
    If you go down to the woods today, You're sure of
    Posts
    14,622
    That's OK, I was just about to finish at work so wouldn't have been able to do anymore anyway.



    Will see if I can find a way of pulling it down at home, for some reason I can't get my firewall to allow me to do it (home firewall more restrictive than work one, go figure).

  5. #15
    Confusion Master
    Auto Apps:loading...
    Enforcer's Avatar
    Join Date
    Sep 2003
    Location
    If you go down to the woods today, You're sure of
    Posts
    14,622
    I think I have found the problem.

    For some reason if rewind is checked, it goes back to the beginning on next start.

    Thing is, even if I uncheck rewind, it keeps going back to checked. and in the ini it keeps going from 0 to 1. I have changed the reg setting for rewind to be 0 and the ini setting to be 0 but it still keeps going back to 1.

    I did have it work twice when in RR by going out of video and then back in, but then I exited RR and restarted abut then it was back to it's usual behaviour.

    So, what the hell is changing that rewind back to on?

  6. #16
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    its not the rewind, RR setsit to rewind when done option
    when you go back to video, rr tells mpchc the position to play...
    if it was that, id have the same issue too...(and so would everyone else)
    did you look at debug.txt since i added the extra code...
    are you trying non mpeg2 video too
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  7. #17
    Confusion Master
    Auto Apps:loading...
    Enforcer's Avatar
    Join Date
    Sep 2003
    Location
    If you go down to the woods today, You're sure of
    Posts
    14,622
    The two lines are in the debug and they look correct.

    I have tried mpg's a small avi from a camera my son did on holiday and a divx avi file.


    All start at the beginning. when the video screen loads it looks like it is going to continue for about half a second, then just restarts.


    This is happening on three PC's my desktop, my laptop and the one I have in the car.

    Using default carwings skin.
    RideRunner 1/7/2011
    XPPro SP3
    mpc-hc 3225 or greater


    Debug, resume, rr.ini, video.ini, mpc-hc.ini

    mpc-hc.zip




    *edit, can we please add a switch that let MPC manage it, ie the video command is just play and not play from whatever it was last.

    Just so I can test whether that would work.

  8. #18
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    its actually just a "play" and when it SAYS its playing a seek to position...
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  9. #19
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    there is nothing in debug.txt, the file is chopped

    so nothing usefull in that .zip
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  10. #20

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. RR 06-01-2011 Release - its already too HOT
    By mitchjs in forum Road Runner
    Replies: 93
    Last Post: 06-26-2011, 12:30 PM
  2. RR 04-01-2011 Release
    By mitchjs in forum Road Runner
    Replies: 36
    Last Post: 05-18-2011, 10:19 PM
  3. Replies: 15
    Last Post: 05-17-2011, 10:33 AM
  4. Replies: 21
    Last Post: 04-01-2011, 08:59 AM
  5. RR 02-01-2011 Release
    By mitchjs in forum Road Runner
    Replies: 24
    Last Post: 02-22-2011, 04:46 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •