Results 1 to 6 of 6

Thread: Problem with subtitles on MPHC

  1. #1
    Constant Bitrate
    Join Date
    Feb 2011
    Posts
    114

    Problem with subtitles on MPHC

    Hello i would ask if someone have problem with implementing this feature in ride runner, i've saw some old treaths about how to use hotkeys with SENDKEY for the commands that mphc has but aren't implemented inside ride runner (for example change track audio of the video, change sub, show/Hide sub and so on)
    Sadly i've read (and tested) that SENDKEY cannot be used with the standard setup of video player, need to load mpc as an external application.
    The problem is that i cannont lunch it as an external application because (i've tested modifing the structure of the video skin) when i go to select video it will not load
    So i was wondering if this problem was fixed during the time or left as it was, there are other ways?
    Thanks for have read

  2. #2
    Constant Bitrate
    Join Date
    Feb 2011
    Posts
    114
    noone had the same trouble?

  3. #3
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,259
    sendkey is only going to send to the "input active" window... i wouldnt use it ever...
    so.. there must be a better way right?

    + Skin Command; "SENDWMCOMMAND;windowname,lparam;wparam"
    windowname can use format of !classname!windowame


    now what is the windowname, i dont know
    what is the value lparam, i dont know
    what is the value of wparam, i dont know

    but once you do, do it!

    not hard to figure out...

    lparam is the command u want to send... look at mpchc!! (Options, keys... ID column)
    wparam is =0

    sendwmcommand;!MediaPlayerClassicW!;xxx;0

    should do it
    where xxx is the command
    like 952 (next audio)

    test in skin tool!!!

    sendwmcommand;!MediaPlayerClassicW!;952;0

    tested, and works when outside of rr, because...
    the player is parented to the rr screen... so... the window will not be able to found as of today...
    i will consider another way possibly looking for the current rr screen's children
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  4. #4
    Constant Bitrate
    Join Date
    Feb 2011
    Posts
    114
    thanks very much mitch, you're like the light in the dark lol never saw abou that command i just looked the history of april 2011 and read this "sendwmcommand", and i found that by googling
    I tested it with SkinTool the command line you give me "sendwmcommand;!MediaPlayerClassicW!;952;0" but it's not working i also tested a simplest command (play/pause 889) with this line "sendwmcommand;!MediaPlayerClassicW!;889;0"
    I tested also with winodw name as: Media Player Classic Home Cinema - v1.5.2.3456
    This is the code used in video_player.skin file for embed it: C,0,60,800,262 (the skin idle for 1 sec then show off if mouse don't change position)

    The version of ride runner i'm using is the last one from 03-02-12
    Can't figure out what's the problem of the command, maybe the window syntax is wrong?

    ps: This is the list of commands if someone need it http://www.autohotkey.net/~specter33...20Commands.txt

  5. #5
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,259
    like i said, it wont work, once a programs window is parented
    if you dont know what that means, its a WINDOWS OS thing...

    re-read my post...
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  6. #6
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,259
    actually i added some support for parented windows month or so ago...
    hmm

    i see.. ok, you have a PM
    Last edited by mitchjs; 03-29-2012 at 10:37 PM.
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

Similar Threads

  1. Subtitles ?
    By winnox in forum Centrafuse
    Replies: 7
    Last Post: 05-09-2007, 07:41 AM
  2. Use of movie subtitles in RR?
    By Tippa in forum Road Runner
    Replies: 3
    Last Post: 06-02-2006, 02:26 AM
  3. frodo and subtitles
    By BrianMay in forum FrodoPlayer
    Replies: 3
    Last Post: 12-04-2004, 07:52 AM
  4. DVD subtitles are not sharp
    By Maddog_rvo in forum FrodoPlayer
    Replies: 1
    Last Post: 08-17-2004, 04:43 PM
  5. DVD Subtitles?
    By sryan2k1 in forum Media Engine
    Replies: 1
    Last Post: 06-23-2004, 08:01 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •