Page 3 of 7 FirstFirst 1234567 LastLast
Results 21 to 30 of 69

Thread: Navigator 11 from Mapfactor

  1. #21
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,263
    Quote Originally Posted by bondango View Post
    Not working here (WIN7) (all paths correct), note :-

    1. When nav button clicked, i overserved in task manager pcnavigation.exe running for a second or two
    2. If already running PC NAV, it shows in RR nav though Partial screen

    so PCNAV is not being executed properly or being blocked from launching
    your really not suppling any real information to help us, help you

    if you want, attach rr.ini (removing reg info), attach debug.txt of 1 session

    also, pcnavigation.exe is NOT "PC_Navigator.exe" so i have no idea what that is
    Last edited by mitchjs; 08-07-2012 at 08:05 PM.
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  2. #22
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,263
    on another note i have made few improvements to RR to support PC Navigator

    1. proper closing of app
    2. rrconfig automation

    RR build 8/7 or >
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  3. #23
    Low Bitrate
    Join Date
    Apr 2012
    Location
    Radelaide South Aus
    Posts
    70
    Hi Mitch
    I cant get it to work under xp sp3
    I get the default windows "Navigator has encountered a problem" send/dont send report dialog
    the debug log has
    8/8/2012 11:39:30 AM: Shell: "C:\Program Files\Navigator11\PC_Navigator\PC_Navigator.exe" --atlas='C:\Documents and Settings\All Users\Application Data\Navigator\11.0\atlas_pcn_free.idc' --window_position=
    8/8/2012 11:39:30 AM: Que Exec: True, external_gps.skin, "ONSCREENCHANGE", False
    8/8/2012 11:39:30 AM: Leave Exec: False, external_gps.skin, ONSCREENCHANGE, False

    full debug.txt file attached

    rr.ini
    [Navigation]
    GPSMode=2
    GPSPath=C:\Program Files\Navigator11\PC_Navigator\PC_Navigator.exe|--atlas='C:\Documents and Settings\All Users\Application Data\Navigator\11.0\atlas_pcn_free.idc'
    GPSName=!BarneyMainWndCls!Navigator

    Ive compared the navigator shortcut (which works fine from the desktop) with the debug log entry and cant see any typo's
    cheers
    Wozza

    Ps
    Ive also attched the error log that XP wants to send home ...not that its much use
    Attached Files Attached Files
    Last edited by Wozza; 08-07-2012 at 10:31 PM.

  4. #24
    Raw Wave pierrotm777's Avatar
    Join Date
    May 2008
    Location
    Bordeaux, France
    Posts
    2,867
    If i can help, these are my settings:
    exectbl.ini:
    / ************************************************** ************
    / Pc Navigator 11
    / ************************************************** ************
    "PC_NAVIGATOR11","SETVAR;QUOTES;"||Load;external_g ps.skin;Pc Navigator;C:\Program Files\Navigator11\PC_Navigator\PC_Navigator.exe$QU OTES$ --atlas='D:\Documents and Settings\All Users\Application Data\Navigator\11.0\atlas_pcn_free.idc' --window_border=no --window_position=0,73,800,453;Navigator"

    / ************************************************** ************

    menu.lst:
    PC_NAVIGATOR 11 = "PC_NAVIGATOR11",PC NAVIGATOR11,Icons\PCNAVIGATOR.png,,Pc Navigator 11 is selected

    or just create a button with:
    PC_NAVIGATOR11

  5. #25
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,263
    Quote Originally Posted by Wozza View Post
    Hi Mitch
    I cant get it to work under xp sp3
    I get the default windows "Navigator has encountered a problem" send/dont send report dialog
    the debug log has
    8/8/2012 11:39:30 AM: Shell: "C:\Program Files\Navigator11\PC_Navigator\PC_Navigator.exe" --atlas='C:\Documents and Settings\All Users\Application Data\Navigator\11.0\atlas_pcn_free.idc' --window_position=
    8/8/2012 11:39:30 AM: Que Exec: True, external_gps.skin, "ONSCREENCHANGE", False
    8/8/2012 11:39:30 AM: Leave Exec: False, external_gps.skin, ONSCREENCHANGE, False

    full debug.txt file attached

    rr.ini
    [Navigation]
    GPSMode=2
    GPSPath=C:\Program Files\Navigator11\PC_Navigator\PC_Navigator.exe|--atlas='C:\Documents and Settings\All Users\Application Data\Navigator\11.0\atlas_pcn_free.idc'
    GPSName=!BarneyMainWndCls!Navigator

    Ive compared the navigator shortcut (which works fine from the desktop) with the debug log entry and cant see any typo's
    cheers
    Wozza

    Ps
    Ive also attched the error log that XP wants to send home ...not that its much use

    i dont see much, othet that window postion cut off in log... (if its cut off in real use, that could explain the program crashing)
    also... the window class is quite differnt then what i found...
    pc navigator works stand alone right?
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  6. #26
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,263
    wozza here is mine

    8/8/2012 9:44:32 AM: Executing: GPS
    8/8/2012 9:44:32 AM: Shell: "C:\Program Files (x86)\Navigator11\PC_Navigator\PC_Navigator.exe" --atlas='C:\ProgramData\Navigator\11.0\atlas_pcn_fre e.idc' --window_position=2,74,797,470
    8/8/2012 9:44:32 AM: Que Exec: True, external_gps.skin, "ONSCREENCHANGE", False


    notice real window positions

    so.. the "A"pplication definition on the sklin?

    you know the RULE, TEST WITH CARWINGS!
    your skin could be missing something in "external_gps.skin"
    Last edited by mitchjs; 08-08-2012 at 10:35 AM.
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  7. #27
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,263
    Quote Originally Posted by pierrotm777 View Post
    If i can help, these are my settings:
    exectbl.ini:
    / ************************************************** ************
    / Pc Navigator 11
    / ************************************************** ************
    "PC_NAVIGATOR11","SETVAR;QUOTES;"||Load;external_g ps.skin;Pc Navigator;C:\Program Files\Navigator11\PC_Navigator\PC_Navigator.exe$QU OTES$ --atlas='D:\Documents and Settings\All Users\Application Data\Navigator\11.0\atlas_pcn_free.idc' --window_border=no --window_position=0,73,800,453;Navigator"

    / ************************************************** ************



    menu.lst:
    PC_NAVIGATOR 11 = "PC_NAVIGATOR11",PC NAVIGATOR11,Icons\PCNAVIGATOR.png,,Pc Navigator 11 is selected

    or just create a button with:
    PC_NAVIGATOR11


    naw, too much junk in exectbl.ini
    im anti exectlb
    try out the new rr 8/7 btw.. and the new rrconfig, has pc navigator option
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  8. #28
    Low Bitrate
    Join Date
    Apr 2012
    Location
    Radelaide South Aus
    Posts
    70
    Hi Mitch
    Yeah it runs fine in the April ver and stand alone.I tried it with your window name and same thing... failed to run....Its got me stumped whats wrong as its the program itself thats failing, so it has to have something o do with how the command is being sent from RR.I havnt tried the carwings skin (its not even installed ) so I suppose that will be next.
    Also where do you enter the windows position? I didnt see it in you example above
    Thanks
    Wozza

  9. #29
    Low Bitrate
    Join Date
    Apr 2012
    Location
    Radelaide South Aus
    Posts
    70
    PS tried the default skin carwings and same error has to be a typo in there somewhere (but Ill be if I can see one)......or the window position

  10. #30
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,263
    the window position comes form the SKIN

    the "A" definition


    it just works...
    u should be using the newest RR
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

Page 3 of 7 FirstFirst 1234567 LastLast

Similar Threads

  1. Mapfactor PC Navigator in CentraFuse?
    By GreenBeauty in forum GPS
    Replies: 7
    Last Post: 11-09-2013, 04:32 PM
  2. Mapfactor Navigator 7 COM port Error
    By markieb in forum GPS
    Replies: 1
    Last Post: 12-12-2007, 05:41 AM
  3. Replies: 1
    Last Post: 10-19-2007, 10:55 PM
  4. MapFactor OCX
    By carmen2007 in forum GPS
    Replies: 0
    Last Post: 06-23-2007, 08:23 AM
  5. Mapfactor Navigator 6
    By Naesstrom in forum Road Runner
    Replies: 11
    Last Post: 03-02-2007, 08:50 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •