Results 1 to 8 of 8

Thread: 2 instances of RRConfig = RR broken!

  1. #1
    Constant Bitrate
    Join Date
    Dec 2007
    Location
    Boulder, CO
    Posts
    206

    2 instances of RRConfig = RR broken!

    I accidentally opened 2 instances of RRConfig and launched RR from one of them and RR broke. Now, when I launch RR I get the default, blue/lightning loader followed by:

    "C:\...Skins\ does not contain a valid skin! Check your settings and try again. Details in Debug.txt"

    The skin appears intact in my Skins folder (also tried reinstalling the skin) and RRConfig is still set up to use this skin and the config preview of the skin still works. I had this happen one other time and that time it deleted everything from my Skins folder and I had to reinstall RR. I'd prefer not to do this again/not to have this issue again! The only debug.txts I found (attached) on my system is are in plugin folders for RRFuelPrices (two locations - on in C:/Documents and Settings\...\Plugins\RRFuelPrices and one in C:\Program Files\...\Plugins\RRFuelPrices) and one in the RRUpd8 folder (C:\Docments and Settings\...\Plugins\RRUpd8). I tried removing these plugins but it didn't help. RR always gets to "Starting Skin Tool..." and fails with the above warning. Any ideas?

    Update: I relinked RRConfig to the skin folder and now RR launches with the proper loader for my skin but instead of RR opening I get a gray box that takes up roughly 1/6 of my screen and does nothing.
    Last edited by Enforcer; 11-15-2012 at 10:16 AM. Reason: Remove plugin debug.txt files - not relevant to problem

  2. #2
    Confusion Master
    Auto Apps:loading...
    Enforcer's Avatar
    Join Date
    Sep 2003
    Location
    If you go down to the woods today, You're sure of
    Posts
    14,622
    If it gets to starting skin tool and then no more it suggests the issue is with skintool loading.

    Try removing the skintool plugin folder.

  3. #3
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    Quote Originally Posted by booksix View Post
    I accidentally opened 2 instances of RRConfig and launched RR from one of them and RR broke. Now, when I launch RR I get the default, blue/lightning loader followed by:

    "C:\...Skins\ does not contain a valid skin! Check your settings and try again. Details in Debug.txt"

    The skin appears intact in my Skins folder (also tried reinstalling the skin) and RRConfig is still set up to use this skin and the config preview of the skin still works. I had this happen one other time and that time it deleted everything from my Skins folder and I had to reinstall RR. I'd prefer not to do this again/not to have this issue again! The only debug.txts I found (attached) on my system is are in plugin folders for RRFuelPrices (two locations - on in C:/Documents and Settings\...\Plugins\RRFuelPrices and one in C:\Program Files\...\Plugins\RRFuelPrices) and one in the RRUpd8 folder (C:\Docments and Settings\...\Plugins\RRUpd8). I tried removing these plugins but it didn't help. RR always gets to "Starting Skin Tool..." and fails with the above warning. Any ideas?

    Update: I relinked RRConfig to the skin folder and now RR launches with the proper loader for my skin but instead of RR opening I get a gray box that takes up roughly 1/6 of my screen and does nothing.

    i cant tell, you still have issue?

    run, RRCONFIG, set it to carwings dynamic... and make sure it still works...
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  4. #4
    Constant Bitrate
    Join Date
    Dec 2007
    Location
    Boulder, CO
    Posts
    206
    Couldn't do that as it wiped out all the other skins.

    Also, Enforcer, I don't think it was due to Skin Tool. I think it was actually whatever was coming after the plugins loaded because, if I took out skin tool, it would just hang on whatever plugin loaded last without skin tool in there. Anyway, I couldn't sleep last night and was going crazy so I did a fully uninstall/reinstall. Thanks for the help though. I'll post if it happens again but hopefully it does not!

  5. #5
    Constant Bitrate
    Join Date
    Dec 2007
    Location
    Boulder, CO
    Posts
    206
    Ok, it happened again. This time I closed RR using the close button on the main menu of the Reborn skin. I then spent a few minutes modifying some tags in winamp and relaunched RR from RRConfig and I get the "no valid skin" failure...

  6. #6
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    just take a look at rr.ini

    SkinPath=
    (and if using)
    NightSkin=

    you prob dont have a valid path!

    SkinPath=Carwings_Dynamic_Lite
    NightSkin=

    when NO ABSOLUTE path is used, RR will do its logical path

    in profile: my documents\riderunner\skins...


    rr.ini skinpath must be valid, runing rr config, delete resume.ini... keep that in mind
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  7. #7
    Constant Bitrate
    Join Date
    Dec 2007
    Location
    Boulder, CO
    Posts
    206
    wow. Good call, thanks!! In my mind, "use single skin" meant it wouldn't ever look for a night skin. All I did was uncheck this and everything is fine.

    The question now is, what is RR actually doing with "Use Single Skin" checked and how does that play into my Gamma / Dimmer settings (currently have "Use Built in Dimmer (GPS)" selected)?

  8. #8
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,255
    it does have anything to do with gamma/dimmer setting...
    the built in dimmer, will be used, its an overlay to the skin, its not perfect, keep in mind...
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

Similar Threads

  1. .dll / VB questions - hardware instances
    By Iamthehor in forum FB Software
    Replies: 12
    Last Post: 06-15-2009, 01:37 AM
  2. REQUEST: Run Multiple RR instances
    By Jarrod in forum Road Runner
    Replies: 33
    Last Post: 12-21-2008, 07:54 AM
  3. controling two instances of RR
    By tundra2000 in forum RR Skins
    Replies: 11
    Last Post: 09-07-2007, 02:47 PM
  4. Iguidance Double instances in RR
    By wariow in forum Road Runner
    Replies: 5
    Last Post: 09-09-2005, 09:43 AM
  5. Two Instances of FP and two sound cards
    By djXternal in forum FrodoPlayer
    Replies: 7
    Last Post: 04-13-2005, 11:58 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •