Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Winamp Volume Issues

  1. #1
    Newbie
    Join Date
    Oct 2012
    Posts
    31

    Winamp Volume Issues

    I'm having trouble with Volume control and Winamp. The problem is the volume +/- buttons do not work. Pressing them yields the 'click' wav sound, but no action seems to be performed.

    This is true with RR version 12/2012 and 01/2013, using CarWings Lite and using DFX 5.1.2 skins. I've checked the debug logs and they show the button press, but that's it.

    Winamp version is 5.63. All drivers, Flash, plugins, etc. are up to date. I also tried this on a fresh install of Windows XP SP2 and the 01/2013 RR code, before installing anything else - same problem.

    The volume % indicator also does not change. It is stuck at 50%. The volume level (sound) does not change either. If I go into the Windows sound controls, via the Taskbar/quick launch bar, they work fine. So, I know it's not a hardware or Windows issue (and I'm running Win XP SP2 btw).

    I don't know if this is an issue with RR core code, Carwings Lite, or Winamp. I would think it's most likely a communication issue between RR and Winamp, except I'd expect the volume % to change even if the volume didn't physically change, and those % indicators are not changing.

    I've searched the files on the PC for "Vol+" and "Vol-" and tried playing with lines in various INI files, but nothing makes a difference. I'd like to try and modify the commands sent to Winamp to see if that would work (since Winamp supports various keyboard combinations), but I cannot find anything that I can modify (e.g. INI files) that seems to affect the communication with Winamp, so right now I'm stuck.

    I've searched this forum quite a bit, but all the threads on Winamp and volume issues are 1) quite old; and 2) different problems than what I'm describing.

    I'm stumped.

  2. #2
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,247
    need to clarify, what volume

    why do you mention winamp?

    use carwings... the volume on the LOWER LEFT is MASTER VOLUME...
    now thats simple on modern os like WIN7/win8, but XP SP2?!?!?!? if anything SP3
    its all up to the DRIVERS of the SOUNDCARD
    and a key setting the master volume map setting
    hell if i can remember what it should be...

    try in RR.ini:
    MasterVolMap=0
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  3. #3
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,247
    also looking at debug.txt
    will tell you about your sound system
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  4. #4
    Newbie
    Join Date
    Oct 2012
    Posts
    31
    Quote Originally Posted by mitchjs View Post
    need to clarify, what volume

    why do you mention winamp?

    use carwings... the volume on the LOWER LEFT is MASTER VOLUME...
    now thats simple on modern os like WIN7/win8, but XP SP2?!?!?!? if anything SP3
    its all up to the DRIVERS of the SOUNDCARD
    and a key setting the master volume map setting
    hell if i can remember what it should be...

    try in RR.ini:
    MasterVolMap=0
    I tried in CarWings Lite and had the same result. Volume up/down buttons no-workee.

    Soundcard is built-in. It's a SoundMax something or other. This is an old PC (Pentium-M 2.1 Ghz). Drivers installed from mobo manufacturer.

    I used SP2 because SP3 forces a bunch of crap on the OS that I did not want.

    I believe the Master vol is already set via RR Config, isn't it? I can look into that tomorrow (i.e. directly in the RR.ini file) if necessary.

  5. #5
    Newbie
    Join Date
    Oct 2012
    Posts
    31
    Like what?

    And what should I look for exactly? There's a lot of data in there.

    David

  6. #6
    Newbie
    Join Date
    Oct 2012
    Posts
    31
    I was thinking if I could emulate a keyboard press in RR to send to winamp (since it allows kbd shortcuts for volume adjustment), I could use that route to send the vol up/down commands to Winamp. However, I'm not sure that would work, and I'm not sure how I could most easily test that in the RR interface.

    I may try using Windows Hot Keys and/or swapping out WinAmp with a slightly older version to see if either solves the problem.

    What is weird is that not only does the sound not change, but the % indicator in RR does not change either.

  7. #7
    Newbie
    Join Date
    Oct 2012
    Posts
    31
    Mitch,

    I got this resolved. Not sure if this is a behavior issue anyone else is seeing, but here's what I have determined:

    1. When I start RR, the Vol+ and Vol- buttons do not work. This is true in DFX5 AND CarWings Lite
    2. After I press the Mute button the first time, the Vol buttons start working. This is true in any menu and on either skin.
    3. If I close RR and restart it, I must go through the process of again of first pressing mute, then I'm fine.

    Other Notes:

    a. I have not tried with putting PC to sleep and resuming yet.
    b. The Play/Stop and forward/back buttons work fine immediately.
    c. Mute causes the Volume level to be reset to 50%. Is this WAD?

    Also, prior to discovering this pattern, I un-installed Winamp 5.63 and installed Winamp 5.5.72

  8. #8
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,247
    winamp has nothing to do with this
    your talking about master volume

    my thought is DRIVERS for the sound card

    confirm the RR.ini SETTING
    OPEN THE TEXT FILE UP, and look!
    (i mentioned the setting a few posts up)

    otherwise

    try another machine...

    XP w SP3

    and NEWEST drivers from MFG of sound card, DO NOT RELY ON 13 year old drivers from Microsoft XP
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  9. #9
    Newbie
    Join Date
    Oct 2012
    Posts
    31
    Quote Originally Posted by mitchjs View Post
    winamp has nothing to do with this

    your talking about master volume
    What does that mean? Sorry, but you'll have to explain that a bit in layman's terms. For instance, if not Master Volume, what is the alternative volume control?

    my thought is DRIVERS for the sound card
    SoundMax is the brand of software drivers. The card is on-board, part of a custom designed ruggedized PC built in 2004/2005. Old. I've tried using more recent drivers from SoundMax, but none of them worked. I have the driver CD from the manufacturer. It's the only set that works. I don't have any audio issues with any other software (for what that is worth to know).


    confirm the RR.ini SETTING
    OPEN THE TEXT FILE UP, and look!
    (i mentioned the setting a few posts up)
    Yes, I understand. I did so after my last post but did not have time to re-post. The file was already set in the RR.ini as you specified, so that's not it.


    otherwise

    try another machine...

    XP w SP3

    and NEWEST drivers from MFG of sound card, DO NOT RELY ON 13 year old drivers from Microsoft XP
    I seem to be stuck with the drivers that I have from SoundMax. They work fine for the other 1/2 dozen apps that I use for input/output of sound.

    I'll try a different OS version or device when I can.

    Are the Vol Up/Down commands sent directly to the sound card? Is that what the Master Volume setting is related to (i.e. where the commands are sent)? I figured the commands went to Winamp since it is playing the music/audio. Either way it seems like the Mute button "wakes up" whatever is receiving the VOL +/- commands. Also, FWIW I have also noticed coming out of Standby/Resume the buttons work properly. It's just the first time when RR is started that I have to first press the Mute button to get the Vol buttons to work.
    Last edited by RadarNutt; 01-04-2013 at 10:43 PM.

  10. #10
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,247
    no, they are sent to the windows mixer... rr just uses the windows mixer API
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

Page 1 of 2 12 LastLast

Similar Threads

  1. volume issues
    By warnockm in forum Road Runner
    Replies: 6
    Last Post: 08-09-2008, 11:04 PM
  2. Volume Issues for Winamp
    By rob_bozuk in forum Road Runner
    Replies: 19
    Last Post: 06-14-2007, 09:15 PM
  3. Volume issues
    By BLK MAJK in forum Road Runner
    Replies: 3
    Last Post: 07-17-2006, 11:33 PM
  4. Replies: 11
    Last Post: 02-11-2004, 10:59 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •