Results 1 to 4 of 4

Thread: How to make media keyboard to support video player on RR

  1. #1
    Newbie
    Join Date
    Dec 2008
    Posts
    24

    How to make media keyboard to support video player on RR

    I got a mini media keyboard (IR keyboard) and have it installed on my car PC. It can work with music player (Winamp) without any issue. But when I play videos on RR, the media keys don't work except the vollume buttons. I can control the video by touch screen on RR skin with no issue.

    Have tried built-in player, MPC and WMP. None work.

    Anyone know how can I setup the RR to make video player to support this media keyboard? (I'm using DFX4.0 skin).
    Name:  MiniKeyboard1.JPG
Views: 278
Size:  62.9 KB

  2. #2
    The Curator
    Auto Apps:loading...
    Blue ZX3's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area,IL
    Posts
    5,079
    Not sure but try adding:

    179,"PLAY"
    177,"PREV"
    176,"NEXT"
    178,"STOP"

    to the KeyTbl.ini file.

    Those being the keycodes for the media keys on a KB and I'd assume that is what that device is sending.
    RideRunner...The #1 FE, PERIOD.

    Current Project: DFXVoice [v1.0 Released]
    Next in line: RRMedia v2.0

    DFX 5.1.1 Skin
    Appstore Link

    My RideRunner Plugins
    RRMedia
    RRExtended
    DFXVoice

    "There are no bugs - only undocumented features."

  3. #3
    Newbie
    Join Date
    Dec 2008
    Posts
    24
    Quote Originally Posted by Blue ZX3 View Post
    Not sure but try adding:

    179,"PLAY"
    177,"PREV"
    176,"NEXT"
    178,"STOP"

    to the KeyTbl.ini file.

    Those being the keycodes for the media keys on a KB and I'd assume that is what that device is sending.
    I will try this on my car PC tomorrow. Thanks a lot

  4. #4
    Newbie
    Join Date
    Dec 2008
    Posts
    24
    Quote Originally Posted by Blue ZX3 View Post
    Not sure but try adding:

    179,"PLAY"
    177,"PREV"
    176,"NEXT"
    178,"STOP"

    to the KeyTbl.ini file.

    Those being the keycodes for the media keys on a KB and I'd assume that is what that device is sending.
    I have tried adding above to the KeyTbl.ini file, the video can response my media keys but the "Prev" and "Next" keys worked as "FRev" and "FFwd". After I changed the command as below, the media keys working normally. Thank Blue for your support.
    179,"PLAY"
    177,"RRPREV"
    176,"RRNEXT"
    178,"STOP"

Similar Threads

  1. Audio but no video playback using Media Player Classic
    By aerotight31 in forum Road Runner
    Replies: 12
    Last Post: 09-25-2009, 07:39 AM
  2. RR/Media Player Classic hanging when playing video
    By RS200Z in forum RR Bug Tracker
    Replies: 3
    Last Post: 05-17-2008, 11:04 AM
  3. Video in Windows Media Player only shows up on one screen
    By RedGTiVR6 in forum General Hardware Discussion
    Replies: 4
    Last Post: 02-14-2008, 05:44 PM
  4. Video & Media Player Classic problem
    By RS200Z in forum Road Runner
    Replies: 2
    Last Post: 07-25-2007, 07:49 PM
  5. Media Car video player
    By MatrixPC in forum MediaCar
    Replies: 2
    Last Post: 03-22-2004, 12:33 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •