Results 1 to 5 of 5

Thread: RR ignores soundcard setting, always uses default soundcard

  1. #1
    Newbie
    Join Date
    Oct 2010
    Posts
    29

    RR ignores soundcard setting, always uses default soundcard

    Hi

    I have two soundcards, one on the motherboard, the other an external USB. I can set either one as the Windows default soundcard, and Windows apps such as Media Player, Windows Media Center, and RideRunner will use it, therefore it is clear both soundcards are working.

    But when I change the RR "soundcard" parameter to 1,2,3,or 4 using RRconfig or by editing the rr.ini file (and restarting RR) to try and make RR use a different soundcard, the sound always comes out whichever one is set as the default in Windows. It appears RR is ignoring the "soundcard" parameter. How does one determine the correct "number" of the installed soundcards or are they always assigned sequential from 0 up?

    Any idea how to troubleshoot or fix this?

    Thanks in advance

    Tim

  2. #2

  3. #3
    Newbie
    Join Date
    Oct 2010
    Posts
    29
    That doesn't solve the problem -- There's navigation audio plus the clicks as you move through menus. My setup is two screens in an RV - a MoCoSo Mini-Touch in the front for music and navigation using the motherboard sound card, and a 28" flat screen in the back using an external USB soundcard for the kids to watch movies on using Windows Media Center. WMC will only use the Default sound card. That's why I want RR to use the other soundcard for music and navigation. That's why I have to get the soundcard parameter working in RR

  4. #4
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,261
    that setting has NO baring on winamp.... (for any music for that matter)
    its only for mixer controls in RR
    which soundcard rr will use for mixer
    (volume controls)
    doesn't really apply anymore... was only used on XP (if it even worked)
    since the audio subsystem is quite modern now(win vista and >), it doesn't apply...

    I don't think RR can do what you want it to do...

    good luck
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  5. #5
    Newbie
    Join Date
    Oct 2010
    Posts
    29
    OK, basically I think you're saying that each app within RR decides where to send its audio. With WinAmp, I was able to change it to an alternate soundcard, but most other apps do not have a setting like that. RR's native sounds such as Text-to-speech and clicks while moving through menus output to the default soundcard. Same with Garmin MobilePC which I am using for navigation.

    Any suggestions on alternatives - some magic utility to redirect audio to different soundcards, two instances of RR (does not sound like that would help), or a different front-end? Is there a front-end that is still being actively developed that might be a better choice?

    EDIT: In the end I set the soundcard that I wanted RR to use as the Windows default soundcard - this is connected to the car stereo. Then I dumped WMC for XMBC which lets me choose the 2nd soundcard which is connected to speakers in the back. Now I have music and navigation up front, and movies in the back for the kids, via XBMC and a Windows remote control.
    Last edited by timbo66; 12-08-2013 at 11:00 PM.

Similar Threads

  1. Replies: 7
    Last Post: 01-27-2012, 02:42 PM
  2. Setting SPDIF out to be default on AC'97?
    By RedGTiVR6 in forum General Hardware Discussion
    Replies: 5
    Last Post: 05-18-2008, 04:23 PM
  3. Setting gains with amp and outboard soundcard
    By Quack in forum Car Audio
    Replies: 4
    Last Post: 06-10-2006, 06:03 PM
  4. how to change the default setting for winamp?
    By RedGTiVR6 in forum General MP3Car Discussion
    Replies: 7
    Last Post: 03-10-2005, 07:41 AM
  5. Setting windows default volume
    By surfer6262 in forum Software & Software Development
    Replies: 0
    Last Post: 08-16-2002, 03:10 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •