Page 18 of 19 FirstFirst ... 8910111213141516171819 LastLast
Results 171 to 180 of 188

Thread: Like Media Car -- Wish you had the source ? Check this out...

  1. #171
    Variable Bitrate
    Join Date
    Nov 2004
    Posts
    232
    Guino,
    I have sent you a PM of a Link to download an Installation that I have made for your program. Let me know how you like it and what you want me to Add/Change. I have it working great, so this will make it much easier for users to Install the program, just let me know what you want me to do to it.

    It currently installs One skin, the silver brushed metal one. It installs the Mediplayer classic to the correct location, the .ini files are tweaked to where the installation directory is. It also installs the Fonts into the correct directory for the Skin that is installed.

    At the end of the Installation it opens the Readme.txt file and the remedia.ini files, so they can be Read/Edited.

    Let me know what you think, and if you think this would help users. I think that it would help greatly.

    Thanks,
    Bryan
    2000 Yukon Denali
    Shuttle SN65G2
    Cel-D 2.4 GHZ 533mhz FSB
    1GB PC800 Mem
    Radeon9200 PRO
    Seagate 120GB
    ATI Remote
    RF Mini Kb w/Trk Ball
    7" Lilliput Touch Screen Monitor
    USB 2.0 Hub
    Rikaline GPS-6010
    PN11 802.11b Wireless
    XP Pro
    750W Inverter

  2. #172
    My Village Called 0l33l's Avatar
    Join Date
    Jul 2004
    Location
    Berkeley, CA
    Posts
    10,516
    Thanks, but Frodo already showed me how to use the sendmessages that were implemented
    Quote Originally Posted by guino
    Sure, I'll change it and also, I'm planning to add a variation of the Sendmessage parameters that should actually be simpler to use...

    EDIT: Man, VB is not takina a liking to WM_USER+XXX message numbers.. it just receives the message, but wParam and lParam are completely changed from what I send.. anyway, I know you can use the current WM_COPYDATA message (it's a standard message), I even found some code for you:

    // Sender: Send data

    procedure TForm1.Button1Click(Sender: TObject);
    var
    aCopyData: TCopyDataStruct;
    hTargetWnd: HWND;
    begin
    with aCopyData do
    begin
    dwData := 0;
    cbData := StrLen(PChar(Edit1.Text)) + 1;
    lpData := PChar(Edit1.Text)
    end;
    // Search window by the window title
    hTargetWnd := FindWindowEx(0, 0, nil, PChar('RoadRunner'));
    if hTargetWnd <> 0 then
    SendMessage(hTargetWnd, WM_COPYDATA, Longint(Handle), Longint(@aCopyData))
    else
    ShowMessage('No Recipient found!');
    end;

    // Recipient - Receive data

    type
    TForm1 = class(TForm)
    private
    { Private declarations }
    procedure WMCopyData(var Msg: TWMCopyData); message WM_COPYDATA;
    public
    { Public declarations }
    end;

    procedure TForm1.WMCopyData(var Msg: TWMCopyData);
    var
    sText: array[0..99] of Char;
    begin
    // generate text from parameter
    StrLCopy(sText, Msg.CopyDataStruct.lpData, Msg.CopyDataStruct.cbData);
    // write received text
    label1.Caption := sText;
    end;

  3. #173
    Maximum Bitrate more mods's Avatar
    Join Date
    May 2003
    Location
    Atlanta, Ga.
    Posts
    873
    Video works now, but.............I'll save that for later. I dont want to give bad news so soon.
    It's the cake having/eating thing.

  4. #174
    Maximum Bitrate more mods's Avatar
    Join Date
    May 2003
    Location
    Atlanta, Ga.
    Posts
    873
    No fear, I tried to reproduce it and couldn't. Here's what happened, I was trying to bring up the video controls and accidentally pulled the video up and to the left (about a third was off screen). I expected it to just snap back, but it just stayed there (still playing). I tried again to bring up the controls but couldn't, so then I hit ctrl+alt+del thinking I would end task, but Road Runner kept the focus on it. It was really kinda funny, it reminded me of that funny Mac movie. The one where he says trying to avoid the doc menu is like boxing with your computer. This all happened when I turned off video auto hide. It's back on now!

    BTW why is the video dragable anyway?
    It's the cake having/eating thing.

  5. #175
    FLAC mauri's Avatar
    Join Date
    Jan 2004
    Posts
    1,041
    Quote Originally Posted by more mods
    Video works now, but.............I'll save that for later. I dont want to give bad news so soon.
    Post the correct string to use for slider in the skin the scroll bar of the time played now add in RR and the string for blinking the mute led?
    I wont edit and use this in my skin.

    Tanks

    Mauri

  6. #176
    Maximum Bitrate more mods's Avatar
    Join Date
    May 2003
    Location
    Atlanta, Ga.
    Posts
    873
    Quote Originally Posted by mauri
    Post the correct string to use for slider in the skin the scroll bar of the time played now add in RR and the string for blinking the mute led?
    I wont edit and use this in my skin.

    Tanks

    Mauri
    Here ya go. That's just the .skin file.
    http://www.carpcs.net/moremods/files/audio player.skin.zip

    Here are the icons if you want them. Just unzip them in the alpine skin folder.
    http://www.carpcs.net/moremods/files/blue icons.zip
    It's the cake having/eating thing.

  7. #177
    Maximum Bitrate more mods's Avatar
    Join Date
    May 2003
    Location
    Atlanta, Ga.
    Posts
    873
    A few other things I've noticed:

    Time Format: I have never been in the military so its kinda weird for me. I like AM/PM.

    Browsing: My music is arranged by artist\album\ and I have around 270 artist. If I scroll down to say the r's, and then browse a artist then back out, the browser sends me all the way back the a's. Is there a way to have it back out to the point where I entered the artist folder (r's)?

    More Browsing: Most of my artist folders have a .jpg of the band (not album art) that is displayed when the artist is hightlighted. Then each album has a .jpg of the album art, but when I click on the artist it shows the .jpg of the band and opening any of the album folders does not chage the image to the album art (it stays on the .jpg in the artist folder).

    I'll keep looking if you don't kill me.
    It's the cake having/eating thing.

  8. #178
    FLAC mauri's Avatar
    Join Date
    Jan 2004
    Posts
    1,041
    Quote Originally Posted by more mods
    Here ya go. That's just the .skin file.
    http://www.carpcs.net/moremods/files/audio player.skin.zip

    Here are the icons if you want them. Just unzip them in the alpine skin folder.
    http://www.carpcs.net/moremods/files/blue icons.zip
    All OK, i have "skinning "my skin whit new scroll and mute indicator blink,its ok!
    Thanks.

    Mauri

  9. #179
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Quote Originally Posted by more mods
    A few other things I've noticed:

    Time Format: I have never been in the military so its kinda weird for me. I like AM/PM.

    Browsing: My music is arranged by artist\album\ and I have around 270 artist. If I scroll down to say the r's, and then browse a artist then back out, the browser sends me all the way back the a's. Is there a way to have it back out to the point where I entered the artist folder (r's)?

    More Browsing: Most of my artist folders have a .jpg of the band (not album art) that is displayed when the artist is hightlighted. Then each album has a .jpg of the album art, but when I click on the artist it shows the .jpg of the band and opening any of the album folders does not chage the image to the album art (it stays on the .jpg in the artist folder).

    I'll keep looking if you don't kill me.
    OK, I'll add 2 settings for "Region" TimeFormat and DateFormat, so you will have flexible ways to view the time according to your settings (this is very easy to do and it's about time to stop this little things from bugging people)

    Go back to current browse folder is actually something I had not really thought about (probably because I have a touch-wheel and like scrolling haha), but I can't see why it would ever be better to always go to the top (you can always browse down with a "back" button code)

    Yeah, I can understand that album art deal... I planned to do it your way in the beginning, but didn't find time to test it your way -- I just wanted sub folders without album art to show the same album art as before, but I can make it change when another album art exists. Complicated will be when you list files lets say on the current folder (with album art) after listing subfolders with other album art files.

  10. #180
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Quote Originally Posted by more mods
    BTW why is the video dragable anyway?
    Well, MPC is a completely separate application that has NO SUPPORT WHATSOEVER for interfacing with other applications (like RR). All the interfacing you see is really a fancy set of smoke and mirrors to look that way. What I mean by this is: I can't possibly control the code within MPC to disable features like move the window around. What I do instead is try to reset the video position everytime RR detects that it has moved or resized away from what it was supposed to be.

    Regarding video autohide, when OFF, you should click the video to hide controls. The detection/alignment of MPC should be the same.

Similar Threads

  1. Media car radio question?
    By shak in forum General Hardware Discussion
    Replies: 1
    Last Post: 10-25-2004, 12:13 AM
  2. Media Car help
    By CJ8501 in forum Newbie
    Replies: 3
    Last Post: 09-12-2004, 05:52 PM
  3. Media Car not responding... Lilliput problem?
    By carpcnoobie in forum MediaCar
    Replies: 3
    Last Post: 09-01-2004, 01:38 PM
  4. searching for songs on media car
    By yunusyu in forum MediaCar
    Replies: 4
    Last Post: 06-17-2004, 03:58 AM
  5. launching media car
    By streetknight in forum MediaCar
    Replies: 2
    Last Post: 01-17-2004, 05:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •