Page 9 of 16 FirstFirst 12345678910111213141516 LastLast
Results 81 to 90 of 156

Thread: RR Doesn't Resume Music after Hibernate

  1. #81
    Maximum Bitrate
    Join Date
    Jun 2003
    Location
    Atlanta/Augusta, GA
    Posts
    505

    Possible Solution

    Possible Solution

    I went to watch Bourn Ultimatum with some buddies and was too wired to fall asleep when I got home, so I took a stab at the hibernate issue in RR. I think I found a solution but need a few of you to test to confirm.

    I slightly modified the code to completely ignore Window's hibernate and resume from hibernate events. Now, the music and skin resume automatically without pressing any buttons or moving the mouse.

    I've attached the file for you guys to beta test. In your RR folder, rename your existing RoadRunner.exe to RoadRunner.exe.bak and copy the new one from the zip file.

    Note, I did not have the libraries for MapPoint or Speech and couldn't locate them online for download, so these features have been disabled in my build. If someone has the mappoint ocx file and speech dll handy, I can rebuild a complete version if you send them my way.
    Attached Files Attached Files

  2. #82
    Low Bitrate happpyg's Avatar
    Join Date
    Feb 2005
    Location
    Bunbury, Western Australia
    Posts
    66
    Woohooo!!! That fixed it on my test machine. I'll try in the car and let you know how it goes.

    Thanks!!!!!!!!!!!!
    Semperon 3200+/512MB/ Seagate SATA2 120GB
    10.2" Xenarc/ Netgear USB Wireless
    M2-ATX/RadioShark
    BU-353 GPS Receiver

    http://www.happyg.mine.nu/carpc/index.html

  3. #83
    Low Bitrate happpyg's Avatar
    Join Date
    Feb 2005
    Location
    Bunbury, Western Australia
    Posts
    66
    Yep, thanks tejesh, not sure what you did but that fixed in the car too, sooo nice not to have to touch the screen every time, thanks heaps!!! And thanks to guino too for his help answering my PM's to try to find a solution!

    Cheers!
    Semperon 3200+/512MB/ Seagate SATA2 120GB
    10.2" Xenarc/ Netgear USB Wireless
    M2-ATX/RadioShark
    BU-353 GPS Receiver

    http://www.happyg.mine.nu/carpc/index.html

  4. #84
    Raw Wave treetop777's Avatar
    Join Date
    Sep 2006
    Location
    War-Town, GA.
    Posts
    2,233
    EXCELLENT! Thanks.

  5. #85
    FLAC djmickyg's Avatar
    Join Date
    Feb 2004
    Posts
    1,314
    very nice! i will be trying this out now!

  6. #86
    Newbie R33vit's Avatar
    Join Date
    Mar 2005
    Location
    Sydney Australia
    Posts
    41
    I found if I hibernate from a skin (ie: select hibernate from exit skin) I dont have a problem when it resumes.

    If I hibernate by pushing the power button on the PC (Set in windows to nibernate when I press the power button) it will return to RR with no sound.

    Also the onresume cmd in the ExecTBL.ini does not execute until you move the mouse.

    hope that helps you Guino

  7. #87
    FLAC djmickyg's Avatar
    Join Date
    Feb 2004
    Posts
    1,314
    also i find the auto skin and gamma chnage didnt work till i moved something..

    tejesh83: i tried out your version with hibernateaware=true on, and the music resumed.
    but my "onresume","restart_phoco" command didnt work when i resumes the pc?

  8. #88
    Maximum Bitrate
    Join Date
    Jun 2003
    Location
    Atlanta/Augusta, GA
    Posts
    505
    Quote Originally Posted by djmickyg View Post
    i tried out your version with hibernateaware=true on, and the music resumed.
    but my "onresume","restart_phoco" command didnt work when i resumes the pc?
    Sorry, the version I posted copletely strips out the hibernate features of RR, the "onresume" event included. Even with hibernateaware=false, RR was still doing some processing with the hibernate and resume from hibernate events. I took this all out of the version I posted.

    Let me see if there is another way to get that event to fire. I got an idea, but I'm new to VB so it may take awhile to figure out. Basically, I want to use a timer that fires every seconds. If more that a second passes since my last check, I'll assume the computer was hibernating and call the neccessary resume code in RR.

  9. #89
    Maximum Bitrate
    Join Date
    Jun 2003
    Location
    Atlanta/Augusta, GA
    Posts
    505

    New Solution

    New Solution

    I implemented the algorithm mentioned above. I tested it out on my dev system and my carpc, and it appears to be working. I need you guys to verify as well though.

    djmickyg, the "onresume" for phoco should work too with this release. Also, this build now includes the MS Mappoint and Speech features.

    FYI - In my car, just today I replaced my audigy 2 ns notebook with a new creative xmod usb sound card (sounds awesome by the way), so with hibernate=true, when I tried this new build, winamp would bich when my carpc resumes from hibernate that the soundcard is not ready. Guino has already taken care of this. Just add usbsound=true to your RR.ini. This will make RR wait a few seconds before asking winamp to resume audio.

    Shameless plug - If you like my work, check out my SmartPlaylists plug-in for RR as well. See my signature below for a link.
    Attached Files Attached Files

  10. #90
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    can you make the changes you made available (sources) so I can put it in the main sources ??

    Thanks for looking at it!
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

Similar Threads

  1. Replies: 22
    Last Post: 08-06-2006, 03:57 PM
  2. no sound on resume from hibernate FIX temporarly
    By xdjxklusivex in forum FrodoPlayer
    Replies: 5
    Last Post: 12-18-2005, 12:23 PM
  3. status update....
    By 0l33l in forum PowerVoice
    Replies: 17
    Last Post: 05-05-2005, 12:22 PM
  4. Audio crash after hibernate (USB alerts)
    By Peoples in forum RR Bug Tracker
    Replies: 11
    Last Post: 03-10-2005, 01:29 PM
  5. No auto resume music and video?
    By organasised in forum Road Runner
    Replies: 3
    Last Post: 02-10-2005, 09:55 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •