Results 1 to 5 of 5

Thread: Problem with remembering playlist

  1. #1
    Newbie
    Join Date
    Feb 2005
    Location
    Rijssen, The Netherlands
    Posts
    7

    Problem with remembering playlist

    Hi,

    I have a problem with roadrunner not remembering my playlist.

    I use winamp 5.x and the latest RR (3-7-05)
    I run an nlited xp pro, with minlogon.
    I have my shell set to "minlogon shutdown.exe" (set to rr.exe before, but it gave problems when shutting down. windows tried to restart rr (becouse it was the shell) at shutdown, whitch gave an error)
    Now i run rr.exe as an service.

    When i use my power-button, windows wants to hibernate, but "minlogon shutdown" will power down the system. Next time the computer is turned on, the playlist is empty. When i use the shutdown option from the rr menu, it does remember the playlist.

    I have tried all sort of things but nothing works.

    My car-pc is nearly finished, exept for this, and im out of ideas.

    Anyone got suggestions?

  2. #2
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    are you using EWF/HORM ?? It is ery unusual for the playlist to be empty since it is saved to disk as soon as you load it into the audio player screen... since it's a hibernation, both Winamp and RR should keep the last state of the playlist and require no additional processing.. Now, if you're using EWF/HORM you do need to make RR "load" the playlist again from disk...

    Try this:

    1-Go into audio browser and Clear the playlist
    2-Add a 5 songs to it (that you can easily identify)
    3-Go back to the audio player/start playback
    4-hit the power button
    5-resume from hibernation (Playlist will show "empty" -- according to you)
    6-Go back to the audio browser, highlight 1 song file and click +1 (ADD 1)
    7-Return to the audio player and see if that file is the only one in the playlist or if the 5 songs you had (before hibernation) are there as well...

    This will basically tell me if the problem is with Winamp or RR...
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #3
    Newbie
    Join Date
    Feb 2005
    Location
    Rijssen, The Netherlands
    Posts
    7
    hey guino,

    Thanx for your fast reply!

    Currently my carpc is at my work so i cant try anything today.
    As for the EWF/HORM, i dont exactly know what it is, but if it has anything to do with my os running on a memory-card, i dont use it. Im running everything from an hd.

    Allso i dont use hibernate. minlogon cant powerdown, it only can hibernate when the powerbutton is pressed, so i use a workarond someone here on the forum made, its a program called "minlogon shutdown". It catches the hibernate "message" and cancels it before any other process receives it (it has an higher priority). It then sends a powerdown message to the system.

    I will try your steps as soon as i can and post the result.

  4. #4
    Constant Bitrate
    Join Date
    Feb 2004
    Posts
    221
    i had this problem before...winamp had all the songs in the playlist, but RR wouldn´t display them...

  5. #5
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,818
    I've only seem that happen when Winamp Lite is used.. even so, it still works some of the time... but in this case, it is hard to tell what's wrong when using a nlite XP install.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

Similar Threads

  1. YAOP (yet another Opus problem)
    By Frankino in forum Power Supplies
    Replies: 14
    Last Post: 06-19-2005, 11:17 AM
  2. Replies: 3
    Last Post: 04-19-2005, 10:29 AM
  3. playlist necessary? (philosophical)
    By crippy in forum Software & Software Development
    Replies: 22
    Last Post: 10-16-2003, 02:39 PM
  4. Slow playlist load at winamp startup
    By xa0s in forum Software & Software Development
    Replies: 6
    Last Post: 08-18-2000, 10:16 AM
  5. Win98 problem
    By JustAGuy in forum Software & Software Development
    Replies: 3
    Last Post: 05-07-2000, 11:18 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •