Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: phoCo remote control w RR??

  1. #1
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842

    phoCo remote control w RR?? (FIX FOUND)

    Testing out RR for a few hours now, im not sure if this is a bug with RR or PhoCo or just not supported, but i cant get the remote control feature to work when i use PhoCo embeded in RR. If i run PhoCo standalone my remote keymaps work fine.
    All other features of PhoCo work fine.
    I searched too but didnt see anyone with this issue, i dont think many people even use this feature of PhoCo.

    thanks

  2. #2
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    I believe Mr. Fabio uses that feature.. You have to set the keys you want to use in ExecTBL.INI to execute the commands you wish RR to perform.. You can find out the keycodes by running the keycode tool in RR's folder and pressing the buttons in your phone to simulate the keypresses... that is, if that's what you're trying to do..
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #3
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    im not sure if i understand fully, or even if you understand me.
    But, when i run phoCo standalone i have the ability to move the mouse from my phone and also send keyboard shortcuts.
    http://zhorvat.dyndns.org/PCForums/S...spx?ForumID=39
    this link is the feature of PhoCo im talking about.

    Is something special needed when phoco is running in embeded mode?

  4. #4
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    You can try running phoco first, then RR to see if that works.. it might be the -remote/NoDesign parameter RR uses to load Phoco that is disabling something (wasn't supposed to)..
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  5. #5
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    Quote Originally Posted by guino
    You can try running phoco first, then RR to see if that works.. it might be the -remote/NoDesign parameter RR uses to load Phoco that is disabling something (wasn't supposed to)..
    that works, but im left with the PhoCo minimize icon covering up RR, it dosent seem to want to leave even when you set phoco to startup=hidden.
    This may also bring up other issues as there is no way to control which app is started first when windows boots. Is there a way to force phoco to startup minimized to the tray or taskbar?

  6. #6
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    That you should ask in the Phoco forum.. I have no idea... Also you may want to ask about the issue of the "remote control" feature not working when phoco is started in remote mode...
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  7. #7
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842

    Fix Found

    been doing a little more testing trying to work this issue out.
    Im posting back here because i think this is actually a RR issue.
    When i create a shortcut to phoco and in the target box put "C:\Program Files\PhoneControl.NET\PhoneCtl.NET.exe" -remote
    phoco starts up in remote mode and "remote control" works just as if normal mode.

    Does RR start PhoCo differently than this? In RRconfig under Phone there is an option to check "Use -remoteNoDesign" but checking and unchecking this box dosent do anything RR still loads PhoCo hidden

    I think i know what the problem is now,
    compareing the log file for phoco running normaly, running in remote mode activated by me using a shortcut and running remote mode activated by RR
    It seems that when RR loads phoco, i get the error "KeyMaps\Mouse.KeyMap.xml not found content is misspelled!!"
    but this error only happens when RR launches PhoCo?

    ***********
    PROBLEM FIXED

    by copying the keymap folder from inside the PhoCo install dir and into the RR install Dir everything works! I guess when RR is launching PhoCo, somehow PhoneCo is looking for files inside of the RR dir instead of its own dir, should this happen?

  8. #8
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    I probably need to launch Phoco from it's own path.. either that or you can specify the FULL path for the keymap files (if that's even possible)..
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  9. #9
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    Quote Originally Posted by guino
    I probably need to launch Phoco from it's own path.. either that or you can specify the FULL path for the keymap files (if that's even possible)..
    i just copied the keymap folder into the root dir of RR and that works fine.
    but launching it from its own path may help fix other issues people were or are having (not sure)

  10. #10
    Variable Bitrate Mr.Fabio's Avatar
    Join Date
    Feb 2005
    Location
    Italy
    Posts
    261
    I'm also using this feature. Try this instead of copy the folder to the RR path :

    In PhoneCtlConfig.xml (Phoco path) specify the full path of the keymap folder like me :
    <UseKeyMap locked="False">c:\Programmi\PhoneControl\KeyMaps\R R.KeyMap.xml</UseKeyMap>

    This should solve your problem without copy PhoCo folders to RR.
    Fabio

    _______________________
    Travla C134
    Jetway J7F2WE 1Gb DDR2 - HD SATA 3.5" 80Gb + HD 2.5" 40Gb - Lilliput 7" TS - Holux GR-213 - Bluetooth - Belkin 802.11g WiFi - Silabs Radio - HTC Leo

    RoadRunner - PC Navigator 7.1 - FreeFone

Page 1 of 2 12 LastLast

Similar Threads

  1. WANTED: Phoco BETA testers for RR...
    By guino in forum Road Runner
    Replies: 200
    Last Post: 12-05-2005, 11:05 AM
  2. status update....
    By 0l33l in forum PowerVoice
    Replies: 17
    Last Post: 05-05-2005, 01:22 PM
  3. RR & PhoCo launch
    By BMVEE in forum Road Runner
    Replies: 2
    Last Post: 04-25-2005, 12:06 AM
  4. RR 04-19-05.. Improved Phoco..
    By guino in forum Road Runner
    Replies: 19
    Last Post: 04-20-2005, 11:38 PM
  5. recommend a remote control for carputer
    By fallnangel in forum Input Devices
    Replies: 3
    Last Post: 01-16-2005, 09:51 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •