Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Starting Phone Control takes a long time

  1. #1
    Newbie
    Join Date
    Jul 2005
    Posts
    18

    Starting Phone Control takes a long time

    Hi,
    When I start RR and it says it is starting Phone Control my CPU goes 100% and it takes ~ 40 seconds for RR to start. Is this normal when using Phone Control?

    Rgds and thanks

    Ant

  2. #2
    Constant Bitrate
    Join Date
    Dec 2003
    Location
    Germany
    Posts
    207
    Depends on your setup and if PhoCo can find your phone. AFAIK RR waits until PhoCo is fully loaded before it continues loading ==> look into your PhoCo settings
    Lilliput 7" TS TFT, ASRock K7VM2, Duron 1,3 GHz, 512 MB DDR RAM, 30 GB Seagate HDD @ 5.400 rpm, WLAN w/ 500mW booster, Toshiba Slimline DVD-ROM Drive, D-Link USB Radio

    Download the German Voicepack 1.0 for FreeDrive now!

  3. #3
    Newbie
    Join Date
    Jul 2005
    Posts
    18
    Hi,
    Sorry I should have mentioned in my original post that if I start Phone Control standalone then it takes ~ 8 seconds to start and be fully functional. It only consumes the CPU and takes ~ 40 seconds during the RR start up process.

    Thanks

    Ant

  4. #4
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    I think you should do some more testing.. it is UNFAIR to compare the FIRST loading time of Phoco (probably done by RR) with the NEXT loading times of phoco (either inside or outside RR)... I can guarantee you that phoco will load a whole lot faster on the 2nd, 3rd etc times.. the only reason why it takes so long to start at first is because all the .NET crap has to load up ..
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  5. #5
    Newbie
    Join Date
    Jul 2005
    Posts
    18
    Quote Originally Posted by guino
    I think you should do some more testing.. it is UNFAIR to compare the FIRST loading time of Phoco (probably done by RR) with the NEXT loading times of phoco (either inside or outside RR)... I can guarantee you that phoco will load a whole lot faster on the 2nd, 3rd etc times.. the only reason why it takes so long to start at first is because all the .NET crap has to load up ..
    Hi Guino,
    I tested this with a cold boot between each tests so as to make it as fair as possible, the results are:-

    Cold Boot -> Start Phone Control -> ~14 seconds
    Cold Boot -> Start Road Runner -> RR says Starting PC for ~40 seconds

    I watch the processes and rr.exe is consuming > 90% CPU and PhoneCTL.NET.exe uses only a few % for 2-3 seconds and nothing for the remainder of the period.

    I assume using the trial version of phone control wouldnt affect this?

    Many thanks

    Ant

  6. #6
    Confusion Master
    Auto Apps:loading...
    Enforcer's Avatar
    Join Date
    Sep 2003
    Location
    If you go down to the woods today, You're sure of
    Posts
    14,630
    Quote Originally Posted by db2boy
    I assume using the trial version of phone control wouldnt affect this?

    Many thanks

    Ant

    Using the trial version affects it big time, because the splash screen requires user input.

    If you search the phoco threads in the RR form you will find that the trail version is not recommended.

  7. #7
    Newbie
    Join Date
    Jul 2005
    Posts
    18
    Quote Originally Posted by Enforcer
    Using the trial version affects it big time, because the splash screen requires user input.

    If you search the phoco threads in the RR form you will find that the trail version is not recommended.
    Thank you for the reply, I had aready written the response when I remembered it was a trial version. Apologies, I do normally search.

    Thanks

    Ant

  8. #8
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,169
    Blog Entries
    53
    I've noticed this too but its not the fault of Phoco or RR. My dongle just doesnt wanna immediately connect. And yes RR waits for phoco to be fully loaded before it launches itself

  9. #9
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    the new version will be more flexible on connecting to Phoco...
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  10. #10
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    Quote Originally Posted by guino
    the new version will be more flexible on connecting to Phoco...
    is it possible to have it act as if it were a normal embeded window, so say if i go to the phone screen, it loads PhoCo then and not at startup and also a close button so i can shut it down if i like without also shutting down RR.

Page 1 of 2 12 LastLast

Similar Threads

  1. Bluetooth phone control
    By 65coupei6 in forum Newbie
    Replies: 2
    Last Post: 08-12-2005, 05:47 PM
  2. long time no see
    By carabuser in forum Off Topic
    Replies: 2
    Last Post: 07-10-2004, 09:55 PM
  3. first time post, long time reader
    By kirk fogg in forum Newbie
    Replies: 3
    Last Post: 02-19-2004, 03:24 PM
  4. Hi all long time no see.....
    By Blop in forum LCD/Display
    Replies: 5
    Last Post: 10-31-2003, 05:15 AM
  5. Replies: 22
    Last Post: 08-13-2001, 02:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •