Page 4 of 5 FirstFirst 12345 LastLast
Results 31 to 40 of 44

Thread: feature request: native gps support

  1. #31
    Maximum Bitrate skippy76's Avatar
    Join Date
    Mar 2004
    Location
    Cambridge, MA, USA
    Posts
    507
    It depends... (regardingthe mappoint port...) In the next version to be released shorlty, the mnappointport will be replaced with gpsport to be less confussing... it will allways be accessable too regardless of the GPS software you are using.
    06 Volvo XC90
    Use to have installed MII 10000/512Mb/40GB, Lilliput 7", OPUS 90W, Wifi-G PCMCIA, Head Unit Aux adapter, Delorme GPS, XM PCR, Audigy NX, RR
    Car PC downloads: http://carpc.harteveldt.com/

  2. #32
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,170
    Blog Entries
    52
    I still cant get this to work in my car. I have xport3 and its working cause all my gps software works with it. I have the indicator "HEADING" on my skin... i have the jpgs in the skin folder. Does xport3 have to be runnin before rr? Right now RR is my shell and it opens a batch file that opens xport3. Here is my .skin.
    Code:
    MEDIACAR Skin
    MEDIACAR menumenu Skin
    menu_off.jpg,menu_off.jpg,menu_on.jpg,menu_down.jpg
    
    /, I, x, y, w, h, Code;INDICATORCODES
    I,6,88,15,15,"ONLINE:B"
    I,17,103,15,15,"PHONE_CONNECTED_PHOCO"
    
    /, B, x, y, w, h, Command;COMMANDCODES, Tooltip
    B,40,80,120,40,"VISU",
    
    /, A, x, y, w, h, color;RGB
    A,270,127,530,405,000
    
    /, F, x, y, w, h, Movie name
    F,0,124,800,420,"main.swf"
    IMG,476,3,133,120,"mclogo.gif"
    
    /, J, x, y, w, h
    J,0,0,0,0
    
    /, I, x, y, w, h, Code;INDICATORCODES
    I,593,538,99,60,"MASTERMUTE"
    
    /, L, x, y, w, h, color R;RGB, G, B, font size;FONT, font name, Code;LABELCODES, Tooltip;LABELALIGNMENT
    L,-8,26,484,46,255,255,255,24,"Century Gothic","TRACKNAME","SCROLL-CENTER"
    L,745,85,48,25,66,155,221,16,"Trebuchet MS","VOLUME","CENTER"
    L,630,85,107,25,166,166,166,16,"Trebuchet MS","DATE","RIGHT"
    
    /, I, x, y, w, h, Code;INDICATORCODES
    I,745,0,50,70,"HEADING"
    
    /, L, x, y, w, h, color R;RGB, G, B, font size;FONT, font name, Code;LABELCODES, Tooltip;LABELALIGNMENT
    L,620,26,114,43,255,255,255,20,"Century Gothic","TIME","CENTER"
    L,0,0,0,0,,,,,,"STATUS",
    L,0,0,0,0,,,,,,"CURRENTTRACKTIME",
    L,0,0,0,0,,,,,,"TRACKTIME",
    L,0,0,0,0,,,,,,"ALBUMART",
    L,0,0,0,0,,,,,,"TRACKNUMBER",
    L,0,0,0,0,,,,,,"CUSTOMFDETA",
    L,0,0,0,0,,,,,,"CUSTOMFDETR",
    L,0,0,0,0,,,,,,"CUSTOMFDNEXTMAN",
    L,0,0,0,0,,,,,,"CUSTOMFDNEXTMANDIST",
    L,0,0,0,0,,,,,,"CUSTOMFDNEXTSTREET",
    L,0,0,0,0,,,,,,"CUSTOMFDHEADDEG",
    L,0,0,0,0,,,,,,"CUSTOMFDROAD",
    L,0,0,0,0,,,,,,"CUSTOMFDSPEED",
    
    /, Y,  Back Slider file path
    Y01,"vslider1\slider_*.gif"
    
    /, S, x, y, w, h, x1, y1, w1, h1, O, Style, Pointer file path, h2, Code;SLIDERCODES, Tooltip
    S01,174,94,267,13,168,91,276,17,H,01,"vslider1\pointer.gif",013,"SONGPOS",
    
    /, I, x, y, w, h, Code;INDICATORCODES
    I,0,0,0,0,"MASTERMUTE"
    
    /, B, x, y, w, h, Command;COMMANDCODES, Tooltip
    B,185,532,106,70,"PREV",
    B,292,533,98,69,"PLAY",
    B,393,534,98,65,"NEXT",
    B,494,533,98,66,"VOL+",
    B,695,533,97,65,"VOL-",
    B,3,546,88,52,"EXIT",
    B,93,547,84,53,"MINIMIZE",
    IDL,60
    
    END
    and here's my .ini

    Code:
    voice=true
    musicpath=C:\Documents and Settings\Shaun Newman\
    videopath=C:\Documents and Settings\Shaun Newman\Desktop\My Movies\
    dvdpath=Internal
    launchpath=C:\Program Files\Road Runner\Launch\
    winamppath=C:\Program Files\Winamp\
    skinpath=C:\Program Files\Road Runner\skins\MC2.0\
    mpcpath=C:\Program Files\Road Runner\mplayerc.exe
    screentype=4:3
    videoautohide=false
    videohidetime=4
    hidemouse=false
    coverfile=*.jpg
    albumart=*.txt
    useid3=3
    showid3playlist=true
    showid3browse=true
    gpsmode=2
    mapmonkeypath=C:\DestinatorApps\Map Monkey\MapMonkey.exe
    gpspath=C:\Documents and Settings\Shaun Newman\Desktop\iGmodPreview3\igmod.exe
    gpsname=--iGmod
    exitmode=4
    showicons=true
    showextensions=false
    titlesafter=-
    listfollowssong=false
    resumemusic=2
    audiorepeat=on
    audioshuffle=on
    gammamode=1
    gammapath=C:\Program Files\Road Runner\Gamma\GammaControl.exe
    dateformat=MM/DD/YYYY
    timeformat=HH:MM AM/PM
    id3listformat=%artist% / %title%
    id3browseformat=%artist% /  %title%  / %genre% / %album%
    mastervolmap=-1
    listnumbers=false
    noformat=false
    hidewinamp=true
    visuname=!Winamp Gen!AVS
    overspeed=80
    scrollmode=1
    builtinvideo=true
    disableinternat=true
    locale=0
    hidetaskbar=false
    hidedesktop=false
    radiomode=0
    radioline=0
    lazytag=false
    allowallfreqs=false
    browsertype=0
    browserpath=C:\Program Files\Mozilla Firefox\firefox.exe
    mapvol=75
    phocopath=C:\Program Files\PhoneControl.NET\PhoneCtl.NET.exe
    phoconodesign=true
    ringtone=C:\WINDOWS\MEDIA\ringin.wav
    standardphonebook=0
    maxcalllistentries=100
    mappointport=11

  3. #33
    Maximum Bitrate skippy76's Avatar
    Join Date
    Mar 2004
    Location
    Cambridge, MA, USA
    Posts
    507
    I think the 'current' version when using an External GPS does not use the internal GPS port. you can try downloading my BETA from: http://carpc.harteveldt.com and make sure you run RRConfig (mappointgpsport has changed to gpsport).

    This will ensure that RR is indeed using a seperate port for GPS data.

    However, I think it's most likely that xport is not starting in time for RR. May I suggest you put xport in the run section of registry?
    06 Volvo XC90
    Use to have installed MII 10000/512Mb/40GB, Lilliput 7", OPUS 90W, Wifi-G PCMCIA, Head Unit Aux adapter, Delorme GPS, XM PCR, Audigy NX, RR
    Car PC downloads: http://carpc.harteveldt.com/

  4. #34
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,170
    Blog Entries
    52
    Quote Originally Posted by skippy76
    However, I think it's most likely that xport is not starting in time for RR. May I suggest you put xport in the run section of registry?
    Does the run section work when explorer isnt the shell? I didnt think it did

  5. #35
    Maximum Bitrate skippy76's Avatar
    Join Date
    Mar 2004
    Location
    Cambridge, MA, USA
    Posts
    507
    that's a very good point, you know I don't know if it does! If I get a chance i'll take a look at the RR code to see what happens if it does not manage to connect to the GPS Port at startup.
    06 Volvo XC90
    Use to have installed MII 10000/512Mb/40GB, Lilliput 7", OPUS 90W, Wifi-G PCMCIA, Head Unit Aux adapter, Delorme GPS, XM PCR, Audigy NX, RR
    Car PC downloads: http://carpc.harteveldt.com/

  6. #36
    Maximum Bitrate skippy76's Avatar
    Join Date
    Mar 2004
    Location
    Cambridge, MA, USA
    Posts
    507
    Ok, just took a look at the code.

    If you are using an External GPS app (e.g. iGmod), then then you'll need to try my BETA version at: http://carpc.harteveldt.com

    If RR cannot connect to the GPS COM port at RR start then it will reattempt to connect to the COM port every second. Basically every second it reads data from the GPS, if it was unable to read data 3 times then it reattempts to connect to the GPS COM Port.
    06 Volvo XC90
    Use to have installed MII 10000/512Mb/40GB, Lilliput 7", OPUS 90W, Wifi-G PCMCIA, Head Unit Aux adapter, Delorme GPS, XM PCR, Audigy NX, RR
    Car PC downloads: http://carpc.harteveldt.com/

  7. #37
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,170
    Blog Entries
    52
    thank you very much! I'll give your beta a run

  8. #38
    Maximum Bitrate skippy76's Avatar
    Join Date
    Mar 2004
    Location
    Cambridge, MA, USA
    Posts
    507
    No probs. There will be a new version of the BETA out later today (hopefully). The BETA 9 should be fine though.
    06 Volvo XC90
    Use to have installed MII 10000/512Mb/40GB, Lilliput 7", OPUS 90W, Wifi-G PCMCIA, Head Unit Aux adapter, Delorme GPS, XM PCR, Audigy NX, RR
    Car PC downloads: http://carpc.harteveldt.com/

  9. #39
    Mo' Programming Mo' Problems
    Auto Apps:loading...
    Sonicxtacy02's Avatar
    Join Date
    Sep 2004
    Location
    Woodbridge, VA
    Posts
    8,170
    Blog Entries
    52
    one thing i've noticed about your beta (unrelated to this thread) is ur version like the last Guino release has the problem with transparent applications. I know that fix is going to be included in Guino's next release but just wanted to let you know i'm having the problem with yours too.

  10. #40
    Maximum Bitrate skippy76's Avatar
    Join Date
    Mar 2004
    Location
    Cambridge, MA, USA
    Posts
    507
    Yeah, that would be because I was not aware of the problem and have not made any code changes to fix it...

    My code is based on the last release that Guino did. Guino is pretty tied up with personal life stuff so I'm not sure if he has the fix or not. Probably bessed PMing him directly about it. If I speak to him I'll mention it too. If he has a fix for it then I can try to include it in this release.
    06 Volvo XC90
    Use to have installed MII 10000/512Mb/40GB, Lilliput 7", OPUS 90W, Wifi-G PCMCIA, Head Unit Aux adapter, Delorme GPS, XM PCR, Audigy NX, RR
    Car PC downloads: http://carpc.harteveldt.com/

Page 4 of 5 FirstFirst 12345 LastLast

Similar Threads

  1. feature request: MM full screen
    By fly_dutchie in forum Road Runner
    Replies: 2
    Last Post: 04-06-2005, 04:02 AM
  2. Feature Request: play song on select
    By badandy in forum Road Runner
    Replies: 5
    Last Post: 04-05-2005, 08:52 PM
  3. Feature Request: Auto Level
    By SJC in forum Media Engine
    Replies: 6
    Last Post: 04-16-2004, 02:09 AM
  4. Feature request
    By MatrixPC in forum MediaCar
    Replies: 3
    Last Post: 11-14-2003, 08:44 AM
  5. ME feature request
    By corsamel in forum ME Archive
    Replies: 1
    Last Post: 11-01-2003, 04:08 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •