Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: send commands to apps not working?

  1. #1
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842

    send commands to apps not working?

    im trying to get RR to launch and app and also send commands (switches) to the app but it dosent seem to be working, when i use any commands RR fails to launch the app and just sits there.

    In the "Skin Commands.txt" file it says
    "Dynamic Commands: set the code of a button to: "RUN;COMMAND+PARAMETERS" will
    make it so clicking this button runs the specified command&parameters in the computer."

    ive tried using the plus symbol and also the "&" symbol but no dice.

    when i use the commands on a windows shortcut they work fine, the full command line is below. Note, this is used only on a windows shortcut. What it does is open Opera with all UI elements turned off, including the file menu


    "C:\Program Files\Opera\Opera.exe" /kioskmode /kiosknormalscreen /nomenu /nopanel

    ive even tried it only using one command but RR still doesnt like my code.

    here is the RR code
    "RUN;C:\playfile.exe|C:\Music.wav||LOAD;opera.skin ;RUN;C:\Program Files\Opera\Opera.exe+/nomenu;Opera"


    anybody have any ideas?

    thanks
    01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
    01101101 01101111 01101011 01100101

    beer replenishment fund
    http://www.mp3car.com/vbulletin/rr-faq/
    mp3car live search

    i have joost invites, just hit me up for one.

  2. #2
    MGD
    MGD is offline
    FLAC
    Auto Apps:loading...
    MGD's Avatar
    Join Date
    Feb 2005
    Location
    Los Angeles
    Posts
    1,756
    I think you still need a Double Pipe in there and get rid of the plus sign.
    Try this command:
    "RUN;C:\playfile.exe|C:\Music.wav||MENU;opera.skin ||RUN;C:\Program Files\Opera\Opera.exe /nomenu;Opera"

  3. #3
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    no dice
    not sure why nothing happens
    01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
    01101101 01101111 01101011 01100101

    beer replenishment fund
    http://www.mp3car.com/vbulletin/forumdisplay.php?f=93
    mp3car live search

    i have joost invites, just hit me up for one.

  4. #4
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    it has something to do with the commands being sent to the app,

    this works
    "RUN;C:\playfile.exe|C:\Music.wav||LOAD;opera.skin ;RUN;C:\Program Files\Opera\Opera.exe;Opera"

    but this dosent work
    "RUN;C:\playfile.exe|C:\Music.wav||LOAD;opera.skin ;RUN;C:\Program Files\Opera\Opera.exe /nomenu;Opera"

    the only difference is the /nomenu
    01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
    01101101 01101111 01101011 01100101

    beer replenishment fund
    http://www.mp3car.com/vbulletin/forumdisplay.php?f=93
    mp3car live search

    i have joost invites, just hit me up for one.

  5. #5
    FLAC Chuck's Avatar
    Join Date
    Sep 2003
    Location
    Ellicott City, MD
    Posts
    1,671
    TRy

    "RUN;C:\playfile.exe|C:\Music.wav||LOAD;opera. skin ;RUN;C:\Program Files\Opera\Opera.exe|nomenu;Opera"
    2001 S10 ZR2

    Chucks Skin - to old

  6. #6
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    pay attention man:

    "RUN;C:\playfile.exe|C:\Music.wav||LOAD;opera.skin ;Opera;C:\Program Files\Opera\Opera.exe|/nomenu;Opera"

    you mixed up the load command and the run command inside of it...
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  7. #7
    FreeDrive Creator CdRsKuLL's Avatar
    Join Date
    Feb 2004
    Location
    Manchester
    Posts
    3,507
    lol consider yourself TOLD..

  8. #8
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    Quote Originally Posted by guino
    pay attention man:

    "RUN;C:\playfile.exe|C:\Music.wav||LOAD;opera.skin ;Opera;C:\Program Files\Opera\Opera.exe|/nomenu;Opera"

    you mixed up the load command and the run command inside of it...

    almost forgott i was even having issues with this. Its late now though, ill check it out in teh morning.
    01101100 01101001 01110001 01110101 01101001 01100100 01011111 01110011
    01101101 01101111 01101011 01100101

    beer replenishment fund
    http://www.mp3car.com/vbulletin/forumdisplay.php?f=93
    mp3car live search

    i have joost invites, just hit me up for one.

  9. #9
    ITL
    ITL is offline
    Maximum Bitrate ITL's Avatar
    Join Date
    Jul 2004
    Location
    Atlanta, GA
    Posts
    631
    Okay, so I'm trying to get Mobile Emulator to run inside of RR, and I was told I need to add this button (and the associated string of commands/parameters):

    B06,3,312,275,78,"RUN;C:\playfile.exe|C:\Music.wav ||LOAD;games.skin;RUN;C:\Program Files\Mobile Impact\me.exe;Mobile Impact",""

    But I'm not sure where this should go. The file to RRSource.zip seems to be down. Can I get a little help?
    CarPC #3: 99% Complete
    Pentium M 1.7Ghz, 1GB DDR2 RAM
    DVD/CD-RW installed in dash below monitor
    OEM LCD relocated for 7" Touchscreen
    Wi-Fi, GPS, PS2 controllers...
    500+ full albums
    4,000+ video games
    music videos, movies, & more!

    old carPC

  10. #10
    Bat
    Bat is offline
    Newbie Bat's Avatar
    Join Date
    Aug 2005
    Location
    Wherever I run out of fuel!
    Posts
    22

    Smile Where?

    Hi,
    From the look of it that's a button command and should go in menu.skin in your skin folder. Always make a copy of your skin and call it something different, and work with the copy. Remember to change RR config to the new skin name! Don't ask me how many times I've forgot that!
    Cheers,
    Gavin.
    Stuff: Via M10K, 60Gb 2.5", Sony slim combo, Travla case, carnetix PSU, Shuttle Express,12" tft!

    Progess: Fitted,Works,Looks kinda ugly!

    Prizes to date: Winner of Most Ghetto, Digital Car meet Oct'05!!

Page 1 of 2 12 LastLast

Similar Threads

  1. OBDII / Elm MPG meter. Almost working but not quite!
    By stevieg in forum Engine Management, OBD-II, Engine Diagnostics, etc.
    Replies: 105
    Last Post: 08-19-2008, 03:24 AM
  2. No voice commands
    By Wadda in forum FreeDrive
    Replies: 1
    Last Post: 10-15-2005, 07:06 AM
  3. help lilliput usb not working!!!
    By pardoe16V in forum LCD/Display
    Replies: 15
    Last Post: 10-14-2005, 03:28 PM
  4. send signal to RCA (not the screen)
    By lazynok in forum LCD/Display
    Replies: 8
    Last Post: 08-11-2003, 11:47 PM
  5. Someone please help 10 hrs wasted working on 4 x 20 Character LCD
    By Martin S. Shepherd in forum LCD/Display
    Replies: 1
    Last Post: 05-31-2001, 10:25 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •