Page 15 of 17 FirstFirst ... 567891011121314151617 LastLast
Results 141 to 150 of 170

Thread: Released: BETA 10

  1. #141
    The Last Good Gremlin GizmoQ's Avatar
    Join Date
    Nov 2004
    Location
    St Louis
    Posts
    2,344

    Master Volume Speed Attenuation

    O.K. what am I doing wrong? I loaded beta 11c, have latest flash, and reran rrconfig before starting RR.

    The following is my RR.ini and I only get expected behavior out of linear change:


    speedatt=true
    speedattmute=true
    speedattunit=mph
    speedattgrad=30
    speedattvola=20
    speedattvolb=100
    speedattspeeda=0
    speedattspeedb=70
    speedattmode=curve
    speedattvolzero=20
    speedattvolgainat50mph=80
    speedattmaxstep=10
    speedattvolzero=20

    When I enable "user vol+gain" or "curved change", 0MPH=0% vol and I reach 100% vol at 25MPH. I want to use the "user vol+gain" just cause I'm lazy and my head unit is awkward to reach right now, but I want 20% vol as min regardless of gain whenever I'm stopped (more is fine if I've increased the gain using the vol up button), but no less than 20% regardless of how much I hit the vol down button.

    I also noticed a small bug in that "speedattvolzero" is created twice in the rr.ini. I tried deleting one but volume behavior did not change.

    Hey TIM, What settings should these be if I want to use gain, have 20% vol when stopped, reach 100% vol around 70MPH, and still be able to tweak the volume up or down with the skin volume buttons?

    Lastly, shouldn't gain allow skin volume controls to work if GPS is not present/detected/locked? I don't seem to get any response out of the skin controls either way, but this would be the desired default, don't you think? .
    HARDWARE: Fujitsu Stylistic ST5111w/WiFi and dock, internal Hitachi 500G HD, external 1TB HD, Sierra Wireless Aircard 550, DVD-RW, BoomzBox HD radio, XM Commander, Delorme GPS, Saitek X-52 Pro joystick, BluSoleil Bluetooth, TPMS, FB, Elm327

  2. #142
    Maximum Bitrate skippy76's Avatar
    Join Date
    Mar 2004
    Location
    Cambridge, MA, USA
    Posts
    507
    MoonShiner: Ok, so if it was initially randomized but you could not change it back that sounds like a bug... I'll add it to my list and resolve it in the next release (Note: There will be no more BETAs on this stuff), Guino will release the software and then I'll do all the bug fixes for the next release.

    GizmoQ: Thanks for the info.

    Regarding the Speedatvolzero, I'll add to my llist of bugs to fix.
    Regarding the User vol+gain, this is Tim's part of the functionality so shall let him responsd.
    Regarding the curved change. I need to do some more testing as the curved functionality was not tested alot.
    06 Volvo XC90
    Use to have installed MII 10000/512Mb/40GB, Lilliput 7", OPUS 90W, Wifi-G PCMCIA, Head Unit Aux adapter, Delorme GPS, XM PCR, Audigy NX, RR
    Car PC downloads: http://carpc.harteveldt.com/

  3. #143
    tim
    tim is offline
    Newbie
    Join Date
    Sep 2005
    Location
    Finland
    Posts
    36
    Quote Originally Posted by GizmoQ
    Hey TIM, What settings should these be if I want to use gain, have 20% vol when stopped, reach 100% vol around 70MPH, and still be able to tweak the volume up or down with the skin volume buttons?
    To get what you like, you should set speedattvolgainat50mph about to 57% and then set volume manually to 20% when stopped. I would also set speedattmaxstep to 1 or even less like 0.5 to changes smooth, but it's up to you how you like it's working.

    This should give ~100% at 70MPH speed, 77% at 50mphand come back to 20% when stopped.

    But if you tweak volume down manually from 100% to 90% when driving 70 mph and then stop, volume will be ~10% when stopped.

    So, there is no way to prevent volume going under or over some level at this moment. I had min and max values there before, but it was not good solution because in real life you don't wan't to keep volume always over some certain level and it was too hard to fix values in ini-file 23 times per day..

    But it's easy to add min and max values if they are really needed, I just drop them off because I though they was not very usefull.

    Quote Originally Posted by GizmoQ
    Lastly, shouldn't gain allow skin volume controls to work if GPS is not present/detected/locked? I don't seem to get any response out of the skin controls either way, but this would be the desired default, don't you think? .
    Sorry but I'm not sure what you exactly mean?

    Volume buttons should work even if gps is not working, but depending your settings volume may go very fast to minimun level if there is no gps data.

    If this is problem, it's possible to change code so that speedvol is working only if gps-data is valid. Hmm, I think that cases where gps is connected directly to RR there is no problems, but if speed is coming outside like from FD we have to add some extra funtionality to get this working. I'm bit busy just now, but I'll try to check this some day.

    tim

  4. #144
    Low Bitrate MoonShiner's Avatar
    Join Date
    Apr 2004
    Location
    Westminster, CA
    Posts
    56
    Skippy,

    Just another bug I noticed with the shufflevideo. With shufflevideo as the default, the audio list and applications list (from the launch directory) are also randomized...

    Just wanted to let you know.

    Keep up the good work!

    Thanks!

  5. #145
    The Last Good Gremlin GizmoQ's Avatar
    Join Date
    Nov 2004
    Location
    St Louis
    Posts
    2,344
    Quote Originally Posted by tim
    To get what you like, you should set speedattvolgainat50mph about to 57% and then set volume manually to 20% when stopped. I would also set speedattmaxstep to 1 or even less like 0.5 to changes smooth, but it's up to you how you like it's working.
    Just updated to above and it did smooth out the transition, but didn't work for increasing vol at 0MPH - STILL 0% and won't change.
    Quote Originally Posted by tim
    So, there is no way to prevent volume going under or over some level at this moment. I had min and max values there before, but it was not good solution because in real life you don't wan't to keep volume always over some certain level

    But it's easy to add min and max values if they are really needed, I just drop them off because I though they was not very usefull.
    Do you actually turn your radio off when stopped at a light or stop sign?? That's what you code does to mine.
    Quote Originally Posted by tim
    and it was too hard to fix values in ini-file 23 times per day..
    ????????
    Sorry but I'm not sure what you exactly mean?
    Quote Originally Posted by tim
    Volume buttons should work even if gps is not working, but depending your settings volume may go very fast to minimun level if there is no gps data.
    If this is problem, it's possible to change code so that speedvol is working only if gps-data is valid. Hmm, I think that cases where gps is connected directly to RR there is no problems, but if speed is coming outside like from FD we have to add some extra funtionality to get this working. I'm bit busy just now, but I'll try to check this some day.
    My GPS is tied directly to RR, tried both ways, still no button control, may be just my systems (Dev and in-car). ATT works O.K. at cruise, vol buttons seem to be recognized but your code takes over in stop and go traffic and its so busy, vol buttons no longer have an effect. I did think I got an increase of volume once at cruise, but as soon as I stopped - back to 0% and no vol button response.

    No need for more code, I'll just stick with linear which works on my system. Maybe I'll replace my volume buttons with vol att and gamma indicators.
    HARDWARE: Fujitsu Stylistic ST5111w/WiFi and dock, internal Hitachi 500G HD, external 1TB HD, Sierra Wireless Aircard 550, DVD-RW, BoomzBox HD radio, XM Commander, Delorme GPS, Saitek X-52 Pro joystick, BluSoleil Bluetooth, TPMS, FB, Elm327

  6. #146
    tim
    tim is offline
    Newbie
    Join Date
    Sep 2005
    Location
    Finland
    Posts
    36
    Quote Originally Posted by GizmoQ
    didn't work for increasing vol at 0MPH - STILL 0% and won't change.
    ...
    Do you actually turn your radio off when stopped at a light or stop sign??
    No I don't and it should not work like you are saying. If you setup vol to 20% when car is stopped (and gps data is valid), it should never go under 20% if you don't change volume manually after that.

    Anyone else have same kind problem with gain mode?

    Well, exactlty are you sure you using "gain" mode at all? Ini-file you posted was "curve" mode enabled?

    Quote Originally Posted by GizmoQ
    speedattmode=curve
    tim

  7. #147
    Maximum Bitrate skippy76's Avatar
    Join Date
    Mar 2004
    Location
    Cambridge, MA, USA
    Posts
    507
    MoonShiner.. . Yeah, guess I did not think it thorugh 100%, should be a relativily easy fix... have added it to my list. I may actaully just add some additional functionality so that you can have random option in the other mdoes too!
    06 Volvo XC90
    Use to have installed MII 10000/512Mb/40GB, Lilliput 7", OPUS 90W, Wifi-G PCMCIA, Head Unit Aux adapter, Delorme GPS, XM PCR, Audigy NX, RR
    Car PC downloads: http://carpc.harteveldt.com/

  8. #148
    Variable Bitrate
    Join Date
    May 2005
    Location
    Germany
    Posts
    325
    Hello,

    hope somebody can help me. Could the settings for GPSVOL be made by a fomula? I need this for following:

    speed -> volume

    0-20 km/h -> 10%
    20-50 km/h -> 15%
    50-80 km/h -> 20%
    80-120 km/h -> 30%
    120 -??? km/h -> 40%

    The volume should smoothly change.

    Thanks a lot
    Ti-ejtsch

  9. #149
    Maximum Bitrate Civic03's Avatar
    Join Date
    Dec 2005
    Posts
    605
    How is testing coming for this? Any major problems? I might test it today.

    PROGRESS 95%[//////////]Complete - Software configurations
    Current Task: Just adding on...
    Needed:wireless keyboard/mouse
    My Carputer Blog
    Car System Site

  10. #150
    Maximum Bitrate Civic03's Avatar
    Join Date
    Dec 2005
    Posts
    605
    I tested your iGuidance beta and I get an error saying it couldn't execute iGuidance.

    PROGRESS 95%[//////////]Complete - Software configurations
    Current Task: Just adding on...
    Needed:wireless keyboard/mouse
    My Carputer Blog
    Car System Site

Similar Threads

  1. Next release (BETA 10) delayed
    By skippy76 in forum Road Runner
    Replies: 7
    Last Post: 11-24-2005, 10:29 PM
  2. MediaEngine Beta 2 Released!
    By phat_bastard in forum Media Engine
    Replies: 13
    Last Post: 09-20-2005, 08:53 AM
  3. FrodoPlayer 1.0.3 Beta Has Been released.
    By frodobaggins in forum FrodoPlayer
    Replies: 0
    Last Post: 04-23-2004, 03:37 PM
  4. beta plug-in update, 2.03 has be released
    By Blackwind in forum Software & Software Development
    Replies: 3
    Last Post: 02-19-2001, 08:15 PM
  5. Blackwind's keypad plugin v2.0 beta released
    By Blackwind in forum Software & Software Development
    Replies: 14
    Last Post: 02-11-2001, 03:54 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •