Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Microphone feedback on XM?

  1. #1
    FLAC arebelspy's Avatar
    Join Date
    Sep 2005
    Location
    San Luis Obispo, CA
    Posts
    1,260

    Microphone feedback on XM?

    When I have my USB microphone selected under control panel> sounds it works fine for recognition, etc. However when I go to XM radio in RR I get a super high pitched squeal.

    The XM goes to the line in on my soundcard, and I'm having RR unmute that line obviously. The Mic is USB.

    When I change the mic in the control panel to be the built in mic line in port (which has nothin plugged in) the XM radio sounds perfect.

    Obviously the mic is causing this high pitched squeal feedback somehow, but it doesn't do it any other time than XM play (mp3s work great, etc), and if the mic is disabled or unplugged XM works great.

    So what's goin on, and how do I fix it?

    -arebelspy
    See my trades here! My For Sale/Trade Thread. Email joe at eipse.com

    Quote Originally Posted by xdjxklusivex
    i think every thread is now a whoreing thread

  2. #2
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    Are you using the Line In Plugin ? or not ?

    I can understand the problem if you DO use the line in plugin, otherwise I have no idea. Maybe you should verify that the Mic is Mute for PLAYBACK.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  3. #3
    FLAC arebelspy's Avatar
    Join Date
    Sep 2005
    Location
    San Luis Obispo, CA
    Posts
    1,260
    Yeah I am using the line in plugin.. i was under the impression that it was required for XM. Is there any way to have XM work without it?

    Where would I check the "Mic is Mute for PLAYBACK." ?

    Thanks for the reply.

    -arebelspy
    See my trades here! My For Sale/Trade Thread. Email joe at eipse.com

    Quote Originally Posted by xdjxklusivex
    i think every thread is now a whoreing thread

  4. #4
    RoadRunner Mastermind
    Auto Apps:loading...
    guino's Avatar
    Join Date
    Nov 2004
    Location
    Toronto, Canada
    Posts
    9,817
    The line in plugin records from the DEFAULT recording source and plays back to the DEFAULT sound card. Basically, if you have the Mic set to record and have the line in installed, you'll be recording from the mic and playing it back and getting it back in the mic, and it will do what you're saying. You need to either stop using the line in plugin (and leave the sound card play the line in directly -- this depends on your sound card, it may not be possible for you), or make sure the Line IN is set as your record line -- this will prevent you from using the microphone for recording. Sorry but seems you're stuck...

    Those options are all controlled SOLELY by the windows mixer: Start->Programs->Accessories->Entertainment->Volume control. There are settings for Playback and for Recording -- you need to check them out and make sure you understand how they work. Sorry I don't have the time to explain it more than that.
    Ride Runner RR's Myspace

    "Being happy is not about having what you want, it's about wanting what you have."
    "The best things in life are always free - but that doesn't mean money can't buy you good things."

  5. #5
    FLAC arebelspy's Avatar
    Join Date
    Sep 2005
    Location
    San Luis Obispo, CA
    Posts
    1,260
    Sounds like a problem with the linein plugin. No need to go into more detail on the advanced sound stuff - I got that all fine. If I unmute my linein plugin in windows it plays the xm radio just fine.. it's only when RR plays it that the high pitched squeal is added, so it must be that line in plugin that for some reason is mixing both the USB mic (being selected as the hardware in audio properties in control panel) and the line in that the xm is coming in to as well..

    So no one out there runs both a mic and XM?

    -arebelspy
    See my trades here! My For Sale/Trade Thread. Email joe at eipse.com

    Quote Originally Posted by xdjxklusivex
    i think every thread is now a whoreing thread

  6. #6
    My Village Called 0l33l's Avatar
    Join Date
    Jul 2004
    Location
    Berkeley, CA
    Posts
    10,516
    Search for AutoMute. I made that little program to mute microphone input automatically

  7. #7
    My Village Called 0l33l's Avatar
    Join Date
    Jul 2004
    Location
    Berkeley, CA
    Posts
    10,516
    AutoMute

    Oh yeh... the mute on the mic merely means that the microphone will not be broadcast through the speakers. It will not affect SAPI

  8. #8
    FLAC arebelspy's Avatar
    Join Date
    Sep 2005
    Location
    San Luis Obispo, CA
    Posts
    1,260
    Oh sick, that's perfect, cause i was actually wanting the mic on to use with NaviVoice. You're a champ boris

    Trying to figure out the frodocomm stuff and automute now...

    -arebelspy
    See my trades here! My For Sale/Trade Thread. Email joe at eipse.com

    Quote Originally Posted by xdjxklusivex
    i think every thread is now a whoreing thread

  9. #9
    My Village Called 0l33l's Avatar
    Join Date
    Jul 2004
    Location
    Berkeley, CA
    Posts
    10,516
    Install Frodocomm. Set the service launcher to launch automatically at startup.

    Enjoy

  10. #10
    FLAC arebelspy's Avatar
    Join Date
    Sep 2005
    Location
    San Luis Obispo, CA
    Posts
    1,260
    Do I need to set both automute and frodo service launcher to go at startup or just the service launcher and that controls automute?

    -arebelspy
    See my trades here! My For Sale/Trade Thread. Email joe at eipse.com

    Quote Originally Posted by xdjxklusivex
    i think every thread is now a whoreing thread

Page 1 of 2 12 LastLast

Similar Threads

  1. Possible to split XM Direct cable to computer and XM commander?
    By Jemmi in forum General Hardware Discussion
    Replies: 3
    Last Post: 12-14-2005, 03:07 PM
  2. Pre-Release Thread: Frodo XM Service
    By frodobaggins in forum Software & Software Development
    Replies: 10
    Last Post: 08-04-2005, 05:10 PM
  3. Line Feedback
    By 2k5f150 in forum Car Audio
    Replies: 5
    Last Post: 06-09-2005, 09:34 AM
  4. XM Direct digital adapter or XM PC cable with SkyFi2???
    By LATEOTT in forum Hardware Development
    Replies: 0
    Last Post: 01-19-2005, 03:18 PM
  5. Using an XM direct as an XMPCR
    By dacndar in forum General Hardware Discussion
    Replies: 20
    Last Post: 10-17-2004, 02:21 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •